We need your help!
Operating the Pale Moon servers, sites, domains, and getting certificates, code signing and more isn't free (or cheap).
Unfortunately there has been a pretty sharp downward trend in what DuckDuckGo's search partnership provides to the project, so now more than ever, we rely heavily on your generous contributions and donations.

If you find Pale Moon in any way useful, please consider one or more of the following options to help out:
  1. Donating to the project directly through PayPal or Ko-fi.
  2. Purchasing challenge coins.
  3. Setting your search engine to the included DuckDuckGo and disabling your ad blocker on the DuckDuckGo domain (so they can show sponsored results).

Doing so will go a long way to make sure we can stay afloat and independent! In addition, Moonchild would still like to pay rent and eat ;)

Foscam IPCWebcomponents plugin not working Topic is solved

Board for discussions around the Basilisk web browser.

Moderator: Basilisk-Dev

User avatar
Rob190
New to the forum
New to the forum
Posts: 2
Joined: 2023-11-17, 17:47

Foscam IPCWebcomponents plugin not working

Unread post by Rob190 » 2023-11-17, 18:01

Hi,
I have some old Foscam security cameras that use NPAPI plugins. They work with Edge in legacy IE mode. I was told Basilisk was one of the few browsers that still supports NPAPI. I've re-installed the IPCWebcomponents plugin but Basilisk doesn't appear to recognize it. Is there something else I need to do to enable it?

Rob

User avatar
Kris_88
Keeps coming back
Keeps coming back
Posts: 782
Joined: 2021-01-26, 11:18

Re: Foscam IPCWebcomponents plugin not working

Unread post by Kris_88 » 2023-11-17, 18:26

32 bit or 64 bit browser?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 34903
Joined: 2011-08-28, 17:27
Location: Motala, SE
Contact:

Re: Foscam IPCWebcomponents plugin not working

Unread post by Moonchild » 2023-11-17, 19:35

Note that IE does not use NPAPI, so you may want to double-check that the NPAPI components are installed.
And as Kris pointed out: architecture matters. you will need the plugin that matches your bit-ness of the browser.
"Sometimes, the best way to get what you want is to be a good person." -- Louis Rossmann
"Seek wisdom, not knowledge. Knowledge is of the past; wisdom is of the future." -- Native American proverb
"Linux makes everything difficult." -- Lyceus Anubite

User avatar
Rob190
New to the forum
New to the forum
Posts: 2
Joined: 2023-11-17, 17:47

Re: Foscam IPCWebcomponents plugin not working

Unread post by Rob190 » 2023-11-19, 13:34

Thanks! Yes I'd installed the x64 version. I know next-to-nothing about the way browser plugins work but it seems this one is just a dll so yes, it would have to match the app.

I was using Edge but MS have broken the IE compatibility mode in the latest release making it impossible to change some of the camera settings. So a big thank-you for keeping NPAPI support :-)

Rob

Post Reply