VP9 video playback is stuttering

The place to report Pale Moon specific bugs on Linux and other operating systems.

Moderator: satrow

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

VP9 video playback is stuttering

Unread post by chaldon » 2018-12-06, 19:42

The problem is present since v28.2.0, at least with the official 64-bit tarball on Debian stable. When playing any HD video on YouTube the video is stuttering/dropping frames. In the terminal I see the lines appearing:

Code: Select all

[vp9 @ 0x7fe369539000] The deprecated avcodec_decode_* API cannot return all the frames for this decoder. Some frames will be dropped. Update your code to the new decoding API to fix this.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3976
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: VP9 video playback is stuttering

Unread post by Night Wing » 2018-12-06, 22:57

I don't experience any stuttering/dropping frames when watching YouTube videos in HD, mostly 720p which is what I usually watch HD videos in YouTube. But I'm not using Debian Stable and I'm also not using the older version of Pale Moon 28.2.0 either.

I'm using 64 bit linux Pale Moon 28.2.2 running in 64 bit linux Mint 19 (Tara) Xfce. Have you tried version (28.2.2)?
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

Re: VP9 video playback is stuttering

Unread post by chaldon » 2018-12-07, 17:07

Yes, the problem is still present in v28.2.2. I've found out more details: the problem is not present on my old netbook PC with the integrated Intel graphics card, while my main PC, which has the problem, has the modern AMD Baffin (Polaris11) based card. I guess VP9 decoder tries to use some kind of hardware acceleration but can't do it correctly for some reason (may be libavcodec used to build Pale Moon is too old?). The problem is present only in Pale Moon - Firefox and Waterfox, for example, run HD videos smoothly.

Update: Steven Pusser's build has this problem as well.
Last edited by chaldon on 2018-12-07, 17:20, edited 3 times in total.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3976
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: VP9 video playback is stuttering

Unread post by Night Wing » 2018-12-07, 19:06

You're using Debian and I'm using Mint. I'm guessing your linux Pale Moon is installed and my linux Pale Moon is "not" installed. And also, I do not use Steven Pusser's builds. I get my 64 bit linux Pale Moon tarball directly from the Pale Moon home page site at the link below.

http://linux.palemoon.org/download/mainline/
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

Re: VP9 video playback is stuttering

Unread post by chaldon » 2018-12-08, 10:26

I'm also using the tarball. Just unpacked it into ~/bin and run. Steven Pusser's builds did not work for me for quite some time requiring "Mozilla runtime" at start so it's about half a year as I don't use them.

I'm going to try to build Pale Moon from the source code, although I'm not sure if I'll succeed. But it's worth a try.
Last edited by chaldon on 2018-12-08, 10:29, edited 2 times in total.

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

Re: VP9 video playback is stuttering

Unread post by chaldon » 2018-12-09, 14:25

Succeeded in building v28.2.2 from the source but alas, the issue is still there. Playback is jerky and there are the same messages in the terminal:

Code: Select all

[vp9 @ 0x7f06bc559800] The deprecated avcodec_decode_* API cannot return all the frames for this decoder. Some frames will be dropped. Update your code to the new decoding API to fix this.
[vp9 @ 0x7f06bb13a800] The deprecated avcodec_decode_* API cannot return all the frames for this decoder. Some frames will be dropped. Update your code to the new decoding API to fix this.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1562
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: VP9 video playback is stuttering

Unread post by trava90 » 2018-12-12, 00:27

VP9 playback has been smooth on my systems; I've been unable to reproduce any stuttering. Just curious, can you reproduce the problem with Pale Moon 28.1.0?

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

Re: VP9 video playback is stuttering

Unread post by chaldon » 2018-12-14, 19:51

trava90 wrote:VP9 playback has been smooth on my systems; I've been unable to reproduce any stuttering. Just curious, can you reproduce the problem with Pale Moon 28.1.0?
No no, it's all fine and smooth in 28.1.0. I've mentioned in the first post that the problem first appeared in the v28.2.0.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1562
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: VP9 video playback is stuttering

Unread post by trava90 » 2018-12-14, 20:02

In about:config, can you temporarily flip the pref "media.ffvpx.enabled" to false and see if VP9 continues to stutter?

User avatar
chaldon
Newbie
Newbie
Posts: 6
Joined: 2018-12-06, 19:33

Re: VP9 video playback is stuttering

Unread post by chaldon » 2018-12-18, 11:58

trava90 wrote:In about:config, can you temporarily flip the pref "media.ffvpx.enabled" to false and see if VP9 continues to stutter?
It's worked! It's all playing smoothly now. Thank you a lot. And merry Christmas!
Last edited by chaldon on 2018-12-18, 12:06, edited 1 time in total.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 5889
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: VP9 video playback is stuttering

Unread post by New Tobin Paradigm » 2018-12-18, 12:09

Off-topic:
Glad we have preferences for these things

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1562
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: VP9 video playback is stuttering

Unread post by trava90 » 2018-12-18, 12:55

Looks like updating to the latest version of ffvpx may have introduced a performance regression then. I'll look into it.

roytam1
Fanatic
Fanatic
Posts: 160
Joined: 2015-03-11, 07:01
Location: Hong Kong

Re: VP9 video playback is stuttering

Unread post by roytam1 » 2018-12-18, 13:43

trava90 wrote:Looks like updating to the latest version of ffvpx may have introduced a performance regression then. I'll look into it.
there is a discussion in #ffmpeg-devel http://mplayerhq.hu/pipermail/ffmpeg-de ... 05443.html

also: https://bugzilla.mozilla.org/show_bug.cgi?id=1487792
Last edited by roytam1 on 2018-12-18, 13:49, edited 2 times in total.


User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24468
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: VP9 video playback is stuttering

Unread post by Moonchild » 2018-12-29, 20:56

New unstable versions have been created with patches for this issue; it would be great if people who reported these issues can give the unstable version a try and let us know if the performance issues have been solved.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
badnick
Lunatic
Lunatic
Posts: 395
Joined: 2017-03-23, 19:56

Re: VP9 video playback is stuttering

Unread post by badnick » 2018-12-30, 08:11

It seems that the problem is solved at least for me with te latest unstable version.
Windows 10 /64 (version 1809)
PM last/64

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1562
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: VP9 video playback is stuttering

Unread post by trava90 » 2018-12-30, 15:22

Thanks for testing badnick.

New Linux unstable is now available as well. @chaldon, can you please see if the problem persists in the unstable build?

User avatar
badnick
Lunatic
Lunatic
Posts: 395
Joined: 2017-03-23, 19:56

Re: VP9 video playback is stuttering

Unread post by badnick » 2018-12-30, 17:37

trava90 wrote:Thanks for testing badnick.
Nop.

The best way to see if there is any little stuttering is to watch videos where objects or image is moving with a constant speed, e.g: https://www.youtube.com/watch?v=HSsqzzuGTPo
Windows 10 /64 (version 1809)
PM last/64

Locked