Zooming in/out doesn't change svg size Topic is solved

The place to report Pale Moon specific bugs on Linux and other operating systems.

Moderator: satrow

wolf_
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Tue, 22 Sep 2015, 10:55
Location: Prague

Zooming in/out doesn't change svg size

Unread postby wolf_ » Mon, 11 Dec 2017, 12:23

Zooming seems to ignore svg images. Here is url I found it on: https://data.wolfsden.cz/stroke_order/genki.html . When you zoom in/out (CTRL + mouse wheel) only size of the letter on the left changes, the svg image on the right remains the same size.

I'm using pentadactyl but don't think it's relevant for this particular issue.

Moonchild Productions Pale Moon 27.6.2

Linux ws 4.14.4-1-ARCH #1 SMP PREEMPT Tue Dec 5 19:10:06 UTC 2017 x86_64 GNU/Linux

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 460
Joined: Sun, 24 Sep 2017, 16:35

Re: Zooming in/out doesn't change svg size

Unread postby SpockFan02 » Wed, 13 Dec 2017, 05:13

It works for me.

Pale Moon 27.6.2 (64-bit), with and without Imagus

MacOS 10.12.6

wolf_
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Tue, 22 Sep 2015, 10:55
Location: Prague

Re: Zooming in/out doesn't change svg size

Unread postby wolf_ » Wed, 13 Dec 2017, 08:40

Possibly linux exclusive bug then?

Anyway I've made some screenshots: https://imgur.com/a/kvI2e ; one for 100% zoom (default), one for max zoomed out (the bug) and one of max zoomed out chromium for comparison (expected behaviour).

EDIT: I've disabled pentadactyl for this so it's not the one causing it.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22407
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Zooming in/out doesn't change svg size  Topic is solved

Unread postby Moonchild » Wed, 13 Dec 2017, 19:26

check about:config -> browser.zoom.full
If it's set to "false" it will only zoom text. "true" will zoom text and images. If you didn't change this yourself, on of your extensions may have changed it.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

vingtzwanzig
Moonbather
Moonbather
Posts: 73
Joined: Thu, 20 Apr 2017, 21:25
Contact:

Re: Zooming in/out doesn't change svg size

Unread postby vingtzwanzig » Wed, 13 Dec 2017, 20:20

I tried this out of interest, and for me on Linux i686, the letters on the left stay the same, but the images on the right zoom with CTRL -_ += normally. When I first looked at the linked page a couple of days ago the letters on the left were smaller than they are now. They are now so big they are slightly blurred and out of focus, and if I shrink the images down the letters overlap and get jumbled together. They are actual font letters, the pointer turns to a cursor over them, and is an arrow over the brush stroke diagrams on the right. Perhaps they are treated like some sort of margin? I also searched and found some other svg image examples and could zoom those normally too. Font display can sometimes be affected by what font packages are installed too.
browser.zoom.full; true

wolf_
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Tue, 22 Sep 2015, 10:55
Location: Prague

Re: Zooming in/out doesn't change svg size

Unread postby wolf_ » Wed, 13 Dec 2017, 20:50

Moonchild wrote:check about:config -> browser.zoom.full
If it's set to "false" it will only zoom text. "true" will zoom text and images. If you didn't change this yourself, on of your extensions may have changed it.


Yep that was it. Interesting, don't remember setting it and only extensions I use are pentadactyl and ublock. Will see if it comes back to false.

For now thank you so much for the advice :)

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 840
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

Re: Zooming in/out doesn't change svg size

Unread postby gracious1 » Thu, 14 Dec 2017, 22:57

Moonchild wrote:check about:config -> browser.zoom.full
If it's set to "false" it will only zoom text. "true" will zoom text and images. If you didn't change this yourself, on of your extensions may have changed it.

wolf_ wrote:Yep that was it. Interesting, don't remember setting it….


You may have accidentally set it in the menu, like so:
Zoom Text Only.png
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone


Return to “Bug reports (Linux & other)”

Who is online

Users browsing this forum: No registered users and 2 guests