PM 27 for Linux doesn't run on Ubuntu Precise, Debian Wheezy.

This board is for discussions, bug reports, etc. for pre-releases of the v27 milestone codenamed "Tycho".

Since the beta phase is over, this board is closed for new posts/topics.

Moderator: satrow

cowlitzron

PM 27 for Linux doesn't run on Ubuntu Precise, Debian Wheezy.

Unread postby cowlitzron » Tue, 15 Nov 2016, 19:33

Pale Moon 27 for Linux doesn't run on Ubuntu 12.04 Precise and Debian 7 Wheezy due to the requirement that glibc has to be 2.17 or newer. The distribution versions mentioned use older versions of glibc. Other supported major distro versions which don't run PM 27 include Linux Mint 13 maya, RHEL/CentOS 5.x and 6.x, and Slackware 13.0, 13.1, 13.37, and 14.0. All the distro versions listed except for RHEL/CentOS 5.x, and Slackware 13.0, and 13.1 will run Pale Moon 26.5.x . Users who are running the listed distro versions which run PM 26.5.x will need to either stay with that version or ubgrade the operating system to a newer version which will run PM 27. The drop of support for some older versions of distros is okay with me since I use Ubuntu 16.04 Xenial as my main distro base. I do have Ubuntu 12.04 Precise on a USB hard drive for testing purposes.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22118
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: PM 27 for Linux doesn't run on Ubuntu Precise, Debian Wheezy.

Unread postby Moonchild » Tue, 15 Nov 2016, 20:02

Thanks for the listing. Unfortunately we can't support all distributions and especially old versions with our generic binaries -- it would require significant compromise to do so.
You may, however, be able to build from source to target these older OS versions.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Image

User avatar
Aube Bleue
Apollo supporter
Apollo supporter
Posts: 44
Joined: Fri, 13 Nov 2015, 03:36
Location: Québec

Re: PM 27 for Linux doesn't run on Ubuntu Precise, Debian Wheezy.

Unread postby Aube Bleue » Wed, 16 Nov 2016, 01:05

cowlitzron wrote:Pale Moon 27 for Linux doesn't run on Ubuntu 12.04 Precise and Debian 7 Wheezy due to the requirement that glibc has to be 2.17 or newer.

Incorrect: ALL alpha/beta 32-bit binaries produced by Travis have been running smoothly on my old 32-bit Toshiba laptop. Maybe that'll change once Tycho becomes official… Anyway, I'll definitely ubgrade upgrade ;-p this laptop in the coming months. The OS installed on it is Bodhi Linux 2 -- which is based on Ubuntu 12.04 LTS (Precise) -- and has glibc version 2.15.
Linux 64-bit and 32-bit user.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1503
Joined: Mon, 20 May 2013, 18:19
Location: Earth
Contact:

Re: PM 27 for Linux doesn't run on Ubuntu Precise, Debian Wheezy.

Unread postby trava90 » Wed, 16 Nov 2016, 06:33

Aube Bleue wrote:Incorrect: ALL alpha/beta 32-bit binaries produced by Travis have been running smoothly on my old 32-bit Toshiba laptop. Maybe that'll change once Tycho becomes official… Anyway, I'll definitely ubgrade upgrade ;-p this laptop in the coming months. The OS installed on it is Bodhi Linux 2 -- which is based on Ubuntu 12.04 LTS (Precise) -- and has glibc version 2.15.

Correct, 32 bit builds of v27 will still work on older distros for now (this will change in the future).

Also, for the record most of the distros mentioned in this thread are nearing EOL anyway. In general, our generic binaries are not going to target older, no longer supported distros. But as Moonchild stated, there should be nothing stopping you from compiling Pale Moon yourself on these distros if you need to.


Return to “Pale Moon "Tycho" alpha/beta”

Who is online

Users browsing this forum: No registered users and 2 guests