Various video playback issues with Pale Moon v27

This board is for discussions, bug reports, etc. for pre-releases of the v27 milestone codenamed "Tycho".

Since the beta phase is over, this board is closed for new posts/topics.

Moderator: satrow

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Various video playback issues with Pale Moon v27

Unread postby Tomaso » Wed, 19 Oct 2016, 14:31

Been using PM27 beta2 for a while now, and I can confirm that there indeed are some video playback issues.

1) At YouTube, when using Flash player, I'll run into problems sometimes.
First, the player controls will disappear, then the videos simply stop (the picture freezes).
Seems to happen mostly when playing videos in a small window.
I think I've been able to prevent it from happening a few times, simply by keeping the player controls visible all the time.

2) At VGTV.no:
http://www.vgtv.no/
Often, the progress wheel just spins, and the videos won't play at all.
If I get them to play, they'll just stop after a few seconds of playback.

3) At Dagbladet.no:
http://www.dagbladet.no/video/
Nothing.
The video windows simply shows up as black screens.
On some rare occasions, the videos actually plays, although I've got no idea why.
The problem at this site isn't limited to PM v27 though, as v26 suffers from the same problem!

User avatar
megaman
Moon Magic practitioner
Moon Magic practitioner
Posts: 2874
Joined: Tue, 30 Aug 2011, 16:40
Location: H-town

Re: Various video playback issues with Pale Moon v27

Unread postby megaman » Wed, 19 Oct 2016, 14:40

Tomaso wrote:Been using PM27 beta2 for a while now, and I can confirm that there indeed are some video playback issues.

I can't try 1 since I refuse to use FLASH, that thing chokes even my high-end desktop over time if I don't restart my browser after using anything with FLASH.
I tried the bottom 2 sites and the videos play. (I'll look for a video that is longer than a minute, tried the one video about someone knocking over TV displays)

Edit: Dagbladet is giving me the black screen with FLASH, tried it, confirmed.
Curiosity leads to a world of experiments.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 20 Oct 2016, 13:28

How about videos @ USA Today:
http://www.usatoday.com/media/latest/videos/news/
Can anyone get them to play?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22158
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Various video playback issues with Pale Moon v27

Unread postby Moonchild » Thu, 20 Oct 2016, 13:33

Tomaso wrote:How about videos @ USA Today:
http://www.usatoday.com/media/latest/videos/news/
Can anyone get them to play?


Code: Select all

Error: NotSupportedError: Operation is not supported
Source File: http://players.brightcove.net/29906170001/rJmr0Xc9_default/index.min.js
Line: 13


not sure what they are trying to do but it's obviously an operation that is not supported. The ads before the actual video play just fine though.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Terryphi
Fanatic
Fanatic
Posts: 162
Joined: Wed, 26 Aug 2015, 06:32
Location: Wales, UK

Re: Various video playback issues with Pale Moon v27

Unread postby Terryphi » Thu, 20 Oct 2016, 13:39

Tomaso wrote:How about videos @ USA Today:
http://www.usatoday.com/media/latest/videos/news/
Can anyone get them to play?

Not in PM 27b2 or FF or Chromium. Presumably not a PM issue.
Linux Mint 19.0 64bit MATE. Latest builds of Pale Moon and Basilisk.

someperson

Re: Various video playback issues with Pale Moon v27

Unread postby someperson » Mon, 24 Oct 2016, 15:11

My dad complained to me the other day about videos on time.com not working. Here's an example:
http://players.brightcove.net/293884104 ... 8873478001

Something in the code here is throwing a NotSupportedError, though I can't really tell what due to minification. Interestingly, this video works if I disable MSE.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 27 Oct 2016, 14:12

YouTube videos seems to play just fine with Flash now, using PM v27.0.0b3.
Embeded videos @ dagbladet.no/video works too!

However, playing videos at vgtv.no is still extremely problematic..
They skip, repeat themselves every other seconds and stops!

Also, videos at usatoday.com/media/latest/videos/news/, and the one posted above by someperson, still won't play at all!

--

EDIT:
Scratch what I said about YouTube videos.
They still stop unexpectedly. :(

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22158
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Various video playback issues with Pale Moon v27

Unread postby Moonchild » Thu, 27 Oct 2016, 15:46

I've sent a message to brightcove seeing if I can get in touch with someone in charge of their player implementation there. It seems they do UA sniffing + some bad assumptions of clients as a result, and feeding us Apple-specific formats instead of what they should fall back to when they detect MSE but not exactly the implementation they want (which is only provided by Chrome and Firefox 44+). This is a serious bug in their player implementation, as their feature support waterfall is broken. Disabling MSE in the browser is a workaround, but that will limit youtube's features to what is present in Pale Moon 26. Other media delivery networks do it correctly; it's just brightcove that doesn't. Unfortunately it's the CDN of choice for media for a lot of American news sites, so we do need a solution.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 27 Oct 2016, 16:15

Moonchild wrote:Disabling MSE in the browser is a workaround

Disabling MSE fixed the playback issues for both brightcove and vgtv.no.
It didn't make any difference for USA Today though.
Don't know about YouTube videos yet, but I'll report back when I know.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 27 Oct 2016, 18:44

I've played a bunch of videos now, and indeed, disabling MSE also takes care of the YouTube issue!
It would probably be a good idea to keep MSE disabled by default in v27 stable, unless of course, you figure out another way to get around the current issues.

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 27 Oct 2016, 20:45

Dang!
I just encountered the issue at YouTube again, with MSE disabled. :(
Oh well, at least it doesn't occur nearly as often as it did with the previous beta.

wolfrun
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: Sun, 16 Mar 2014, 21:15
Location: Canada

Re: Various video playback issues with Pale Moon v27

Unread postby wolfrun » Fri, 28 Oct 2016, 20:38

Since my post is about video issues I'll post here. The only issue I have with V7 (I'm using the portable version win 7 64 bit) is that when watching a video and expand it to full screen, it plays rather jerky in HTML5 format. In Chrome and FF the same videos are smooth playing in full screen mode in HTLM5 format. Examples are here http://vidtodo.com/l06h8vrvxpcv and here http://www.vikings.com/media-vault/vide ... 0b147077fd Also I tried this test http://html5test.com/index.html and how it compares to other browsers http://html5test.com/results/desktop.html Other than what I have previously mentioned, everything else is running good so far with uBlock0 and NoScript addons.

User avatar
megaman
Moon Magic practitioner
Moon Magic practitioner
Posts: 2874
Joined: Tue, 30 Aug 2011, 16:40
Location: H-town

Re: Various video playback issues with Pale Moon v27

Unread postby megaman » Fri, 28 Oct 2016, 20:48

Off-topic:
wolfrun wrote:Since my post is about video issues I'll post here. The only issue I have with V7 (I'm using the portable version win 7 64 bit) is that when watching a video and expand it to full screen, it plays rather jerky in HTML5 format.

Please don't share links to pirated/streaming content that is illegal. Vidtodo violates copyright.
Also, our topics may be general to the title but not relating to the description, so it should be in another topic.

I do have the "jerky" HTML5 problem on YouTube videos, so I figured it was YouTube at it again, but from your experience, it seems to be the browser.
I'm under the unzipped portable 32-bit, so it appears to affect both.
Curiosity leads to a world of experiments.

wolfrun
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: Sun, 16 Mar 2014, 21:15
Location: Canada

Re: Various video playback issues with Pale Moon v27

Unread postby wolfrun » Sat, 29 Oct 2016, 00:28

Please don't share links to pirated/streaming content that is illegal. Vidtodo violates copyright.

Point taken. Maybe this url can replace the one that is forbotten. https://www.nhl.com/blackhawks/video/le ... c-45638303 Same problem in HTML5, when video is enlarged, it plays jerky and choppy. By the way that above video the Vikings on Vidtodo is being played as reruns on regular TV here on the History Channel. Also on my above post if edits were allowed I would have deleted that Vidtodo url.

User avatar
__NM64__
Fanatic
Fanatic
Posts: 238
Joined: Thu, 17 Oct 2013, 05:29
Location: Northeast Ohio

Re: Various video playback issues with Pale Moon v27

Unread postby __NM64__ » Sat, 29 Oct 2016, 04:13

Moonchild wrote:Disabling MSE in the browser is a workaround, but that will limit youtube's features to what is present in Pale Moon 26.

You could always leave MSE for WebM enabled but have MSE for MP4 disabled.

wolfrun wrote:Since my post is about video issues I'll post here. The only issue I have with V7 (I'm using the portable version win 7 64 bit) is that when watching a video and expand it to full screen, it plays rather jerky in HTML5 format. In Chrome and FF the same videos are smooth playing in full screen mode in HTLM5 format.


This may seem like a strange question, but does this stutter issue occur in Firefox 34? If so, does it not occur in Firefox 35?

For reference and testing purposes, here are links to portable versions of Firefox 34 and 35:

Firefox 34.0.5: https://sourceforge.net/projects/portab ... %2034.0.5/

Firefox 35.0: https://sourceforge.net/projects/portab ... on%2035.0/

win7-7
Fanatic
Fanatic
Posts: 161
Joined: Mon, 16 Sep 2013, 15:18
Location: --

Re: Various video playback issues with Pale Moon v27

Unread postby win7-7 » Sat, 29 Oct 2016, 15:51

http://www.vgtv.no/

works quite well by quick testing in Firefox 42.

example bad build of Mozilla Central is 30.7.2015

first good build of Mozilla Central is 31.7.2015

https://hg.mozilla.org/mozilla-central/ ... 53d4297f02

However these changes depend from meta bug

https://bugzilla.mozilla.org/show_bug.cgi?id=1171379

wolfrun
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: Sun, 16 Mar 2014, 21:15
Location: Canada

Re: Various video playback issues with Pale Moon v27

Unread postby wolfrun » Sat, 29 Oct 2016, 16:32

This may seem like a strange question, but does this stutter issue occur in Firefox 34? If so, does it not occur in Firefox 35?

No stutter in the latest Firefox build or the latest Google Chrome build. Stuttering or jerkiness happens in Palemoon V27 on my system, when video is enlarged.

User avatar
__NM64__
Fanatic
Fanatic
Posts: 238
Joined: Thu, 17 Oct 2013, 05:29
Location: Northeast Ohio

Re: Various video playback issues with Pale Moon v27

Unread postby __NM64__ » Sat, 29 Oct 2016, 21:12

wolfrun wrote:No stutter in the latest Firefox build or the latest Google Chrome build. Stuttering or jerkiness happens in Palemoon V27 on my system, when video is enlarged.

But what about Firefox v34 and Firefox v35?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22158
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Various video playback issues with Pale Moon v27

Unread postby Moonchild » Thu, 10 Nov 2016, 09:03

So far no response from brightcove, at all. The only result that happened from me contacting them is that they started sending me automated marketing mails. :thumbdown: :evil:

Somehow I'm not surprised.

I think I'll put a temporary workaround in place identifying as Mobile to them, until we can get a better solution.
Specific useragent suggestions would be welcome for that.

EDIT: Using an MSIE useragent for players.brightcove.net seems to work without degrading quality too much (aljazeera works, vgtv.no works in both flash and html5 mode)
USA Today still doesn't work. I've written to the news site directly now to see if I can get some way of moving forward with this.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Tomaso
Keeps coming back
Keeps coming back
Posts: 987
Joined: Thu, 23 Jul 2015, 16:09
Location: Norway

Re: Various video playback issues with Pale Moon v27

Unread postby Tomaso » Thu, 10 Nov 2016, 20:58

Actually, I just checked again, and videos at dagbladet.no, usatoday.com and vgtv.no all seems to play just fine now, using PM v27.0.0b3,x64 Portable!
I wonder why.


Return to “Pale Moon "Tycho" alpha/beta”

Who is online

Users browsing this forum: No registered users and 1 guest