PM looses every time the sync settings

Anything to do with the Pale Moon Sync service.

Moderator: satrow

pandur
Newbie
Newbie
Posts: 3
Joined: Mon Sep 28, 2015 8:23 pm
Location: here

PM looses every time the sync settings

Postby pandur » Thu Oct 01, 2015 9:19 pm

Hi,

I am running PM on Android, Linux and Win7 and its working fine so far :thumbup: . On Linux (32) or Win7 (64) PM is missing the sync server settings. So I have to sing in every time.
I wonder why I can't find any thread in this forum or with Google covering this problem? Does any one has the same problem and maybe solved it?
Could anyone give me a hint what I am doing wrong?

EDIT:
Installed version: 25.7.2 (x64)
Every time I start PM the problem is the same (on Linux and Windows, not on Android):
    * I start PM and press the sync icon - usually it starts syncing
    * the sync setup window will be displayed
    * I fill in the login details of my existing account and it starts syncing
    * little test: press the sync icon and it starts syncing
    * close PM and start it again
    => sync settings are missing
Cheers

pandur
Newbie
Newbie
Posts: 3
Joined: Mon Sep 28, 2015 8:23 pm
Location: here

Re: PM looses every time the sync settings

Postby pandur » Fri Oct 16, 2015 10:01 am

No suggestions? No common problem. I am alone with it on three different devices and operating systems? :)
What additional information is needed?
As I can see I am using the PM sync server and not the mozilla one.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20075
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: PM looses every time the sync settings

Postby Moonchild » Fri Oct 16, 2015 10:45 am

I don't think anyone has encountered your specific issue. Since it happens on both Linux and Windows, it would rule out specific system software that might interfere.

Is this an old or a new profile (e.g. migrated from previously used Firefox)?
Have you checked if you are using default settings for your preferences?
Are you using any extensions that manipulate session information? Have you checked compatibility?
Are you using private browsing mode? Options -> privacy -> history section -> custom settings -> "always use private browsing mode"

Can you include the output of Help -> troubleshooting information here if you can't find a solution with these hints (as text, please use the [hide] forum tag)
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

axb78613
New to the forum
New to the forum
Posts: 1
Joined: Fri Nov 20, 2015 5:15 pm
Location: TX

Re: PM looses every time the sync settings

Postby axb78613 » Fri Nov 20, 2015 5:17 pm

This happens to me too and I have been trying to troubleshoot it. It occurs while the browser is running and not necessarily on a restart. I am using the extension Self Destructing Cookies, which is currently my prime suspect for this issue - I suppose I have to whitelist cookies from palemoon.org to work around this?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20075
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: PM looses every time the sync settings

Postby Moonchild » Tue Nov 24, 2015 8:03 pm

The sync settings aren't stored in cookies. Sync is client software that runs in the browser core.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

_ntnn
Newbie
Newbie
Posts: 6
Joined: Fri Jan 08, 2016 8:15 pm
Location: noop

Re: PM looses every time the sync settings

Postby _ntnn » Fri Jan 08, 2016 8:23 pm

From IRC:
ripper93 | In my preferences > Privacy > History > Settings > Data, I had the "Saved Passwords" box checked...
ripper93 | ops, my bad, not "Saved Passwords", but "Active logins"
ripper93 | then PM cleared my logins everytime I quit

So uncheck "Active logins" in Pref > Privacy > History > Settings > Data,

sygma
New to the forum
New to the forum
Posts: 1
Joined: Fri Jan 08, 2016 8:47 pm
Location: Earth

Re: PM looses every time the sync settings

Postby sygma » Fri Jan 08, 2016 8:59 pm

The same thing happened to me and I found what it was.

First, is not some bug or error, but a PM feature that erases the Sync configuration.
If you did check the "Saved Passwords" in the Settings from Clearing History In the Privacy tab of Preferences, PM will erase the Sync config.

Unchecking it did solve the problem for me.

Image


Haven't tried with all the options to see if any other does the same thing, but with the ones in the image the sync isn't erased anymore.

Hope it works for you.

pandur
Newbie
Newbie
Posts: 3
Joined: Mon Sep 28, 2015 8:23 pm
Location: here

Re: PM looses every time the sync settings

Postby pandur » Mon Jan 11, 2016 7:28 am

Sorry for late reply!

Moonchild wrote:Is this an old or a new profile (e.g. migrated from previously used Firefox)?
Have you checked if you are using default settings for your preferences?
Are you using any extensions that manipulate session information? Have you checked compatibility?
Are you using private browsing mode? Options -> privacy -> history section -> custom settings -> "always use private browsing mode"

a) Is a new profile
b) yes, tested also with default settings
c) no: I had some extension and themes that weren't support by PM -> Solution! ... for now ;)
d) yes, I always use private browsing mode

So c) solved my problem. I removed all addons except noScript.
=> Thanks a lot!

But what about the Saved Password setting mentioned by sygma?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20075
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: PM looses every time the sync settings

Postby Moonchild » Mon Jan 11, 2016 11:38 am

Sync requires a password. If you clear it, then Sync will no longer be functional and will reset itself.
Clearing passwords on shutdown is mainly meant for situations like Kiosk use where you want this cleared out.

If you never want website passwords stored, then tell Pale Moon not to store them in the first place:
Options -> Security -> uncheck "Remember passwords for sites"
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

jyrki
Newbie
Newbie
Posts: 3
Joined: Sun Jul 24, 2016 3:14 pm

Re: PM looses every time the sync settings

Postby jyrki » Fri Sep 16, 2016 1:43 pm

Hi

I'm having a similar issue, not quite like the above ones, but similar enough.

my sync password has to be 'updated' every time the browser starts.

Image

And when you into preferences/sync you get this:

Image

I need to just paste the same password, and it goes happily away ...until next restart.

I'd say there's something stuck in the wrong bit somewhere.
Comes from a fresh install, not imported. I do have got another profile where sync works perfectly. The one I'm having issues with has less addons (same set) than the working one.

Any help appreciated

Palemoon Version: 26.4.0.1 (x64)
running on arch linux (manjaro flavour)

Thanks!

tristank
Newbie
Newbie
Posts: 3
Joined: Thu Jun 25, 2015 6:43 pm
Location: Germany

Re: PM looses every time the sync settings

Postby tristank » Wed Nov 02, 2016 8:23 pm

I'm having the same issue as jyrki. Any suggestions or news on that matter.


Return to “Pale Moon Sync”

Who is online

Users browsing this forum: No registered users and 1 guest