after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Anything to do with the Pale Moon Sync service.

Moderator: satrow

User avatar
s8472
Newbie
Newbie
Posts: 5
Joined: Thu, 15 Nov 2018, 18:04

after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Unread postby s8472 » Mon, 28 Jan 2019, 16:40

After a sync in v28.3.*, the bookmark's KEYWORD call in the address bar doesn't work at all.
One has to restart the browser in order to get it working.
New or old bookmarks with KEYWORD - all of them are affected.
There doesn't seem to be any failures or errors in the sync log.
The KEYWORD is properly present in the bookmark record, it just doesn't work when called, until the browser restart.

OS: Arch Linux

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23021
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Unread postby Moonchild » Mon, 28 Jan 2019, 21:11

I'm unable to reproduce any issues with this. My OS is Windows but that shouldn't make a difference here as it's all internal.

I've synced and used a keyword for a bookmark in the address bar and it properly pops up the bookmark with the keyword indicator (magnifying glass).
keyword1.png
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
s8472
Newbie
Newbie
Posts: 5
Joined: Thu, 15 Nov 2018, 18:04

Re: after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Unread postby s8472 » Tue, 29 Jan 2019, 17:53

I'm not using the "location bar suggestions", it's disabled entirely.
When I type a bookmark's KEYWORD into the location bar and press enter, a bookmarked URL should be loaded directly.
Use the location bar like a command (KEYWORD) in CLI, do not use the suggested URLs found.
Just to be sure, I also disabled all add-ons in order to rule out that kind of influence, but no change after disabling with restart all of them, same problem after full sync.
I'm also testing it with bookmark's JSON backup, importing it again to simulate full sync.

Here, a sample of such failure:
examplex.png

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23021
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Unread postby Moonchild » Tue, 29 Jan 2019, 22:41

Ah well, that's a non-standard way of doing this -- would have helped if you would have explained exactly how you were trying to use it from the start to understand the problem.

You're sure this is a problem that doesn't exist in 28.2.*, and regressed in 28.3.*? Please verify if you're not sure, because this kind of interaction between components is complex to start with and we have to be looking at the correct range of changes to pinpoint the possible cause.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
s8472
Newbie
Newbie
Posts: 5
Joined: Thu, 15 Nov 2018, 18:04

Re: after a sync in v28.3.*, the bookmark's KEYWORD doesn't work at all, only after browser restart

Unread postby s8472 » Thu, 31 Jan 2019, 06:56

Moonchild wrote:You're sure this is a problem that doesn't exist in 28.2.*, and regressed in 28.3.*? Please verify if you're not sure, because this kind of interaction between components is complex to start with and we have to be looking at the correct range of changes to pinpoint the possible cause.

In between of the 28.0 and 28.2 I was facing another problem described in https://forum.palemoon.org/viewtopic.php?f=52&t=20884, which made the sync in PM completely unsuable to me.
This was finally fixed in the 28.3.
Because of that major problem, I cannot provide you with that verification.
This new issue is really of a minor severity compaing to the previous one mentioned.

Moonchild wrote:Ah well, that's a non-standard way of doing this -- would have helped if you would have explained exactly how you were trying to use it from the start to understand the problem.

I have three PCs. I still combine usage of FF and PM (split to either multiple physical displays or to virtual displays).
Therefore, I'm sharing my bookmarks in between of FF and PM.
Time ago, I was using XMARKS on all of them to share the data, but since it's "death" I'm forced to share it like this using FF's and PM's own sync services.
So for an instance, I export/backup my bookmarks in FF and import/restore them in the PM, no matter on which PC.
Import/restore is performed well and on that very same PM instance the KEYWORDs are working right away, following sync push (with exceptions of TABS I'm syncing everything else) when it chooses to on it's own.
However, after I come to the other remaining PCs where a PM sync pull happened, all KEYWORD calls on that PM instance aren't working until I restart the browser.


Return to “Pale Moon Sync”

Who is online

Users browsing this forum: No registered users and 1 guest