as of v28 sync pull stopped working properly, messing bookmarks totally

Anything to do with the Pale Moon Sync service.

Moderator: satrow

User avatar
s8472
Moongazer
Moongazer
Posts: 8
Joined: 2018-11-15, 18:04

as of v28 sync pull stopped working properly, messing bookmarks totally

Unread post by s8472 » 2018-11-15, 19:54

Hello

- using Arch Linux (usually with all recent updates).
- three computers (all with the same OS, two laptops, one workstation) being synchronized.
- Pale Moon package source in the distribution.
- have already tested to disable or remove all extensions, but no change there.
- have also tested new sync account, with no change either.

As of upgrade to v28, I've noticed the sync stopped working pulling the bookmarks properly (until then, everything worked fine in v27).
Doesn't matter which computer is pushing the data to sync.

Push seems to work ok:
push-success-sync-1542303026810.txt:1542302933262 Sync.Engine.Clients INFO 1 outgoing items pre-reconciliation
push-success-sync-1542303026810.txt:1542302936014 Sync.Engine.Clients INFO 1 outgoing items pre-reconciliation
push-success-sync-1542303026810.txt:1542302936776 Sync.Engine.Prefs INFO 1 outgoing items pre-reconciliation
push-success-sync-1542303026810.txt:1542302938620 Sync.Engine.Bookmarks INFO 8515 outgoing items pre-reconciliation
push-success-sync-1542303026810.txt:1542303026070 Sync.Engine.Forms INFO 0 outgoing items pre-reconciliation
push-success-sync-1542303026810.txt:1542303026078 Sync.Engine.History INFO 7 outgoing items pre-reconciliation
However, the pull log is speaking only about 998 bookmarks applied:
pull-success-sync-1542303614034.txt:1542303552926 Sync.Engine.Clients INFO Records: 0 applied, 0 successfully, 0 failed to apply, 0 newly failed to apply, 2 reconciled.
pull-success-sync-1542303614034.txt:1542303556186 Sync.Engine.Prefs INFO Records: 1 applied, 1 successfully, 0 failed to apply, 0 newly failed to apply, 0 reconciled.
pull-success-sync-1542303614034.txt:1542303557296 Sync.Engine.Passwords INFO Records: 0 applied, 0 successfully, 0 failed to apply, 0 newly failed to apply, 0 reconciled.
pull-success-sync-1542303614034.txt:1542303606812 Sync.Engine.Bookmarks INFO Records: 998 applied, 998 successfully, 0 failed to apply, 0 newly failed to apply, 2 reconciled.
pull-success-sync-1542303614034.txt:1542303613538 Sync.Engine.Forms INFO Records: 0 applied, 0 successfully, 0 failed to apply, 0 newly failed to apply, 0 reconciled.
pull-success-sync-1542303614034.txt:1542303613996 Sync.Engine.History INFO Records: 7 applied, 7 successfully, 0 failed to apply, 0 newly failed to apply, 0 reconciled.
The pull log is full of similar events (full logs are in attachment):
push-success-sync-1542303026810.txt:1542303558658 Sync.Engine.Bookmarks DEBUG -0OPFawGqKxg mapped to undefined
push-success-sync-1542303026810.txt:1542303558658 Sync.Store.Bookmarks DEBUG Applying record -0OPFawGqKxg
push-success-sync-1542303026810.txt:1542303558658 Sync.Store.Bookmarks DEBUG Remote parent is yg7ev9iHzd-6
push-success-sync-1542303026810.txt:1542303558664 BookmarkSyncUtils DEBUG insertSyncBookmark: Item -0OPFawGqKxg is an orphan: parent yg7ev9iHzd-6 doesn't exist; reparenting to unfiled
push-success-sync-1542303026810.txt:1542303558752 BookmarkSyncUtils DEBUG reparentOrphans: Reparenting [] to -0OPFawGqKxg
push-success-sync-1542303026810.txt:1542303558754 Sync.Store.Bookmarks DEBUG Created folder -0OPFawGqKxg under unfiled: {"kind":"folder","syncId":"-0OPFawGqKxg","parentSyncId":"unfiled","title":"$(MY_CUSTOM_BOOKMARK_TITLE)","tags":[]}
push-success-sync-1542303026810.txt:1542303605350 BookmarkSyncUtils DEBUG reparentOrphans: Reparenting ["-0OPFawGqKxg","1Uys9tc0iS6o","1dviYyADe05R","36FqcyjU68ze","3TLGZxPuWtJ0","Dbt-qHqQ-pRK","IhuaWsMuP05L","JMxzIbYioY74","JlwtFHMtqnO-","SUqBpnlveTyi","TEBfZDPkfkzs","VlDxQ-K0XOzc","VpJsCASKxC_Q","gkKTk1yrWVTQ","kMYgMg3nQq4C","pCeZq4vH8KYL","saiOQ2fHtMLG"] to yg7ev9iHzd-6
push-success-sync-1542303026810.txt:1542303605350 BookmarkSyncUtils TRACE reparentOrphans: Attempting to move item -0OPFawGqKxg to new parent yg7ev9iHzd-6
push-success-sync-1542303026810.txt:1542303608648 Sync.Store.Bookmarks DEBUG Could not order children for -0OPFawGqKxg: TypeError: sortedChildren is undefined (resource://gre/modules/Bookmarks.jsm:716:23) JS Stack trace: reorder/<@Bookmarks.jsm:716:23 < TaskImpl_run@Task.jsm:319:42 < process@Promise-backend.js:932:23 < walkerLoop@Promise-backend.js:813:7 < scheduleWalkerLoop/<@Promise-backend.js:747:11 < waitForSyncCallback@async.js:98:7 < makeSpinningCallback/callback.wait@async.js:152:27 < promiseSpinningly@async.js:218:12 < _orderChildren@bookmarks.js:827:5 < _processIncoming@bookmarks.js:541:9 < _sync@engines.js:1630:7 < WrappedNotify@util.js:166:21 < sync@engines.js:689:5 < _syncEngine@enginesync.js:321:7 < sync@enginesync.js:168:15 < onNotify@service.js:1330:7 < WrappedNotify@util.js:166:21 < WrappedLock@util.js:121:16 < _lockedSync@service.js:1320:12 < sync/<@service.js:1312:14 < WrappedCatch@util.js:95:16 < sync@service.js:1300:5
As a result, the bookmarks are incomplete on the pull-ing computer, and due to some of those "sorting" issues in log, it also screwes up the bookmarks order on the push computer at next sync recursively.

I have no further clue why is this happening.
Can somebody help, please?
Thank you in advance.
Attachments
weave_logs.zip
(91.73 KiB) Downloaded 5 times

User avatar
s8472
Moongazer
Moongazer
Posts: 8
Joined: 2018-11-15, 18:04

Re: as of v28 sync pull stopped working properly, messing bookmarks totally

Unread post by s8472 » 2019-01-16, 18:37

There seems to be some improvement at last release v28.3.0, perhaps due to the recent changes in sync.
I'll keep on testing it.

User avatar
martywd
Fanatic
Fanatic
Posts: 118
Joined: 2014-04-16, 14:36
Location: TX

Re: as of v28 sync pull stopped working properly, messing bookmarks totally

Unread post by martywd » 2019-01-16, 19:58

.
Similar issue, but I haven't lost my bookmarks. Yet. This on three machines, one running Win7, two running LM 19.1 all PM 28.3.0 64-bit. 'Preferences|Sync' window shows the following. I know the key is correct, I made a note of the user, password, and key fields when setting up Pale Moon sync originally.

Edit to add: I unlinked and started the sync setup again, with username, password and key. Still fails with a key error.

Image

.

User avatar
karlchen
Moongazer
Moongazer
Posts: 11
Joined: 2019-01-16, 15:55

Re: as of v28 sync pull stopped working properly, messing bookmarks totally

Unread post by karlchen » 2019-01-16, 20:20

Hi, martywd.

You posted the issue in the wrong thread. ;-)
P.M. 28.3 brings along a new sync client, which no longer accepts the sync key, which had been valid up to P.M. 28.2.2.
Stepped into the same trap as well. Please, cf. in this thread here: Re: Keep getting 'wrong recovery key' after resetting data.
Moonchild posted the solution: Generate a new sync key, after upgrading to P.M. 28.3; and sync will be back to normal operation.

HTH,
Karl

User avatar
martywd
Fanatic
Fanatic
Posts: 118
Joined: 2014-04-16, 14:36
Location: TX

Re: as of v28 sync pull stopped working properly, messing bookmarks totally

Unread post by martywd » 2019-01-16, 23:10

karlchen wrote:Hi, martywd.

You posted the issue in the wrong thread. ;-)
Arrrgggghhhhh!

Thanks @karlchen for heads up. Much appreciated.

.

Post Reply