Sync stopped working! Help!

Anything to do with the Pale Moon Sync service.

Moderator: satrow

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22132
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Sync stopped working! Help!

Unread postby Moonchild » Sun, 22 Apr 2018, 09:42

Following up on the announcement made, this is a general post to re-iterate what is going on with Pale Moon Sync and why it may have stopped working on 22 April 2018 for you.

For various reasons, not in the least the fact that StartCOM has been forced into foreclosure and certificates cost money otherwise (And Let's Encrypt is not an option), we have been moving the sync server from the palemoon.net domain to the palemoon.org domain. The palemoon.net (old) Sync server host address has worked in tandem for a while, but we are retiring that as a valid address.

While Pale Moon has been given automatic migration options to update this address, and most of you will have already been moved transparently to the new address, there are various reasons why this might not have occurred.

If your Sync stopped working, please check your settings in the advanced configuration editor:

  1. Type about:config in the address bar and press enter.
  2. Find the preference services.sync.clusterURL
  3. Verify that it is set to https://pmsync.palemoon.org/sync/index.php/

If it is not set to the address shown, double-click the value and change it. Note: the only change should be palemoon.org vs. palemoon.net.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Image

kender42
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Wed, 18 Oct 2017, 19:14

Re: Sync stopped working! Help!

Unread postby kender42 » Wed, 09 May 2018, 15:54

If your Sync stopped working, please check your settings in the advanced configuration editor:

Type about:config in the address bar and press enter.
Find the preference services.sync.clusterURL
Verify that it is set to https://pmsync.palemoon.org/sync/index.php/


I went into the about:config and that setting does not exist. What do I do now to get sync working?
Using version 27.9.1 (64-bit)

[edit: forgot to add PM version]

Screenshot:
pmscreenshot.png
Last edited by kender42 on Wed, 09 May 2018, 18:33, edited 1 time in total.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Sync stopped working! Help!

Unread postby Fedor2 » Wed, 09 May 2018, 19:16

There is so written in the code actually.
services.sync.clusterURL is processed only
if (currentUIVersion < 16)
but meanwhile const UI_VERSION = 16; and currentUIVersion is assigned so too.

So set it manually.

kender42
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Wed, 18 Oct 2017, 19:14

Re: Sync stopped working! Help!

Unread postby kender42 » Wed, 09 May 2018, 22:27

I'm not understanding. Can you lay out the steps I need to take?

Because I can't get sync to work at all. All I get is a code to enter and when I go to advanced settings it can't connect to the server.
Wouldn't it just be easier to just enter your username/email and your password and just link it that way, instead of all these confusing and (potentially) dangerous tweaks to the config file. Especially for those of us that have no tech experience.

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 459
Joined: Sun, 24 Sep 2017, 16:35

Re: Sync stopped working! Help!

Unread postby SpockFan02 » Wed, 09 May 2018, 22:46

Your email and password are required to sync, yes, for security and privacy reasons. But, the browser also needs to know where to send and receive data to be synced, and that's what the clusterURL is. As Moonchild has explained, for reasons related to the cost of certificates, this needs to be changed.

To set the preference, in about:config, right-click, hover over New in the context menu, click String, enter the preference name services.sync.clusterURL, and the value https://pmsync.palemoon.org/sync/index.php/.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22132
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Sync stopped working! Help!

Unread postby Moonchild » Thu, 10 May 2018, 00:21

Fedor: of course it is. The UI version gets updated -- that code is only supposed to run once, period.

Spockman: Creating a new pref? No.. people shouldn't be doing that. They should already HAVE a clusterURL if their Sync has been set up, and just need to CHANGE it.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Image

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 459
Joined: Sun, 24 Sep 2017, 16:35

Re: Sync stopped working! Help!

Unread postby SpockFan02 » Thu, 10 May 2018, 08:04

Then if they don't have it they should set up Sync again :)

User avatar
troypulk
Fanatic
Fanatic
Posts: 239
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Sync stopped working! Help!

Unread postby troypulk » Thu, 10 May 2018, 14:05

Is this done on the phone or the PC?
SolydX EE (64-bit)

Pale Moon 28.0.0b5 (64-bit)

kender42
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Wed, 18 Oct 2017, 19:14

Re: Sync stopped working! Help!

Unread postby kender42 » Thu, 10 May 2018, 14:33

It's happening on both PC and Mobile.

I originally had sync set up but after the latest update it stopped working.

[edit #1-2] I got the pc version working, but the mobile tells me to enter a valid server url with no way to get to those settings. User name pass and recovery key are correct on mobile but says there is no valid server url. Even using the above url says it's invalid

the custom url I used in the mobile version (under custom server) is

Code: Select all

https://pmsync.palemoon.org/sync/index.php/
and the mobile version tells me it invalid.


[edit #3-4] The pc version just stopped working again and says it can't connect to the server. What other options/extensions can I use to sync my bookmarks? The pm sync is an abject failure.

How can I export my bookmarks with pm mobile? There doesn't seem to be a menu or an option to do this.
Last edited by kender42 on Thu, 10 May 2018, 16:55, edited 4 times in total.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Sync stopped working! Help!

Unread postby Fedor2 » Fri, 11 May 2018, 05:52

Can you connect mobile yo the pc? Then you can retrieve the whole profile and get whatever you want.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22132
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Sync stopped working! Help!

Unread postby Moonchild » Fri, 11 May 2018, 17:25

I've found the culprit of this confusing situation: I failed to update the server-side setting of the sync server when moving over to the .org domain, and as a result the server would communicate the wrong cluster URL to the browser when setting up sync. This has now been fixed.
Last edited by Moonchild on Fri, 11 May 2018, 17:25, edited 1 time in total.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Image

kender42
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Wed, 18 Oct 2017, 19:14

Re: Sync stopped working! Help!

Unread postby kender42 » Sat, 12 May 2018, 13:35

Fedor2 wrote:Can you connect mobile yo the pc? Then you can retrieve the whole profile and get whatever you want.


How do I retrieve the bookmarks once it's connected?

I looked through the folders my device allows me but I can't find where the bookmarks are located.
Almost all of my folders are hidden and the only bookmarks file is the one that came pre-installed on my device. And no my device is not rooted nor can it be rooted. ALL root options have failed from framaroot to kingroot. All say that it can't be rooted.

kender42
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: Wed, 18 Oct 2017, 19:14

Re: Sync stopped working! Help!

Unread postby kender42 » Sat, 12 May 2018, 13:36

Moonchild wrote:I've found the culprit of this confusing situation: I failed to update the server-side setting of the sync server when moving over to the .org domain, and as a result the server would communicate the wrong cluster URL to the browser when setting up sync. This has now been fixed.



Still says that the server address is invalid on both devices.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Sync stopped working! Help!

Unread postby Fedor2 » Mon, 14 May 2018, 00:44

I looked through the folders my device allows me but I can't find where the bookmarks are located.


Search for the file prefs.js sure it has to point to the profile. Copy all files and launch with the regular palemoon then.

xunil76
Newbie
Newbie
Posts: 4
Joined: Wed, 22 Nov 2017, 14:12

Re: Sync stopped working! Help!

Unread postby xunil76 » Thu, 12 Jul 2018, 13:46

this problem has recently recurred, despite having followed the steps in this thread to correct the issue. This is happening on my work PC (PM 27.9.3, 32-bit), my 2 personal laptops (PM 27.9.0 64-bit on one of them...not sure on the other, it's at home), and my home desktop (not sure what version ATM, I'm not at home now).

The only difference is that unlike before, the error only comes up once after launching the browser...I can close the error, and it doesn't come back until the browser has been completely closed & reopened. Still, I'd really like to not have to close this error every single time I launch the browser. This happens both at work and at home, so I know it's not just a work firewall issue.

PM Error.png

PM Version Work PC.png

xunil76
Newbie
Newbie
Posts: 4
Joined: Wed, 22 Nov 2017, 14:12

Re: Sync stopped working! Help!

Unread postby xunil76 » Thu, 12 Jul 2018, 13:59

Oh, also forgot to mention that my work PM and my personal PM are each on separate sync accounts, so it's not just an issue with my account...unless both accounts are suffering from the same issue.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22132
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Sync stopped working! Help!

Unread postby Moonchild » Thu, 12 Jul 2018, 22:50

"failed to connect to the server" likely means that you're having interfering third-party software that blocks the initial sync connection.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

Image


Return to “Pale Moon Sync”

Who is online

Users browsing this forum: No registered users and 2 guests