Dictionaries not compatible?

Talk about code development, features, specific bugzilla bugs, enhancements, patches, and other highly technical things.
Forum rules
Please keep everything here strictly on-topic.
This board is meant for Pale Moon source code development related subjects only like code snippets, patches, specific referenced Bugzilla bugs, mercurial, etc.

This is not for tech support! Please do not post tech support questions in the "Development" board!
Please make sure not to use this board for support questions. Most "bug reports" do not belong in this board and should initially be posted in Community Support or other relevant support boards.

Please keep things on-topic as this forum will be used for reference for Pale Moon development. Expect topics that aren't relevant as such to be moved or deleted.
Post Reply
User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1722
Joined: 2012-08-19, 20:32

Dictionaries not compatible?

Post by back2themoon » 2020-03-12, 17:52

I've been a bit away so sorry if I missed something. I'm seeing all my three usual dictionaries disabled as not compatible, is this new? No leniency on the poor dictionaries, or a bug?

29.0.0.a2 x64 2020-03-11
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

User avatar
JoeyG
Lunatic
Lunatic
Posts: 479
Joined: 2017-06-12, 13:27
Location: How can you be in two places at once when you're not anywhere at all?

Re: Dictionaries not compatible?

Post by JoeyG » 2020-03-13, 11:01

back2themoon wrote:
2020-03-12, 17:52
... I'm seeing all my three usual dictionaries disabled as not compatible, is this new? No leniency on the poor dictionaries, or a bug? 29.0.0.a2 x64 2020-03-11
Though it's not "the solution", just to get things up and running again provisionally, you might check the respective install.rdf files and edit them as needed.

This isn't really "allowed", but I guess only doing it for your own personal use on a temporary basis isn't a crime against humanity :roll: .
Last edited by JoeyG on 2020-03-13, 12:10, edited 3 times in total.
Pale Moon x64 28.10.0 and 29.0.0a5 (portable 2020-07-06); Basilisk x64 2020.06.10 - all on Win7 SP1 x64 (English). Lenovo S20, Xeon X5670, 12gb RAM. NEC PA272W on Matrox C420. NEC SpectraView 241 and PA241W on Matrox M9120. Thanks to the devs.

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1963
Joined: 2015-09-03, 19:47
Location: UA
Contact:

Re: Dictionaries not compatible?

Post by JustOff » 2020-03-13, 11:20

Perhaps you are using Firefox dictionaries, they are no longer compatible after Issue #1446 (UXP). Try reinstalling the ones you need from here.
Here are the add-ons I made in a spare time. That was fun!

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1722
Joined: 2012-08-19, 20:32

Re: Dictionaries not compatible?

Post by back2themoon » 2020-03-13, 11:30

Ok thanks, but are dictionaries considered the same as extensions?

Also, I'll throw the request here: please also consider (Tobin?) uploading this Greek-English (US) dictionary.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7339
Joined: 2012-10-09, 19:37
Location: Binary Outcast

Re: Dictionaries not compatible?

Post by New Tobin Paradigm » 2020-03-13, 13:34

The fuck is greek english us?!

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1722
Joined: 2012-08-19, 20:32

Re: Dictionaries not compatible?

Post by back2themoon » 2020-03-13, 16:41

Double dictionary. Useful and common (on non-Latin languages, I guess). You don't have to keep switching and mixed content is common here.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7339
Joined: 2012-10-09, 19:37
Location: Binary Outcast

Re: Dictionaries not compatible?

Post by New Tobin Paradigm » 2020-03-13, 17:55

Maybe when dictionaries become real add-ons on the site then people can submit and/or takeover that initial selection. But I will not be personally converting any more.

User avatar
Andrew Herbert
Fanatic
Fanatic
Posts: 116
Joined: 2019-11-25, 21:46

Re: Dictionaries not compatible?

Post by Andrew Herbert » 2020-03-14, 16:47

I wonder if this has been unintentional. The issue text on GitHub doesn't mention anything about dictionaries.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7339
Joined: 2012-10-09, 19:37
Location: Binary Outcast

Re: Dictionaries not compatible?

Post by New Tobin Paradigm » 2020-03-14, 18:02

Are dictionaries strict compatibility? Are these Mozilla provided or ones currently living on my repo subdomain?

What is the targetApplication blocks for one that isn't working?

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1722
Joined: 2012-08-19, 20:32

Re: Dictionaries not compatible?

Post by back2themoon » 2020-03-14, 20:11

None of the ones that went incompatible were from your repo. This is from the linked gre-eng dictionary:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">
    <Description about="urn:mozilla:install-manifest">
        <em:type>64</em:type>
        <em:bootstrap>true</em:bootstrap>
        <em:id>SpellingGR-EN_US@kostaskatsaros</em:id>
	<em:unpack>true</em:unpack>
        <em:version>0.8.7</em:version>
        <em:name>Greek - English (US) Spelling dictionary</em:name>
        <em:description>Combined Greek - English (US) spell checking dictionary for Firefox - Thunderbird - Seamonkey</em:description>
        <em:homepageURL>https://addons.mozilla.org/en-US/firefox/addon/greek-english-spell-dictionary/</em:homepageURL>
        <em:creator>Kostas Katsaros</em:creator>
        <em:targetApplication>
            <Description>
                <!-- Firefox -->
                <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
                <em:minVersion>2.0</em:minVersion>
                <em:maxVersion>42.*</em:maxVersion>
            </Description>
        </em:targetApplication>
        <em:targetApplication>
            <Description>
                <!-- Thunderbird -->
                <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
                <em:minVersion>2.0</em:minVersion>
                <em:maxVersion>42.*</em:maxVersion>
            </Description>
        </em:targetApplication>
        <em:targetApplication>
            <Description>
                <!-- SeaMonkey -->
                <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
                <em:minVersion>1.1a</em:minVersion>
                <em:maxVersion>2.39</em:maxVersion>
            </Description>
        </em:targetApplication>
    </Description>
</RDF>
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7339
Joined: 2012-10-09, 19:37
Location: Binary Outcast

Re: Dictionaries not compatible?

Post by New Tobin Paradigm » 2020-03-14, 20:27

Yeah, the Dual-GUID system has been adjusted for Pale Moon 29 to ONLY ALLOW Extensions with a Firefox ID (not a Pale Moon or toolkit ID). That is why it is now incompatible. Themes, Language Packs, old style item packages, and I think I am forgetting one type.. without a Pale Moon or Toolkit ID will not be allowed to install or be used.

Remove all targetApplication blocks in there and add a toolkit@mozilla.org minVersion 4.1 maxVersion 5.0.0a1 targetApplication and continue along until I get dictionaries onto the Add-ons Site Proper then perhaps you can fork and submit it for everyone to enjoy.

This is special dispensation (read: non-harassment permission) from me to do this for dicts for the time being for your personal use. Please do not dist it.

User avatar
Andrew Herbert
Fanatic
Fanatic
Posts: 116
Joined: 2019-11-25, 21:46

Re: Dictionaries not compatible?

Post by Andrew Herbert » 2020-03-15, 14:54

I thought dictionaries were less intertwined than language packs and themes. :eh:

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 7339
Joined: 2012-10-09, 19:37
Location: Binary Outcast

Re: Dictionaries not compatible?

Post by New Tobin Paradigm » 2020-03-15, 17:42

They still have an install.rdf file and follow the same rules. There is a reason the forked and processed ones only have a toolkit targetApplication.

This is one of them.

Post Reply