SDK error

Talk about code development, features, specific bugzilla bugs, enhancements, patches, and other highly technical things.

Moderator: satrow

Forum rules
Please keep everything here strictly on-topic.
This board is meant for Pale Moon source code development related subjects only like code snippets, patches, specific referenced Bugzilla bugs, mercurial, etc.

This is not for tech support! Please do not post tech support questions in the "Development" board!
Please make sure not to use this board for support questions. Most "bug reports" do not belong in this board and should initially be posted in Community Support or other relevant support boards.

Please keep things on-topic as this forum will be used for reference for Pale Moon development. Expect topics that aren't relevant as such to be moved or deleted.
User avatar
WilliamK
Fanatic
Fanatic
Posts: 161
Joined: 2018-02-23, 06:51

SDK error

Unread post by WilliamK » 2018-09-11, 10:08

I am away from my office and have setup PM builds on a different computer. But when I build on 32-bit using start-shell-msvc2013.bat I am getting this error...

configure: error: DirectX SDK at C:/Program Files/Microsoft DirectX SDK (March 2009) appears broken
Last edited by WilliamK on 2018-09-11, 10:10, edited 1 time in total.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 5423
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: SDK error

Unread post by New Tobin Paradigm » 2018-09-11, 14:39

When building yourself especially on Windows you are on your own.

What verson of the codebase are you trying to build?
Image

- Shadow the Hedgehog is my favorite Pokemon! -
http://binaryoutcast.com/ | http://thereisonlyxul.org/

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 795
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: SDK error

Unread post by Isengrim » 2018-09-11, 14:57

WilliamK wrote:I build on 32-bit using start-shell-msvc2013.bat
If you are building Pale Moon 28.x, you will need Visual Studio 2015 CE or Pro with the C++ tools.
Linux Mint 18.3 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
WilliamK
Fanatic
Fanatic
Posts: 161
Joined: 2018-02-23, 06:51

Re: SDK error

Unread post by WilliamK » 2018-09-11, 16:10

New Tobin Paradigm wrote:What version of the codebase are you trying to build?
27.9.3 32-bit. It works well on my main 64-bit PC but that has a variety of later VS resources and SDKs. This one hasn't been used since 2014 and is 32-bit using VS 2010 that I upgraded to VS 2013 and then updated with Update3 to get past a bunch of errors.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23640
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: SDK error

Unread post by Moonchild » 2018-09-12, 06:21

You don't need the DirectX SDK anymore (it was only needed for XP ANGLE support). Even so, if you have one installed, you should be using the June 2010 one.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
"I'm afraid you have me mistaken for someone who can be shamed by a child." -- Quillspawn

Locked