Page 10 of 13

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 00:48
by visionhelp
Fedor2 wrote:All that stuff beside wiki and issues are there for programmers, should not bothered with it.
I got that thought and can full appreciate this.
For me at this time this is a complete new kind of structure, which I currently do not have space in mind to figure it out.
I would prefere to do it here at this thread, but this could bring us in troubles with Moonchild, so I will take Your offer for PM.
Fedor2 wrote:All right, updated wiki page, for likes you do not want neither k-lite nor lav splitter installer.
Hope you can handle with zip files and cmd
I just said it - unasked - in the name of FlexPM. And in the name of love to the Pale Moon browser. (Greet them welcome, or, just let them do their ideas for it.)
I prefere the K-Lite Codec Pack, if it works. And this is still not the case, but this in the 26.5.0, which is not Your´s.

Your wiki at Your https://github.com/Feodor2/Mypal/wiki is empty, this moment (Wednesday, 31. January 2018), the following is OK. (WOW. Thanks, also in the name of FlexPM.) https://github.com/Feodor2/Mypal/wiki/H264-support
(Sadnessly I had to read this: FFmpeg Builds (for Windows) https://ffmpeg.org/general.html#Video-Codecs the Winsows Builds at https://ffmpeg.zeranoe.com/builds/:
"FFmpeg is the leading multimedia framework to decode, encode, transcode, mux, demux, stream, filter and play. All builds require at least Windows 7 or Mac OS X 10.10."
But there still is Your "FFmpeg libraries on WINXP", Fedor2, which You get from installing K-Lite Codec Pack, at least the LAV-splitter from there.)

Sorry, Moonchild, I am trying to stop it here. It seems as finding no end.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 02:00
by roytam1
visionhelp wrote:
Fedor2 wrote:All that stuff beside wiki and issues are there for programmers, should not bothered with it.
I got that thought and can full appreciate this.
For me at this time this is a complete new kind of structure, which I do not have space in mind to figure it out.
I would prefere to do it here at this thread, but this could bring us in troubles with Moonchild, so I will take Your offer for PM.
Fedor2 wrote:All right, updated wiki page, for likes you do not want neither k-lite nor lav splitter installer.
Hope you can handle with zip files and cmd
I just said it - unasked - in the name of FlexPM. And in the name of love to the Pale Moon browser. (Greet them welcome, or, just let them do their ideas for it.)
I prefere the K-Lite Codec Pack, if it works. And this is still not the case, but this in the 26.5.0, which is not Your´s.

Your wiki at Your https://github.com/Feodor2/Mypal/wiki is empty, this moment (Wednesday, 31. January 2018), the following is OK. (WOW. Thanks, also in the name of FlexPM.) https://github.com/Feodor2/Mypal/wiki/H264-support
(Sadnessly I had to read this: FFmpeg Builds (for Windows) https://ffmpeg.org/general.html#Video-Codecs the Winsows Builds at https://ffmpeg.zeranoe.com/builds/:
"FFmpeg is the leading multimedia framework to decode, encode, transcode, mux, demux, stream, filter and play. All builds require at least Windows 7 or Mac OS X 10.10."
But there still is Your "FFmpeg libraries on WINXP", Fedor2, which You get from installing K-Lite Codec Pack, at least the LAV-splitter from there.)

Sorry, Moonchild, I am trying to stop it here. It seems as finding no end.
Just to be clear, pm26-based browsers doesn't use any ffmpeg, since it doesn't deal with any MediaSource and its extensions.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 02:15
by visionhelp
Yikes, gasp. OK. Thank You.
Firefox 52 doesn´t it, too. That single one I got until now, which wanted explicit only a html5-player, to play.
So I need to install Pale Moon for XP 27 the next time.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 02:20
by New Tobin Paradigm
There is no such thing as Pale Moon for XP 27.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 11:41
by visionhelp
This is a decision, which Moonchild Productions - and the both developers of "... for XP v27.x" have to do, please.
And in my archive absolutely it is.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 14:16
by New Tobin Paradigm
New Tobin Paradigm wrote:There is no such thing as Pale Moon for XP 27.

Re: Building Palemoon 27 for XP

Posted: 2018-01-31, 14:39
by visionhelp
Yes, You are right, the ... 27 not, sorry. Certainly. Not 27.
This is a point.
And this really needs betterment, at all. That clear, that it is NOT the 27, and not the followings, too.
(Pale Moon (from Moonchild Productions), the current, which is still supported, is from Windows 7 on, I think, and the versions for XP ´ONLY´ - (?) - only the versions for XP. Absolutely right. Thank You to this note.)


But - if I may point to this - all (Pale Moon versions) can benefit from all the others.

And if someone likes to compare and needs a solution for installing more than one version and get to run more than one version at the same time, to compare, and anyone is able to create a solution for this, all the other Pale Moon versions can benefit from things, which can follow from there.
But this is only my point of view.

Re: Building Palemoon 27 for XP

Posted: 2018-02-02, 05:30
by visionhelp
Just seeing the name of the thread "Pale Moon 27 for XP" . . ., the next "... 28 ..." . . . ?

I installed the Fedor2´s version. May I say it here, for other members with?

The video https://www.youtube.com/watch?v=NuIAYHVeFYs works.
Wow. Near at 3D, if I am not doing it only in my mind.
With speed about 1 MBit/s and less, about 300 KBit/s, so the speed-test at this time.
With stutter, but music plays and it is to see - and listen -, what it is about.

The last K-Lite Codec Pack was installed.

The red time-line is always at the end, so not the current play-time to see. (Something has changed only showing the time which is leaving to play?
Or perhaps from the complete uninstalled .NET Framework in my XP.)
And the chat of Youube at the right site is running and has to be switched off every time. I never had this before. Perhaps new also at Youtube. I do not know.

One speed-test - at - speedtest.t-online.de did a Blue Screen "Bad_Pool_Caller". This could be from the Mobile Phone (as modem) connection for the PC.

This one is well: https://fast.com/de/

Re: Building Palemoon 27 for XP

Posted: 2018-02-02, 18:08
by visionhelp
As next I would like - as knowing from the Flash-player - to be asked to confirm, whether a html5 video is wanted to be played.
Against Ads - as html5 - to the costs of my internet-speed and the date-lots limits of the mobile phone contract.

Re: Building Palemoon 27 for XP

Posted: 2018-02-18, 05:24
by visionhelp
I have to revise a thing I said in this thread here, I think.

It is about copyright laws and patent law or - in other words - industrial property rights.

Yesterday evening, in a documentation about - not only - the beginnings of Apple, Microsoft, IBM, was told, that at the time of VisiCalc - I hope I remember this name correct - development in USA did not exist the possibility to patent a software.
But after this and short before MS-DOS was developed, the USA did change this and for software it is possible to get patent laws.

The point of differences must be the about 30 to 40 % of a song, for example, may be a copy of an other song.
Parts of a copy from other software in software can only be much more less with patent laws, else it would make no sense.
This to avoid seems then near only still possible, with programming a software with a complete other computer language. To avoid every possible problems there.

Re: Building Palemoon 27 for XP

Posted: 2018-02-23, 02:29
by Tony0945
Where can I get VS2013. All the links I find wind up downloading VS2017. I'm liking the idea of building the Linux version with MingW. I've also used Xming to connect to a Linux box from XP, but it's clunky.

Re: Building Palemoon 27 for XP

Posted: 2018-02-23, 06:45
by roytam1
Tony0945 wrote:Where can I get VS2013. All the links I find wind up downloading VS2017. I'm liking the idea of building the Linux version with MingW. I've also used Xming to connect to a Linux box from XP, but it's clunky.
https://www.visualstudio.com/en-us/vs/older-downloads/

Re: Building Palemoon 27 for XP

Posted: 2018-02-23, 13:29
by Tony0945
That page is a 404. Thanks anyway,

Re: Building Palemoon 27 for XP

Posted: 2018-02-23, 14:39
by GMforker

Re: Building Palemoon 27 for XP

Posted: 2018-03-12, 18:23
by Tony0945
Thank you. Unfortunately that was dead end too as it requires a Microsoft account. I tried to start one but the creation process requires a telephone that can receive texts. My hous phone is only voice. I am downloading 2017 as it doesn't require any registration. If that doesn't work, I'll investigate running the linux version with mingw or cygwin.

Re: Building Palemoon 27 for XP

Posted: 2018-03-12, 20:50
by WilliamK
New Tobin Paradigm wrote:There is no such thing as Pale Moon for XP 27.
If someone has built a PM offshoot that supports XP I am interested in knowing what is required.

Re: Building Palemoon 27 for XP

Posted: 2018-03-12, 21:06
by New Tobin Paradigm
It would still not BE Pale Moon. It would be something else.

Re: Building Palemoon 27 for XP

Posted: 2018-03-13, 12:48
by visionhelp
to WilliamK:

There are two versions of PM - for XP - of Fedor2 and roytam1, which Moonchild Productions does not want to be called PM.

You need one of the two versions to install as requirement, to have a PM - which is not wanted to be called PaleMoon, and which they do not like to support, too - installed in XP.

(Because of the necessary changes of PM to get it to run in XP, one can say, it is not THE PM as the usual PM, because Moonchild Productions DOES not build THIS two versions for XP, and will never build one.
Right, correct, New Tobin Paradigm ?)

Re: Building Palemoon 27 for XP

Posted: 2018-03-13, 15:17
by New Tobin Paradigm
No it is NOT Pale Moon at all.. It is a browser similar.. Based on but NOT Pale Moon. If it was Pale Moon it would not run on Windows XP. So stop calling it Pale Moon even in conversation because it isn't.

Re: Building Palemoon 27 for XP

Posted: 2018-03-13, 17:33
by visionhelp
This is forbidding free speech, sorry.

One can not talk about, if You may not use the word.
If talking about, it is necessary and legal to say it is a PM-version, (from: being) based on PM).


This seems to want to wipe out, that XP exists with - two - working - adapted, different - versions/variants/varieties of PM, sorry.
Or what here am I understanding wrong, please ?


Topic program-language: no separate main-thread for this ?