Building a Pale Moon fork for Windows XP

Talk about code development, features, specific bugzilla bugs, enhancements, patches, and other highly technical things.

Moderator: satrow

Forum rules
Please keep everything here strictly on-topic.
This board is meant for Pale Moon source code development related subjects only like code snippets, patches, specific referenced Bugzilla bugs, mercurial, etc.

This is not for tech support! Please do not post tech support questions in the "Development" board!
Please make sure not to use this board for support questions. Most "bug reports" do not belong in this board and should initially be posted in Community Support or other relevant support boards.

Please keep things on-topic as this forum will be used for reference for Pale Moon development. Expect topics that aren't relevant as such to be moved or deleted.
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22142
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Building Palemoon 27 for XP

Unread postby Moonchild » Tue, 16 Jan 2018, 20:09

My name is not Childmoon; spoonerizing it like that makes it look like you're trying to ridicule. I hope that's not the case.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Tue, 16 Jan 2018, 20:15

Ooopss, I am very sorry, I was so in the themes . . .

Moonchild, very sorry, please.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Wed, 17 Jan 2018, 06:25

Lunar XP Browser (Feodor2) /(roytam1).

But in regard to the existence of the Lunarsoft.com brand https://www.lunarsoft.net/lunarsoft, I do not know.
Last edited by visionhelp on Wed, 17 Jan 2018, 06:29, edited 1 time in total.

User avatar
Vultural
Apollo supporter
Apollo supporter
Posts: 30
Joined: Wed, 26 Aug 2015, 16:32
Location: Cheung Chau

Re: Building Palemoon 27 for XP

Unread postby Vultural » Thu, 18 Jan 2018, 16:04

Man, this is rather discouraging.
I read about "New Moon" recently and wondered if it would be a viable alternative for my wife's XP.
Her laptop is 13 years old with a smallish hard drive.
I tried loading a Ubuntu distro, but she hated it.
Offered to buy her a new lap, but no no no. I am old enough not to argue with females.
Her Pale Moon is still 25.6 (I think) which she only uses when FF is contrary,

Aside from the "branding" issues, do any of you have opinions about this "New Moon"?
If this is not the proper venue, or if I have committed a faux pas, please forgive me.
Thank you.
Image

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Thu, 18 Jan 2018, 18:19

If the wrong place, from me this apologize, too.

I am working with XP SP3 and Version: 26.5.0 (Atom/WinXP), without knowing I have a Atom CPU or not.
It works well, even the Youtube videos. The Facebook videos troubles. For this I use Firefox.

I had trouble on Facebook with the message as similar as "Your browser is outdated, do update".
This could be solved with the help of Lyceus with a setting in the "about:config".
An other one - from Add-Ons of FF, which mostly are not to download - messaged a wrong older version-number of Firefox would be installed, despite of using Pale Moon.
This helped an other settings change in "about:config".

As next I am going to try - one site back in this post viewtopic.php?f=5&t=16241&start=140#p132182 - the version of Feodor2, after somebody noted here some posts back, this one is easy to install.

(I like Your wife´s knowing what she likes.)
Last edited by visionhelp on Thu, 18 Jan 2018, 18:21, edited 1 time in total.

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1635
Joined: Tue, 19 May 2015, 02:26
Location: Arizona U.S.

Re: Building Palemoon 27 for XP

Unread postby Thehandyman1957 » Fri, 19 Jan 2018, 03:20

I too hope that they are able to come to some sort of workable conclusion to this issue. Not because I still use XP but for those that still do.

I completely understand why folks hang on to that version and I myself dragged my feet for a long long time before finally
updating to W7. There were a lot of reasons to wait and it took me some time to manage W7 to my liking but to be honest,
I would not go back to XP unless I absolutely had to. The things that held me back, I have managed to overcome including the
look and feel of XP.

But for those with older hardware I completely understand your reasons for staying. But due to the continual security issues
and even harder, web compatibility issues and other issues that come with having an outdated browser let alone
operating system I hope that the folks doing these builds can find a way to work
with those who have offered their valuable assistance to make your web browsing safer. :angel:
"A common mistake people make when trying to design something
completely FOOLPROOF, is underestimating the ingenuity of complete FOOLS! ;) "

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Fri, 19 Jan 2018, 12:54

There is at least one guy working at an own build of XP, which has nothing to do with Microsoft, except of the grafical look and all this, what makes XP to XP.
Coding, programming, completely new, at best in a complete other programming-language as the XP was done, can avoid possible copyrights-violations.
To make some differences to XP, closing the ´security holes´, making it as small as necessary, as private as possible, as fast as possible.
Putting some possible developments into it, as already in the bootable CD/DVD Knoppix, which needs no video-/audio-codecs to be installed extra, and all video-formats are displayed in its best quality and colour-settings from alone, for example.
Problems at some time Antivir- and similar programs, which will deny the support for XP.
New hardware - not the 64-Bit CPU, a 32-Bit XP runs on a 64-Bit CPU - and the fitting driver for this XP are challenges.

I sadnessly did not bookmark the links to this XP-development, it is noted in this thread here.


I did 98 - and now XP - after years, to get them into my hands instead they having me in their hand.
Every new Windows-system with complete beginning from new with all . . ., no thank You very much.
XP is MY last Windows-version, with all these works.

Maybe a complete hidden Android-system on a tablet. It is so hidden, that even hardly finding things, they are not possible to find. This prevents me from such works, too. But Android - for me - is still more spying MY device than the Microsoft´s and other products, without any rights to that and without letting anyone really know, what for they collect all this datas for profiling every single human.
And even if they would tell honest, it could be so unbelievable crazy, that alone from this it is not to believe yet, too.
Sorry, I am getting Off Topic. But my neighbours do not want to listen, to talk, or to think about, to this.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Building Palemoon 27 for XP

Unread postby Fedor2 » Mon, 22 Jan 2018, 22:21

Hi there i returned
Palemoon is fully suit me, i only want to run it on winxp, and do not want any radical changes.
Even that newer basilisk possible to build for winxp. I have no will to start some new project, i am not for that certainly. May be when i have much free time, not likely i do in the near future.

I gladly accept any help, moonchild provided already the hosting for binaries, i handle the site https://github.com/Feodor2/Mypal , and made advertise it early, with all issue related my build go there, read wiki i written, if there no answer, make an issue, and i shall write more wiki pages. You only bother is to sign up github, which is easy - no mobile and capcha bullshit. But dedicated site i can't handle, if you wanted that sorry, so use github. New moon theme is almost the same as i recall in firefox nightly, if you do really annoy it, i can change it for firefox nightly myself.
About logo and other such things i do not care at all, and certainly not good in that. If you really annoy of this, you are to put any you want yourselves, at least i can write an instruction how to change icon of the exe. What else?

And the code of course, i don't mind fork the whole, but i see no point for this for today, and i see no way i can handle the whole code.

FlexPM
Moongazer
Moongazer
Posts: 11
Joined: Sat, 15 Apr 2017, 15:15

Re: Building Palemoon 27 for XP

Unread postby FlexPM » Tue, 23 Jan 2018, 15:19

Hello Fe(o)dor, thanks again for your effort - as i stated two pages ago i really appreciate to have the possibility to use (nearly) the same browser on my old XP-Partition, as i use PM on my Linux partition!

Please, let me repeat my issue/phenomena/diffrence between your installation (i did it portable) and roytam's:
After putting the 3 LAV-DLL's in the working directories i observe: mp3 & video is working flawlessly with Roytam's version, but no (html5)media plays in your version, unfortunately.

Do you (or anyone else here) have an idea of the cause for that?
Is there any way to (kind of) register the 3 DLL's in Feodor's build?

Many thanks in advance,
flex
Last edited by FlexPM on Tue, 23 Jan 2018, 17:20, edited 1 time in total.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Tue, 23 Jan 2018, 19:50

Hi.

Thanks, Fedor2, for clear words.

For me it is wery OK, if not orientating to the developments of Pale Moon, which have to consider the developments of Pale Moon for the newer Windows- and other OS-versions.
This is not necessary for a browser for XP only.

What actually - in the main - is needed is html5 working.
And an alternative for slow internet-connections, like mine.

FlexPM, please, didn´t You have nothing else to do, than to put these 3 LAV-DLLs into a determined folder, for Roytam´s version? And then html5 works?
As I understand some weeks ago, the Pale Moon 27.x has problems to get the html5 working. But this may be I understand wrong, sorry.


Fork, StopAtXP, New Moon, Pale Moon for XP, or MyPal . . .
MyPal´s name from Fedor2 for this is done as A - his - solution.
After translating "pal" to german, I understand "PayPal", uhh. Not my choice, but able to call it Fedor2´s MyPal, as he names it there himself https://github.com/Feodor2/Mypal


I, currently, as a new beginner of installing - only - the Fedor2´s MYPAL version, of Pale Moon for XP, have following problems:
- as so understood, not possible to run two versions of Pale Moon, my running now 26.5 PLUS the Fedor2´s version, stops me to install - to test first - the Fedor2´s version.
- "Assets" = what, I can not understand and do not trust to ask.
- MEGA Desktop-App = Alternative download only?, no note to this, have to work it out alone, and everybody, too, so un-nice, sorry.
- and "If you going to take and use patches, apply them with ignore-whitespace option otherwise it may fail.": means WHAT, please? Sorry.

But Fedor2 does not want to support - quote - "But dedicated site i can't handle", and this I have to respect.

But, as said, I do not trust to ask so many questions, which are not answered, noted, already.
Now, what, for me . . .? I do not know. I only can wait, at this very moment.
And . . . the roytam1´s version is "not so easy" to install . . ., but html5 works.

Apropos "easy install": the patches, ´only´ the codes to copy - in a text-file, I am sure -, but not knowing to which name and in the main, which extension . . ., I cannot work with this, sorry.
I had to ask really every single one. No, please.
Last edited by visionhelp on Tue, 23 Jan 2018, 20:24, edited 3 times in total.

FlexPM
Moongazer
Moongazer
Posts: 11
Joined: Sat, 15 Apr 2017, 15:15

Re: Building Palemoon 27 for XP

Unread postby FlexPM » Tue, 23 Jan 2018, 21:05

visionhelp wrote:Hi.

FlexPM, please, didn´t You have nothing else to do, than to put these 3 LAV-DLLs into a determined folder, for Roytam´s version? And then html5 works?
As I understand some weeks ago, the Pale Moon 27.x has problems to get the html5 working. But this may be I understand wrong, sorry.

Yes, got the latest 27.8 build from here: https://o.rthost.cf/palemoon/?sort=date&order=desc (it's a self-extracting 7z),
extracted it into my portable folder, and putted the 3 LAV-DLL's in there too.
After copying a profile (from an older PM as i prefer to have different ones), adding the profile-location in the profile.ini (in C.\DuE\<user>\Anwendungsdaten\....) and starting in with the apropriate -p "profilename" it worked.

Html5 Video in a Browser on my antique, dignified, flash-free XP-partition - it's a rivelation :D

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Building Palemoon 27 for XP

Unread postby Fedor2 » Tue, 23 Jan 2018, 23:21

I want provide you support but have no free time for handling full-fledged site.

There is https://github.com/Feodor2/Mypal/wiki it some as FAQ there and there is
https://github.com/Feodor2/Mypal/wiki/H264-support - please read it

You can ask questions there https://github.com/Feodor2/Mypal/issues - see big green button "New issue"

Because the github is not suitable for regular users, thats why you see there many unfamiliar words, do not confuse with it, you may want know it if you decide become a programmer or computer technician. But github thats all we have now. If you know some good place easy accessible (no mobile and cpacha), i shall open topic there.

update:
i have set better page https://feodor2.github.io/Mypal/ watch there
Last edited by Fedor2 on Wed, 24 Jan 2018, 00:55, edited 1 time in total.

FlexPM
Moongazer
Moongazer
Posts: 11
Joined: Sat, 15 Apr 2017, 15:15

Re: Building Palemoon 27 for XP

Unread postby FlexPM » Wed, 24 Jan 2018, 16:34

Thanks again Fe(o)dor, for your answer, explanation and collected links. Now i've got the fact:
For your build's integration of Html5 media it's mandatory to install (register) the LAV-Codecs properly on the system.
However, for Roytam's build it seems sufficient (at least with latest 27.8 version, on my machine) to put the 3 DLLs into Newmoon's main folder.
Bye

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Thu, 25 Jan 2018, 23:39

Fedor2, FlexPM, thanks to You both.

It will need me some time to work it out. Thanks for now, so far first once.


(rivelation = revelation? Yes?)
Last edited by visionhelp on Thu, 25 Jan 2018, 23:40, edited 1 time in total.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Fri, 26 Jan 2018, 20:33

FlexPM wrote:For your build's integration of Html5 media it's mandatory to install (register) the LAV-Codecs properly on the system.
However, for Roytam's build it seems sufficient (at least with latest 27.8 version, on my machine) to put the 3 DLLs into Newmoon's main folder.


I can perform, that installing the K-Lite Codec Pack (13.7.5) in XP it solved the problem with some sites of mostly bery big companies with - I treasure - special html5-features: the Blue Screen (crash) of XP, to my Pale Moon 26.5.0 (Atom/WinXP).
I had an older K-Lite Codec Pack. I did not have problems with Youtube, but with the videos at Facebook.

The problems with Facebook are still the same.
They offer to make an application for my browser. OK, thanks.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Sat, 27 Jan 2018, 21:23

https://www.youtube.com/watch?v=NuIAYHVeFYs&html5=1
This - if the wrong place here, sorry - even does not play in Firefox.

Here are some notes about it. For me it is currently just too much for my poor head:
https://github.com/cisco/openh264/issues/2835
https://msfn.org/board/topic/175591-ena ... out-flash/
https://github.com/cisco/openh264/issues/1943


Supplement:
I did some changes in the settings of the K-Lite Codec Pack. (First, in the main for Firefox.)
I - only can - played around with some settings about MP4, to switch on. Do not ask me what.
Checking the "https://www.youtube.com/html5" after re-start of Firefox showed some changes:
Only the middle red "!"s now are still not working, the "H.264" and the "MSE & H.264".

Realizing this now brings me very strong to the idea, hm, it is a setting in the codecs.
If there the needed for html5 is switched off, it can not work in the plug-in of the browser. It seems like not installed, but it ´only´ is just not setted correctly.

Perhaps this helps further to some, who know more about the correct settings for this html5 could work, at least in Firefox, but in the main in the follow optimized-wise for Pale Moon, too, certainly.

(Please, which setting is necessary to bring this to enabled in "https://www.youtube.com/html5"?)

Thanks for the interesst.


Still an other link to an other - part of - solution, to make the confusion complete, which also could work for Pale Moon:
https://www.ghacks.net/2014/07/25/enabl ... right-now/
Last edited by visionhelp on Sat, 27 Jan 2018, 22:33, edited 3 times in total.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Building Palemoon 27 for XP

Unread postby Fedor2 » Sun, 28 Jan 2018, 16:48

visionhelp

You definitely went wrong direction, these are inappropriate for Palemoon. Installing K-lite is enough no need to do some setting, they are should be on their default values. If you still confused write me on github or in private, we shall sort it out.

Recently i was bumped into confusing incident: in the installer inside the version tab is stated company Moonchild Productions, and because of that such a person frenzied persists that this is official version, So, to avoid confusion in the future i am to remove company string at all.

After all, this is one more reason to change name, at first time i did not change because users not liked that. However i ask you consider this again.
Last edited by Fedor2 on Sun, 28 Jan 2018, 17:52, edited 1 time in total.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Mon, 29 Jan 2018, 07:12

Fedor2, thanks for Your attention.

To trick some settings in the "about:config" of Pale Moon - for to switch off the exclamation mark of the "Youtube/html5" 6 supported things -, can not be the way, so my last thoughts to that.

After having installed - with the help and advice from Lyceus - the last K-Lite Codec Pack, I think, the Blue Screens crashes of some (big company) sites with html5-technics have disappeared.
But this I must test once conscious and intentional. (Tested it with one site and it seems to be OK now this.)

There are so many confusing things represented if reading things about html5. It depends on where Your read, depending on from whom, with which interessts and intentions.

After thinking and getting clear, for me, it is not the point, not THE MAIN, to have this html5 WORKING, I just DO NOT WANT Blue Screens crashes, first.
I am happy with working videos from Youtube as flash or what ever, if only the video is to view and the sound to hear.
This already - with Youtube - worked even with my older K-Lite Codec Pack, or maybe more, I think, the Flash-player plug-in in Pale Moon.

So, after thinking about it, I do not need the html5 working at all, where the Flash-player DOES it.

The ´only´ problem is - but will get probably a problem with time, with this development from some interessts of propagating this html5 this way -, where only a html5-player plays THIS video still, with no alternative.
For example this link https://www.youtube.com/watch?v=NuIAYHVeFYs (Title: Beautiful Relaxing Music 24/7: Study Music, Sleep Music, Meditation Music, Sleeping Music).
To this the newest K-Lite Codec Pack still does not help (for Pale Moon 26.5).

Also in my case of slow connection - if limit of 1 GB is used, after some days - of then still 128 KByte/s highest, I need LOWest data-sizes.
A german TV zdf.info - live-stream (only in Germany) and from mediathek - does it very well, one of less, I think, but this I do not know, but there is to see, it WORKs, even with 128 KByte/s.


And still this point please, from the talks here:
for Firefox there exist many, many html5-player plug-ins.
That it is not possible to create one - if Open Source or not - for Pale Moon, I cannot really imagine.


Fedor2, thanks for Your offer. I will subscribe at Your site and ask there.
I want to begin with installing Your Pale Moon XP - sadnessly Moonchild does not want exact this, to avoid to be brought together with this version, despite the user NEED to know, and as me, want to have it as name for to recognize it at the name and not first from having have to remind, oh, the Fedor2´s MYPAL is THE version of Pale Moon FOR XP -, parallel to the now working 26.5 version.
(And the common respect to Moonchild and his work . . ., but this is what he does not want, too. This makes it very hard, if a note to this at Your site is not enough for Moonchild, that this Your version is not from Moonchild (Productions), and support questions to things from this Your version are not welcome by Moonchild and by the Pale Moon Forum. To may name it Pale Moon XP (ONLY), or similar.)
Last edited by visionhelp on Mon, 29 Jan 2018, 13:51, edited 3 times in total.

visionhelp
Moon lover
Moon lover
Posts: 95
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: Building Palemoon 27 for XP

Unread postby visionhelp » Tue, 30 Jan 2018, 08:38

In my archiv - at this moment - I name it "Pale Moon XP, Fedor2´s MyPal".
I need to be able to distinguish, at least for archiving, but more the working with it at all.

There is ´my´ 26.5. version, from Moonchild Productions.
And there is the roytam´s version.

The 26.5.0 version still is doing it well.
And with just the begining to install - parallel - the Fedor2´s version, I need to try to keep the 26.5.0 version running with, too.

Sadnessly this thread here is not EXPLICIT the 26.5.0 version, but it is for the XP version(s), so my hope and understanding.
But further sadnessly, from my so understood statement from Moonchild - tell me if understood not quite right, please -, no support the XP-versions of Moonchild Productions, too, would make me next troubles, yes?

Despite of, I try:
At Fedor2´s H264-support https://github.com/Feodor2/Mypal/wiki/H264-support I found now this:
Quote: "H264 needs the LAV-splitter in the Windows-system installed at least" and in Pale Moon in "about:config" this setting, - and if not exists, to do it MANUALLY ? -, ´media.ffmpeg.enabled´ to ´TRUE´, my idea from this. And if wanted disabled: to ´FALSE´.
Whether this solves my preference, all videos with Flash-player, and H264 (-quality) only, if no other way possible, I do not know.

The idea from FlexPM has an elegance and creativity, which sometimes is needed and sometimes can be helpful - either for this problems or others also -, to tag, to label, it with "is a no go", is rejecting and dismissive, sorry.
Fedor2, it must not be Your preference, but it is a solution, if it works.
He ´just´ needs to know, how to register it in XP.
(With this Google-search "xp register dll files" finding this, for example: http://viralpatel.net/blogs/register-dll-files/)

And an other sorry, the github-site, to make a Pull Request and the entire environment of this, I fear I cannot get friend with it.
(By the way, found after extracting: The Assets are the Patches, OK.)
Last edited by visionhelp on Tue, 30 Jan 2018, 08:51, edited 2 times in total.

User avatar
Fedor2
Astronaut
Astronaut
Posts: 544
Joined: Mon, 11 Apr 2016, 01:26

Re: Building Palemoon 27 for XP

Unread postby Fedor2 » Wed, 31 Jan 2018, 00:00

All right, updated wiki page, for likes you do not want neither k-lite nor lav splitter installer.
Hope you can handle with zip files and cmd

And an other sorry, the github-site, to make a Pull Request and the entire environment of this

All that stuff beside wiki and issues are there for programmers, should not bothered with it. See above how to make an issue


Return to “Development (discussion)”

Who is online

Users browsing this forum: No registered users and 1 guest