latest Palemoon f. Atom/WinXP 26.5 and Java?

Support board for people running on (retail/OEM) Windows XP (32/64-bit).

Moderator: satrow

Forum rules
This is a self-serve support board for our community. The development team can't provide any support for Windows XP (and compatible versions of Pale Moon for it) any longer.
mainziman

latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-19, 11:30

Hello,

Palemoon doesn't see my installed Java 1.6u20 (I know it is old and for some reasons it must be exact this release)
how can I get Palemoon to accept Java?

Thanks,
Walter

roytam1
Fanatic
Fanatic
Posts: 160
Joined: 2015-03-11, 07:01
Location: Hong Kong

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by roytam1 » 2017-12-19, 12:00

try setting dom.ipc.plugins.java.enabled = true in about:config ?

mainziman

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-19, 12:43

no luck

this javascript function

Code: Select all

function checkjava( )
{
	var javaEnabled;
	try
	{
		javaEnabled = navigator.javaEnabled();
	}
	catch( err )
	{
		return 'Not available';
	}
	return javaEnabled ? 'Enabled' : 'Disabled';
}
still returns 'Disabled' ... and in Add-ons still no Java Plug-in

roytam1
Fanatic
Fanatic
Posts: 160
Joined: 2015-03-11, 07:01
Location: Hong Kong

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by roytam1 » 2017-12-19, 14:06

mainziman wrote:no luck

this javascript function

Code: Select all

function checkjava( )
{
	var javaEnabled;
	try
	{
		javaEnabled = navigator.javaEnabled();
	}
	catch( err )
	{
		return 'Not available';
	}
	return javaEnabled ? 'Enabled' : 'Disabled';
}
still returns 'Disabled' ... and in Add-ons still no Java Plug-in
do you have it enabled in java control panel?

mainziman

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-20, 06:58

yes its enabled
Image
by the way: with Mozilla Firefox Java plugin works

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24470
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by Moonchild » 2017-12-20, 08:14

Do you have the java plugin enabled in your add-on manager?
If you can't set it to "always enable" because it's too old and known to be vulnerable, then it will be forced into "click to play" mode and you can't use it unless you actually embed the plugin and require user interaction (your script requires it to always be enabled).
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

mainziman

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-20, 08:55

Moonchild wrote:Do you have the java plugin enabled in your add-on manager?
Image
how?
If you can't set it to "always enable" because it's too old and known to be vulnerable, then it will be forced into "click to play" mode and you can't use it unless you actually embed the plugin and require user interaction (your script requires it to always be enabled).
first i'd like to see the plugin at all ...
it seems as it wouldn't exist

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24470
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by Moonchild » 2017-12-20, 12:03

Yeah, make sure the plugin is installed in a location known to the browser, or Pale Moon can't use it.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

mainziman

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-20, 12:56

in which location does it have to be, in order to be known by palemoon?

KingsMan
Apollo supporter
Apollo supporter
Posts: 35
Joined: 2017-08-13, 07:05

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by KingsMan » 2017-12-20, 16:22

consider upgrading to PM27
here is XP compatible build
https://github.com/Feodor2/Mypal/releases
get newer JRE
http://www.softpedia.com/get/Programmin ... l#download
version 8 and 7 is XP compatible

mainziman

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by mainziman » 2017-12-20, 18:39

as I said before, I know its an old release and for some reasons it must be exact this release: 1.6u20
and we are talking about latest Palemoon f. Atom/WinXP 26.5

visionhelp
Fanatic
Fanatic
Posts: 102
Joined: 2015-07-18, 18:14
Location: Germany

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by visionhelp » 2018-01-04, 09:59

When I am asked in which folder to install, Java, JRE, I choose the "Programs" folder. In all cases it is enough.

From my current experience of update to Pale Moon to 26.5 (Atom), but I am not sure, whether this is the same problem with Java or JRE, I have to do some settings manual in about:config.
(For Mozilla Add-Ons this setting, for "update Your browser" an other setting.)

If not receiving an answer to this from the Pale Moon forum, I would uninstall both, Java and Pale Moon, and clean all leaves until into the registry.

Then new install. But the follow of the installation could be a solvation.
First Java or first Pale Moon.

One of both COULD be a solvation. I am with You, there should be an easier solution than uninstall and have to try the different possible followings of installations.

(The ´perfect´- better: the best - version of Java for Pale Moon I could miss, too. I am just trying to install Add-Ons from Mozilla, Flash-Player for Facebook, Messenger for Facebook, which is not to install already.
And all Java slows down every browser, the newer the more slow, my experience already years ago, and missing some newer version, I never got a message, a web-site function does not work of a missing Java version. So I am curious about Your version.

And this XP compatible build PM27 I do not understand easy, no, not at all, how to install easy.)
Last edited by visionhelp on 2018-01-04, 10:47, edited 2 times in total.

visionhelp
Fanatic
Fanatic
Posts: 102
Joined: 2015-07-18, 18:14
Location: Germany

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by visionhelp » 2018-02-02, 15:25

mainziman wrote:Palemoon doesn't see my installed Java 1.6u20 (I know it is old and for some reasons it must be exact this release)
Hi mainziman,
would You like to tell me the special about Java 1.6u20?
(Perhaps a link for a download, too, thanks.)
I want to uninstall my version 7 or 8 and want to have only the really needed.
.NET Framework - ALL - already I did uninstall, because of a strange thing happened only to a Screen-Shot function, which did not work properly anymore. And after uninstalling .NET Framework it all works very well again, and the speed of the XP: only wonderful.
And this program, which wants a version .NET Framework, hm, let´s see, until now I did not need to re-install only one version of .NET Framework for any special program this as environment needed.

Thanks.

Could You solve Your problem?
Last edited by visionhelp on 2018-02-02, 15:27, edited 1 time in total.

dapgo
Fanatic
Fanatic
Posts: 106
Joined: 2016-10-11, 11:36

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by dapgo » 2018-02-05, 13:07

The Java 6 you want to use has to be of the same bits than Palemoon (32or 64bits) otherwise PM will not see Java.
On the other hand as far as I known Firefox "Plugins" detects the latest java installed in the system, so supposing that you have several versions installed and active (Control panel) you should see the lastest installed in your system but not necessarily the higher version


mainziman wrote:
Moonchild wrote:Do you have the java plugin enabled in your add-on manager?
Image
how?
If you can't set it to "always enable" because it's too old and known to be vulnerable, then it will be forced into "click to play" mode and you can't use it unless you actually embed the plugin and require user interaction (your script requires it to always be enabled).
first i'd like to see the plugin at all ...
it seems as it wouldn't exist

visionhelp
Fanatic
Fanatic
Posts: 102
Joined: 2015-07-18, 18:14
Location: Germany

Re: latest Palemoon f. Atom/WinXP 26.5 and Java?

Unread post by visionhelp » 2018-02-05, 21:43

"Windows Presentation Foundation" is the name of the Java plug-in. OK. Thanks for this info.

I never had this plug-in in any PaleMoon isntalled available. But without problems, it appears.


It is about Java 1.6u20, I understand.

Locked