v26.5.0 (Atom), problems with Add-Ons from Mozilla

Support board for people running on (retail/OEM) Windows XP (32/64-bit).

Moderator: satrow

Forum rules
This is a self-serve support board for our community. The development team can't provide any support for Windows XP (and compatible versions of Pale Moon for it) any longer.
visionhelp
Moon lover
Moon lover
Posts: 87
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

v26.5.0 (Atom), problems with Add-Ons from Mozilla

Postby visionhelp » Thu, 04 Jan 2018, 09:36

If wrong place, please, move.

After having solved, with the help of Lyceus, the problem the message of Facebook "update Your browser", now some add-ons from the Mozilla Add-Ons for Pale Moon message "cannot be installed, appears to be damaged".

This is my personal log to it:

Code: Select all

Add-Ons from Mozilla, for Pale Moon, message:
"You use version 24.9".

Pale Moon: about:config - "24.9" -
general.useragent.override.addons.mozilla.org
Mozilla/5.0 (Windows NT; x86; rv:24.9) Gecko/20100101 Firefox/24.9 (Pale Moon)
I change "/24.9 " to "57.0 ". Solves it.

But installing the messenger Add-Ons:
 "Messenger for Facebook™ von Baris Derin, could not get installed because of appearing to be damaged."
https://addons.mozilla.org/de/firefox/addon/facebook-messenger/

The same with:
Facebook Messanger von Bolaram Paul
https://addons.mozilla.org/de/firefox/addon/facebook-messanger/


For HTML5 on Facebook there is an alternative Flash-Player:
(this could be able to be used in Pale Moon for all sites with HTML5, my idea.)
https://addons.mozilla.org/de/firefox/addon/flash-video-player-on-facebook/

(No crashes anymore first from html5 and playing video, until there is a solution for to play html5 in Pale Moon.)
If it is to install: same as with the messenger Plug-Ins. Appears to be damaged.
They should be with to the Add-On page of Pale Moon, if no license-problems do avoid this.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20819
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: v26.5.0 (Atom), problems with Add-Ons from Mozilla

Postby Moonchild » Thu, 04 Jan 2018, 10:29

Don't expect Firefox 57 add-ons to work, ever. Firefox 57 only supports WebExtensions, and Pale Moon does NOT support WebExtensions. As such, none of the offered extensions on addons.mozilla.org when telling them you are using Firefox 57 will work.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

visionhelp
Moon lover
Moon lover
Posts: 87
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: v26.5.0 (Atom), problems with Add-Ons from Mozilla

Postby visionhelp » Thu, 04 Jan 2018, 10:42

These Add-Ons are for FF v48 and down.

It is from the Pale Moon own Add-Ons feature the offer of the Add-Ons of Mozilla for Pale Moon.

And I am not talking about the Add-On to work.
The download does not work, of appearing the Add-On is damaged, so the message. Sorry.

visionhelp
Moon lover
Moon lover
Posts: 87
Joined: Sat, 18 Jul 2015, 18:14
Location: Germany

Re: v26.5.0 (Atom), problems with Add-Ons from Mozilla

Postby visionhelp » Sun, 07 Jan 2018, 11:17

Off-topic:
(Off Topic: can not edit anymore? For to add it in the post one above.)


visionhelp wrote:These Add-Ons are for FF v48 and down.

visionhelp wrote:Add-Ons from Mozilla, for Pale Moon, message:
"You use version 24.9".

Pale Moon: about:config - "24.9" -
general.useragent.override.addons.mozilla.org
Mozilla/5.0 (Windows NT; x86; rv:24.9) Gecko/20100101 Firefox/24.9 (Pale Moon)
I change "/24.9 " to "57.0 ". Solves it.

Supplement:
With the setting ´back´ to "/24.9 " - [restart Pale Moon] - the add-on site messages the version-number of FF for which from a/the add-on is. (At about New Year 2017 to 2018.)
Last edited by visionhelp on Sun, 07 Jan 2018, 11:21, edited 2 times in total.


Return to “Windows XP support”

Who is online

Users browsing this forum: No registered users and 2 guests