Page 6 of 6

Re: Flash Plug-in

Posted: 2021-01-12, 21:06
by Moonraker
Captain Chicky wrote:
2021-01-12, 18:01
I've tried changing the dates in the NPSWFXX dll file, but to no avail. Either the previously suggested method on page 4 is somehow incorrect, or the invalidated signature still allows flash to get blocked. Is there any other method? :think:
Try using version 30 of flash and see if it works ok,.

Re: Flash Plug-in

Posted: 2021-01-12, 22:36
by Sob__
@Captain Chicky: Try again, it works. If you don't want to patch files by hand, you can download xdelta3-3.1.0-x86_64.exe.zip from https://github.com/jmacd/xdelta-gpl/releases/tag/v3.1.0 and attached file, and let it do the patching:

Code: Select all

xdelta3-3.1.0-x86_64.exe -d -s NPSWF32_32_0_0_465.dll patch32.xdelta NPSWF32_32_0_0_465.dll-patched
xdelta3-3.1.0-x86_64.exe -d -s NPSWF64_32_0_0_465.dll patch64.xdelta NPSWF64_32_0_0_465.dll-patched
Select 32/64 bit depending on your Pale Moon version. First make backup of old file and then replace it with patched version.

Re: Flash Plug-in

Posted: 2021-01-13, 22:04
by alkisg
UCyborg wrote:
2021-01-03, 22:49
So, find a hexadecimal string 000040463E6F7742, replace it with eg. 0000C02055148042, that will just change the year from 2021 to 2040.
I just signed up to say thanks for that! So, for Linux users that prefer the command line, that would be:

Code: Select all

xxd -p /usr/lib/adobe-flashplugin/libflashplayer.so | tr -d '\n' | sed 's/000040463e6f7742/0000c02055148042/' | xxd -p -r > /tmp/libflashplayer.so
sudo mv /tmp/libflashplayer.so /usr/lib/adobe-flashplugin/libflashplayer.so

Re: Flash Plug-in

Posted: 2021-01-14, 00:52
by nimanima
Thanks a lot! I have detected on an old backup harddrive of mine that in 2015 I had downloaded the offline install packages for Flash Player versions 17.0.0.134, 17.0.0.190, 17.0.0.191 and 18.0.0.203. After indeed the current version having been disabled under Windows 10, also in Pale Moon, I uninstalled 32 and re-installed 18 - so far it's running! So, if anybody wants/needs let me know.

Standalone 32, by the way still works.

Only that that both doesn't help at all for all the programmes that rely on the activex version implemented in Internet Explorer (for example Media Player Classic, Irfan View, SWF Player). Has anybody tested whether it's now possible to offline-install an older version of that activex-internet-explorer plugin?

Re: Flash Plug-in

Posted: 2021-01-15, 00:16
by Cassette
nimanima wrote:
2021-01-14, 00:52
Only that that both doesn't help at all for all the programmes that rely on the activex version implemented in Internet Explorer (for example Media Player Classic, Irfan View, SWF Player).
I too wondered what I needed to change to get MPC-HC to read swf files so I went to Google. The file you need to modify is the Flash.ocx file and it's the same change as with the plug in. The issue is the file is write protected so you will have to work around that.

Re: Flash Plug-in

Posted: 2021-01-15, 18:38
by alexisnik199111
alkisg wrote:
2021-01-13, 22:04
UCyborg wrote:
2021-01-03, 22:49
So, find a hexadecimal string 000040463E6F7742, replace it with eg. 0000C02055148042, that will just change the year from 2021 to 2040.
I just signed up to say thanks for that! So, for Linux users that prefer the command line, that would be:

Code: Select all

xxd -p /usr/lib/adobe-flashplugin/libflashplayer.so | tr -d '\n' | sed 's/000040463e6f7742/0000c02055148042/' | xxd -p -r > /tmp/libflashplayer.so
sudo mv /tmp/libflashplayer.so /usr/lib/adobe-flashplugin/libflashplayer.so
i tried this memont and it says the file cant be found,also i tried the manual patching but nothing..

i also tried this in the mms.cfg these but nothing

EOLUninstallDisable=1
SilentAutoUpdateEnable=0
AutoUpdateDisable=1
EnableAllowList=1
AllowListURLPattern=https://chat.greek-chat.gr/chat.php--->this is the flash site i want to unblock
AllowListUrlPattern=https://<server e.g. google.com/>
AllowListUrlPattern=https://<server e.g. yahoo.com/>