Page 1 of 1

link for sumatrapdf plugin

Posted: 2019-12-14, 09:13
by lavabo
Hello

i seek the plugin for palemoon and old versions of firefox
the url
ftp://archive:get@ftp.palemoon.org/misc ... .2-x64.zip
is 404

I have windwos 1809 64 bt edition and palemoon 28.8 64 bit and firefox 64 bit

Re: link for sumatrapdf plugin

Posted: 2019-12-14, 12:08
by billmcct
That link has been dead for some time. If you want Sumatra to work in 64 bit PM then install the 64 bit version of Sumatra.
https://www.sumatrapdfreader.org/downlo ... iewer.html

Re: link for sumatrapdf plugin

Posted: 2019-12-22, 08:59
by lavabo
SumatraPDF-2.5.2-install.exe gives me the plugin in 32bit, not the 64bit plugin

Re: link for sumatrapdf plugin

Posted: 2019-12-22, 09:48
by Frasier
lavabo wrote:
2019-12-22, 08:59
SumatraPDF-2.5.2-install.exe gives me the plugin in 32bit, not the 64bit plugin
Why not try downloading the 'SumatraPDF-3.1.2-64-install.exe' link?
SumatraPDF.png
found on the upper part of the page that billmcct linked to.

Re: link for sumatrapdf plugin

Posted: 2019-12-22, 13:16
by therube
viewtopic.php?f=47&t=20554

2.5.2 (.exe) is the last version to have the plugins.

Re: link for sumatrapdf plugin

Posted: 2019-12-22, 18:27
by Moonchild
If you need it you can easily build it from source. It's how I built it as well as a courtesy in the past. You just needs VS 2008, 2010 or 2012 to build it. build solutions are provided in the source.

Re: link for sumatrapdf plugin

Posted: 2019-12-23, 05:20
by lavabo
I was going to look at building the 64bit plugin myself, but apparently somebody did it for 3.0
https://sourceforge.net/projects/pcxfir ... umatraPDF/
so I hope I just update the .exe to the latest version
therube wrote:
2019-12-22, 13:16
viewtopic.php?f=47&t=20554

2.5.2 (.exe) is the last version to have the plugins.

Re: link for sumatrapdf plugin

Posted: 2019-12-23, 07:28
by lavabo
with the 64bit plugin at https://sourceforge.net/projects/pcxfir ... umatraPDF/ palemoon sees the plugin and uses sumatrapdf well.


But with Firefox ESR 64 bit, the plugin is not detected and it is still the adobe reader which is used.
I compiled myself the plugin 64bit for version 2.5.0 and firefox ESR 52.8.1 64 bit still does not see the plugin. I enabled ''plugin.load_flash_only'' and it works well for firefox 52 ESR 32bit with the official 32 bit plugin, but not with the 64bit plugin+64bit firefox. I do not understand why.

Re: link for sumatrapdf plugin

Posted: 2019-12-23, 11:08
by Moonchild
Firefox doesn't support plugins anymore. I Guess you missed that memo.
Also, we can really only help you with plugin issues on Pale Moon, not Firefox.

Re: link for sumatrapdf plugin

Posted: 2019-12-23, 18:57
by therube
Off-topic:
FF 52 ESR x64 only supported Flash & Silverlight plugins.
FF 52 ESR x86 would support other plugins (like Java...).

Re: link for sumatrapdf plugin

Posted: 2019-12-24, 07:13
by New Tobin Paradigm
Applications support NPAPI but plugins support applications. If there is not a 64bit version of a plugin for an application then well they don't support the 64bit version of that application. NPAPI hasn't changed in any dramatic way since out of process plugins about 10 years ago and 64bit has been stable in mozilla-based code for AT LEAST that long. So there is little excuse other than the makers of those plugins couldn't be bothered at the time and today everyone has all but stopped supporting NPAPI its self.