Portable ver 27.2.1 and Plug-ins

General discussion and compatibility support about browser plug-ins.
(e.g. Adobe Flash, Java plugin, authentication plugins, Unity)

Moderators: satrow, FranklinDM, Lootyhoof

User avatar
TwoTankAmin
Astronaut
Astronaut
Posts: 721
Joined: Wed, 23 Jul 2014, 13:56
Location: New York

Portable ver 27.2.1 and Plug-ins

Unread postby TwoTankAmin » Fri, 31 Mar 2017, 14:16

I am sort of easing my way into P M 27. At the same time I am moving from the 32 to the 64 bit version. I run Windows 7 Home Premium.

I was able to download the portable version to a brand new 32 gig USB 3 stick. I was able to get it looking pretty much identical to how I have ver. 26.5. I was also able to get all my Bookmark bar links set up as well. I can report that the 3 sites that would never work for me on 26.5 all work on Portable 27. That is the best news so far.

My next step was to try and get my preferred extensions and plug-ins installed. When I opened it plug-in section of Add-ons, I was surprised to see both Flash Player and Silverlight listed and having the same versions as I use in 26.5. I only have 6 plug-ins total. The two I just mentioned and then 2 for Nvidia, Java and 1 for my Canon Digi-cam. These 4 do not appear in Portable. I am not sure how to get these 4 Plug-ins added to Portable.

Next, I use the last available version of Flash EST 18.0.0382 and mostly have it set to never activate or ask to activate. I have Silverlight set the same way and have version 5.1.40728.2. Both these versions are way out of date. However, when I click on more for either plug-in, the page has no way to do an update. Moreover, if i click on check for updates, there are none shown for either of them. I realize there are no updates for ESR 18, but Adobe wants me to update to the current version of Flash i am sure. I hate Flash and am not a fan of Adobe, but still there should be updates that show up. The same for Silverlight. I am sure this is not how this should be working.

I should also say that my issues with plug-ins are a lot simpler than the ones with extensions. but that is for another thread elsewhere. I am still using 26.5 as my general browswer and only doing minimal things online in Portable until I can resolve security and privacy concerns.

And suggestions re the plug-ins is greatly appreciated. Bear in mind I am in the unsophisticated group of P M users and need any suggestions to be crystal clear and to assume I know next to nothing.

Edit 10.57 ESt: I solved the Java. DOH- I have 32 bit ver 26.5 but I am using 64 bit Portable. I was having issues downloading the latest Nvidia driver from their site and tried using the Portable version to do it. Nvidia told me I needed java and gave me the link. I have now downloaded 64 for Portable and at the same time it has updated the 32 bit version for 26.5 as well (I think).
“No one has ever become poor by giving.” Anonymous
“Everyone is entitled to his own opinion, but not to his own facts.”" Daniel Patrick Moynihan
"The good thing about science is that it’s true whether or not you believe in it." Neil DeGrasse Tyson

User avatar
billmcct
Lunatic
Lunatic
Posts: 404
Joined: Tue, 04 Sep 2012, 15:19
Location: Atlanta Georgia USA

Re: Portable ver 27.2.1 and Plug-ins

Unread postby billmcct » Fri, 31 Mar 2017, 15:13

The Java and Silverlight plugins are taken from the Operating system, The Flash plugin has to be installed for whichever PM your using (x86 or x64).
Win 7 x64 - Pale Moon 28x x32

User avatar
TwoTankAmin
Astronaut
Astronaut
Posts: 721
Joined: Wed, 23 Jul 2014, 13:56
Location: New York

Re: Portable ver 27.2.1 and Plug-ins

Unread postby TwoTankAmin » Fri, 31 Mar 2017, 16:01

billmcct wrote:The Java and Silverlight plugins are taken from the Operating system, The Flash plugin has to be installed for whichever PM your using (x86 or x64).


Wait a minute I am confused. I had the Flash and Silverlight plug-ins appear in Portable without my doing a thing. Somehow the Portable version found them on its own. I did not install Flash in portable. I am not even sure it is possible to install an ESR version any more? On the other hand, I had Java 32 bit installed because I am using 32 bit Pale Moon ver 26.5. I started with the 32 bit version of P M a couple of years back because it was more stable than the 64 bit version for a number of things. I needed reliable way more than fast. I never changed to the 64 bit version. The Java plug-in did not appear in the plug-in list for Portable until I did a Java download. However, I have Java in the plug-ins for P M 26.5.

Because I was having an issue updating my Nvidia GeForce driver from their site using 26.5, I tried using the Portable version. When I did, I got a message from the Nvidia site that I needed to download Java to run their driver diagnostic/download tool. They provided a link to Java which I clicked through to the Java download site. It automatically offered me the 64 bit version for downloaded. To get the Java plug-in into the Portable version, I had to download that 64 bit version of Java. I am assuming that I now have both 32 and 64 bit java on my system and the appropriate one gets used by my two different Pale Moon version set-ups. Further, when I downloaded 64 bit Java, I also had the Java Deployment Toolkit appear as well. It has the same red letter warning in Portable as in 26.5 and was also set to never activate.

Neither Flash nor Silverlight is anywhere near a current version and they are the same version number for both 26.5 and Portable. Both were listed the very first time I viewed plug-ins in order to install them in Portable.
“No one has ever become poor by giving.” Anonymous
“Everyone is entitled to his own opinion, but not to his own facts.”" Daniel Patrick Moynihan
"The good thing about science is that it’s true whether or not you believe in it." Neil DeGrasse Tyson


Return to “Browser plug-ins”

Who is online

Users browsing this forum: No registered users and 2 guests