Unity Web Player Error Again

General discussion and compatibility support about browser plug-ins.
(e.g. Adobe Flash, Java plugin, authentication plugins, Unity)

Moderators: satrow, Lootyhoof, Andrew Gilbertson

Orlanth
New to the forum
New to the forum
Posts: 1
Joined: Tue, 15 May 2018, 08:54

Unity Web Player Error Again

Postby Orlanth » Tue, 15 May 2018, 09:08

Since the newest update last week Unity Web Player is again failing to run, it give the "Failed to update Unity Web Player" error. This error occurs consistently on different machines when attempting to use Facebook to run the games Shop Heroes or Forge of Gods. Uninstallng and reinstalling Unity Web Player does not solve the problem. This error has appeared and disappeared with new Pale Moon update versions since January 2018. On average, if the bug is present, it disappears when the next version of Pale Moon is released. As the error appears only with certain updates of Pale Moon and occurs on multiple applications running Unity, I infer that some type of flag is being set or reset at compilation of new versions of Pale Moon.

--Why would Pale Moon attempt to get an updated version of the Unity plug in when there is no update going on?

--Is there a flag in Pale Moon that can be set to Not check for plug in updates?

Thanks for any help!

User avatar
hitokage
Moonbather
Moonbather
Posts: 69
Joined: Sat, 03 May 2014, 02:19
Location: Frederick, MD

Re: Unity Web Player Error Again

Postby hitokage » Wed, 16 May 2018, 10:40

Orlanth wrote:--Why would Pale Moon attempt to get an updated version of the Unity plug in when there is no update going on?

--Is there a flag in Pale Moon that can be set to Not check for plug in updates?

The Unity plug-in itself, not Pale Moon, looks for updates under certain circumstances. If the Unity content was created with a newer version or the plug-in was updated for security reasons - that is supposed to be what will trigger the plug-in to want to update. However it also seems to happen if there is some kind of connection (or content) problem - basically something not loading properly for whatever reason or something wrong server side.

The last version of the plug-in is 5.3.8 and they aren't supporting it anymore. If it isn't a connection or server issue, reinstalling normally fixes it, but outside that it's difficult to troubleshoot as an end-user as everything else may be working fine. You can try reinstalling using the full version installer if you haven't already - x86 full installer and x64 full installer.
Last edited by hitokage on Wed, 16 May 2018, 10:42, edited 2 times in total.


Return to “Browser plug-ins”

Who is online

Users browsing this forum: No registered users and 2 guests