Add-on compatibility and current versions

General discussion, compatibility and contributed extensions.

Moderators: satrow, Lootyhoof, Andrew Gilbertson

User avatar
New Tobin Paradigm
Banned user
Banned user
Posts: 4417
Joined: Tue, 09 Oct 2012, 19:37

Add-on compatibility and current versions

Postby New Tobin Paradigm » Thu, 29 Mar 2012, 19:46

A few notes about add-on compatibility and current versions of Pale Moon:

This is being rewritten.. For now please check http://addons.palemoon.org/firefox/incompatible/ for known issues with add-ons with Pale Moon 25.

DO NOT POST IN THIS THREAD!

Original version of this post for previous versions of Pale Moon (24.x and older)
If you can't install an add-on in Pale Moon because it's stated to "not be compatible", try a previous version

Because Pale Moon does not follow Mozilla's rapid release schedule, and because add-on compatibility is (very) regularly broken by Mozilla's incessant tinkering with user interface code, you may find that the latest published version of add-ons are possibly not compatible with the current released version of Pale Moon. You should check the "version information" at the bottom of pages on addons.mozilla.org to see version compatibility details, and compare the major version of compatibility with the major version of Pale Moon (e.g. Pale Moon 20.2 is compatible with Firefox 20.0 as far as add-ons is concerned, even though security and updates have it on par with Firefox 22.0 in other respects). There is a good reason Pale Moon's version numbering is the way it is - a major version will always reflect the version of Firefox that is the most compatible in terms of extensions/toolkit.

If your Pale Moon compatible version is not listed for the latest version of the add-on, click "See complete version history" and check the latest compatible version of the add-on (the button should turn green or yellow, allowing you to install).

Just because add-ons are marked "by default compatible" since the Firefox code base v10 doesn't automatically mean that they are compatible.

Although a large number of add-ons indeed have little trouble being plugged into a newer version of the browser, there are and always will be some add-ons that are not going to play nice. This can be because of changes in the browser UI, browser code, theme, default settings or any number of other things, or a combination thereof.

>> Always check carefully if an add-on has been marked as compatible with the version of the browser you are trying to use it on <<

Try to use a development, beta or experimental version first if you are having problems with an add-on that is not marked as specifically compatible. Quite often these "dev" version have changes in them that make them compatible with what used to be "Beta Firefox" "Aurora Firefox" or "Nightly Firefox" versions that have since become "release" versions of the code base.
I hate Pod Six. Tch, I don't even know why we have a Pod Six. Total suck Pod.
[ ニュー・トビン・パラダイム ]

Return to “Browser extensions”

Who is online

Users browsing this forum: No registered users and 6 guests