ηMatrix/eMatrix support thread

General discussion, compatibility and contributed extensions.

Moderators: satrow, Lootyhoof, FranklinDM

coffeebreak
Board Warrior
Board Warrior
Posts: 1808
Joined: 2015-09-26, 04:51
Location: U.S.

Re: ηMatrix/eMatrix support thread

Unread post by coffeebreak » 2019-07-24, 22:02

vannilla wrote:
2019-07-24, 11:11
Can you try this one: https://gitlab.com/vannilla/ematrix/-/tags/3.0.1
Doesn't work.
Clicking "trash can" + "Apply changes" initially puts a line through the personally-added list.
(list is found here).

After that, if you close the dashboard and reopen it, or navigate away from the Hosts files tab and then return to it, all hosts lists disappear from the dashboard, as shown (though not from the database). This didn't happen with v3.0.0.
eM-no-hosts.png
Trying to remove the list in v3.0.1 produced this error:

Code: Select all

Error: ReferenceError: unregisterSource is not defined
Source File: chrome://ematrix/content/js/assets.js
Line: 810

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-07-25, 11:59

Hopefully this is the last one: https://gitlab.com/vannilla/ematrix/-/tags/3.0.3

If you are examining the database to make sure the lists are removed, check the "assetSource" and "assetCache" rows, as those are the ones used internally (the row with the list's URL as the name holds the actual data, but it should not be used directly unless it's registered.)

coffeebreak
Board Warrior
Board Warrior
Posts: 1808
Joined: 2015-09-26, 04:51
Location: U.S.

Re: ηMatrix/eMatrix support thread

Unread post by coffeebreak » 2019-07-26, 04:15

vannilla wrote:
2019-07-25, 11:59
Hopefully this is the last one: https://gitlab.com/vannilla/ematrix/-/tags/3.0.3
This does appear to have fixed it.

Concerning the sqlite database, I didn't check it. I think your judgment of what's in there (or not) will be more reliable than mine.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-20, 23:51

Fun fact: until now I thought I had released version 3, but then I realized I didn't.
Version 3.0.3 (the first stable release of version 3) is officially out.
Sorry about the delay, but as I said I was sure I had done this already...

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-22, 17:38

As a default setting I block scripts globally including first-party scripts (the script box is dark red). With the previous version (2.1.0) I was able to use Duckduckgo and Startpage, with the latest version (3.0.3) both sites don't work and when I do a search I only get a blank page, ddg should've been redirected to its html version but it doesn't (at least when I perform the search in the address bar). I tried with a clean profile without success.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-23, 12:31

Unfortunately, right now I'm away until next week and the most technological thing I have is my phone (which I'm using to post this), so I can't look into it.

Does it work if you use the per-site mode? What if you enable first-party scripts?
I know it can be annoying having to browse like this, but if I can't locate the issue it can't be fixed once I'm back home.
You just need to do that for the search engine, then you can revert back to your usual settings (if there aren't other problems, that is.)

By the way, 3.0.3 is special because you can revert back to 2.x without losing or corrupting anything (at least in theory), so if nothing works you can go back (make sure automatic updates are disabled.)

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-23, 17:42

I reverted to 2.1.0 and disabled auto-updates yesterday. Yes if I enable first party scripts for both sites everything works fine, but this enables ads in Startpage. It's not something urgent, version 2.1.0 works perfectly so I can wait an eventual fix when you have some free time after your vacation.

I did a search with Startpage and the Error Console open trying to see differences in errors and warning from one version to the other, and the only one that I noticed is the lack in the latest version of a CSP which says that child-src has been deprecated and worker-src and frame-src should be used instead. In 3.0.3 child-src has been removed and there are some changes regarding frame-src, it might be the latter changes which causes the bug. I'm not a coder so probably what I said makes no sense.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-23, 19:50

Actually I'm not too practical about CSP either, so I trusted the error message and tried to fix(?) it.
While it's true that I could've kept it as it was, I didn't like seeing that message every time I opened the console. If it's the cause there's no real reason not to revert it.
Once I'm home that'll be the first thing I'll examine.

Michaell
Fanatic
Fanatic
Posts: 122
Joined: 2018-05-26, 18:13

Re: ηMatrix/eMatrix support thread

Unread post by Michaell » 2019-08-24, 22:40

FWIW, with 3.03 on PM 28.6.0 Win10, DDG works for me with JS blocked for the site (didn't try global). And that was entering search term on the page not from address bar.
Win10home(1709), PM28.4port

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-25, 07:45

@Michaell
You didn't try what I mentioned on my post. Yes ddg works from its web page, but it doesn't from the address bar. Startpage doesn't work either from its web page or from the address bar.

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-30, 13:07

The last working version is from commit of 11 July 2019 named "Change child-src to frame-src".

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-30, 14:44

moonshiner wrote:
2019-08-30, 13:07
The last working version is from commit of 11 July 2019 named "Change child-src to frame-src".
Thanks for checking out different commits! It really helped.
I made a tentative fix, please check it out: https://gitlab.com/vannilla/ematrix/-/tags/3.0.4

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-30, 16:33

Searching with DDG from the address bar now works, while with Startpage's home page search I still get a blank page.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-30, 17:00

moonshiner wrote:
2019-08-30, 16:33
Searching with DDG from the address bar now works, while with Startpage's home page search I still get a blank page.
Startpage seems to require scripts to work properly.
Can you see if enabling scripts shows any result? If so, the problem is with the website itself rather than with the extension.

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-30, 17:13

With version 2.1.0 and the version I mentioned above Startpage works. The script box is dark red and the rest of the script's column is light red. It works disabling javascripts from about:config or using a text browser like "links" or w3m. It works even with newer version of ematrix disabling css though.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-08-31, 09:56

moonshiner wrote:
2019-08-30, 17:13
With version 2.1.0 and the version I mentioned above Startpage works. The script box is dark red and the rest of the script's column is light red. It works disabling javascripts from about:config or using a text browser like "links" or w3m. It works even with newer version of ematrix disabling css though.
Well this is confusing. I don't know what could cause this behaviour (or at least it's not obvious.)
Does it happen only when searching from the website itself or even when using the browser's search plugin?

moonshiner
Moongazer
Moongazer
Posts: 14
Joined: 2019-05-26, 16:35

Re: ηMatrix/eMatrix support thread

Unread post by moonshiner » 2019-08-31, 11:21

It happens both ways. I tried firefox with umatrix and startpage works. I also tried with an new palemoon's profile, installed ublock and I get the same blank page when I disable inline scripts. Yes it's very confusing because with ematrix 2.1.0 or umatrix all scripts are blocked including inline scripts at least according to the logger. You can ignore this issue I'll stick with 2.1.0, thanks for the effort anyway.

User avatar
adesh
Astronaut
Astronaut
Posts: 709
Joined: 2017-06-06, 07:38

Re: ηMatrix/eMatrix support thread

Unread post by adesh » 2019-09-01, 18:33

Actually offending commit is not the one reported above, but the parent of that commit:

Code: Select all

commit 52603bc5bc8831d0ec0f901f1279871599f877d9
Author: Alessio Vanni <vannilla@firemail.cc>
Date:   Wed Jun 19 18:59:25 2019 +0200

    Fix typos and reinstate some old declarations
https://gitlab.com/vannilla/ematrix/com ... 1599f877d9

I think if you just fix the typo and don't reinstate anything, everything should work as earlier.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-09-02, 19:27

The thing is, I had to reinstate them because the extension wouldn't behave as expected.
I can't work on this for a few days due to personal circumstances, so if there's someone really bothered by this and want to see it fixed as quickly as possible it would be nice if they could try adesh's suggestion and report back.
If not, work will resume probably next week or so.
Sorry for the trouble.

vannilla
Astronaut
Astronaut
Posts: 618
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Unread post by vannilla » 2019-09-09, 19:22

New test version: https://gitlab.com/vannilla/ematrix/-/tags/3.0.5

I tested it by doing the following:
  • Disabled all scripts for DuckDuckGo (the tile with the "scripts" word is dark red)
  • Searched something using the search plugin
  • Disabled all scripts for Startpage (the tile with the "scripts" word is dark red)
  • Searched something using the (new) search plugin
The resulting pages had clearly less features than those with scripts enabled, but I never got a blank page (i.e. I used search terms that would give some results and I got them.)
Please check it out. If it works it will be released to the masses.

Post Reply