Can´t install languages for spell check.

General discussion, compatibility and contributed extensions.

Moderators: satrow, FranklinDM, Lootyhoof

User avatar
dclarkg
Newbie
Newbie
Posts: 4
Joined: 2018-06-04, 17:02

Can´t install languages for spell check.

Unread post by dclarkg » 2018-06-04, 17:22

Hello, I'm creating this topic in this section but i´m not sure if dictionaries are add-ons or extensions. If the section is incorrect then feel free to move it to the correct one.

Basically my issue is that I did a clean windows reinstall a few days ago and reinstalled Palemoon, if I try to add a new language for the spell check (right click word, languages, add dictionary) it takes me to the mozilla/firefox dictionary page but it tells me that I need firefox to install any languages.

The last time I did a windows reinstall was in February, back then I installed palemoon and installed the dictionary language from the mozilla/firefox page without any issues and the languages kept working with every update. If anyone has a solution or workaround please let me know.

Thx!

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24235
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Can´t install languages for spell check.

Unread post by Moonchild » 2018-06-04, 17:42

More addons.mozilla.org strict checking at work :/
I'm afraid this is entire in Mozilla's hands, they are blocking any and all browsers that aren't Firefox at the moment.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Goodydino
Lunatic
Lunatic
Posts: 497
Joined: 2017-10-10, 21:20

Re: Can´t install languages for spell check.

Unread post by Goodydino » 2018-06-04, 20:16

If you go to the All Versions page and right-click the install button, you should be able to download the installer. I just tried it for the British English dictionary, loading with Pale Moon, and got the .xpi file.

User avatar
dclarkg
Newbie
Newbie
Posts: 4
Joined: 2018-06-04, 17:02

Re: Can´t install languages for spell check.

Unread post by dclarkg » 2018-06-04, 21:09

Moonchild wrote:More addons.mozilla.org strict checking at work :/
I'm afraid this is entire in Mozilla's hands, they are blocking any and all browsers that aren't Firefox at the moment.
I think this is happening since their quantum or whatever update if I´m not mistaken
Goodydino wrote:If you go to the All Versions page and right-click the install button, you should be able to download the installer. I just tried it for the British English dictionary, loading with Pale Moon, and got the .xpi file.
Thank you for the Tip, however I don´t find the "All versions" page. If you can share the link I´ll appreciate it.

Goodydino
Lunatic
Lunatic
Posts: 497
Joined: 2017-10-10, 21:20

Re: Can´t install languages for spell check.

Unread post by Goodydino » 2018-06-05, 21:40

Go to the bottom of the page for the dictionary description and click on "Version Information". Right-click the green button for the first item and choose Save. You can install the .xpi file manually by opening the add-ons window and dragging the file onto it.

User avatar
dclarkg
Newbie
Newbie
Posts: 4
Joined: 2018-06-04, 17:02

Re: Can´t install languages for spell check.

Unread post by dclarkg » 2018-06-06, 01:07

Goodydino wrote:Go to the bottom of the page for the dictionary description and click on "Version Information". Right-click the green button for the first item and choose Save. You can install the .xpi file manually by opening the add-ons window and dragging the file onto it.
It worked like a charm! I didn't do "right click > save as" on the green button, since it says "add to firefox" I just clicked it and Palemoon picked it up. Is working properly. Many thanks!
Moonchild wrote:More addons.mozilla.org strict checking at work :/
I'm afraid this is entire in Mozilla's hands, they are blocking any and all browsers that aren't Firefox at the moment.
I'm quoting you Moonchild so you can be aware of this workaround.

User avatar
JoelAustralia
New to the forum
New to the forum
Posts: 2
Joined: 2019-02-08, 00:28

Re: Can´t install languages for spell check.

Unread post by JoelAustralia » 2019-02-08, 00:58

Was just seeking out information on this same issue. I have just changed computers and uploaded Pale Moon again but can no longer load the correct English Dictionary. The fix above no longer works as all the previous versions also direct you to download Firefox. I dont use many addons, just a British/Australian spell check and a downloader helper. But it no seems I can no longer do either of these on Pale Moon which sort of will sadly render it unusable for me. I really dont want to go back to Firefox after they turned themselves into a Chrome Clone. Pale Moon has always been the way to go. Any help around this dilemma would be greatly appreciated? Is there possibly even an import/export function on Pale Moon like Firefox once had. My old computer is dying a slow death but if I can ever get it to start again that may be an option but direct downloading would be preferable. If I download Pale Moon from a British site would the correct dictionary already be installed or are all versions American? Many thanks.

PS One thing I did notice is that when you click on the "Add Dictionary" link it takes you to Mozilla where you find nothing works. Maybe if these are rendered inoperable now the link should take you to a place one the Pale Moon site that states no dictionaries available? Having been trying to fix this for the past hour or so that may help warn in advance this is happening.

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Can´t install languages for spell check.

Unread post by yami_ » 2019-02-08, 11:05

Most dictionaries will hopefully be available from APO later this month, meanwhile here are links to en-AU and en-GB dictionaries.
cat came back from Berkeley waving flags -- rob pike

Goodydino
Lunatic
Lunatic
Posts: 497
Joined: 2017-10-10, 21:20

Re: Can´t install languages for spell check.

Unread post by Goodydino » 2019-02-08, 22:30

I just got the en-GB language pack from the Pale Moon site and it works.

User avatar
JoelAustralia
New to the forum
New to the forum
Posts: 2
Joined: 2019-02-08, 00:28

Re: Can´t install languages for spell check.

Unread post by JoelAustralia » 2019-02-09, 05:31

yami_ wrote:Most dictionaries will hopefully be available from APO later this month, meanwhile here are links to en-AU and en-GB dictionaries.
The link you provided worked perfectly and instantly. Thank you so very much.

I just need to find a compatible downloader helper and Im all set to go. I so hate changing computers but they always give out in the end.

User avatar
loxodont
Astronaut
Astronaut
Posts: 500
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: Can´t install languages for spell check.

Unread post by loxodont » 2019-02-13, 14:30

As the dictionary/spell check question turned up in another forum post, it might be helpful here that legacy dictionaries are available on the newer thunderbird.net site. From the *.xpi filenames (...sm-tb-fx.xpi, while fx=Firefox) they should in most cases also work in Pale Moon.

https://addons.thunderbird.net/en-US/th ... age-tools/

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 5683
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Can´t install languages for spell check.

Unread post by New Tobin Paradigm » 2019-02-13, 15:18

If you can wait until after the weekend or at the latest end of next week.. We will have forked dictionaries on the Add-ons Sites...
Image
- The universe is a spheroid region, 705 meters in diameter. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/

User avatar
loxodont
Astronaut
Astronaut
Posts: 500
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: Can´t install languages for spell check.

Unread post by loxodont » 2019-02-13, 16:38

New Tobin Paradigm wrote:.. We will have forked dictionaries on the Add-ons Sites...
Seen your Phoebus project previews recently :thumbup: - that's good news; really waiting for it. I didn't know dictionaries will be included too.
It will surely reduce more of the trendy legacy add-ons confusion.

User avatar
dclarkg
Newbie
Newbie
Posts: 4
Joined: 2018-06-04, 17:02

Re: Can´t install languages for spell check.

Unread post by dclarkg » 2019-04-23, 16:01

Hello

A while ago I created this thread because dictionaries could not be installed on Pale Moon but the latest workaround isn't working anymore. If you attempt to install the xpi file from the Thunderbird site I get the "not supported" error. Back in February this was working properly. Any Ideas?

Thx

User avatar
Aube Bleue
Moonbather
Moonbather
Posts: 59
Joined: 2015-11-13, 03:36
Location: Québec

Re: Can´t install languages for spell check.

Unread post by Aube Bleue » 2019-04-23, 20:09

dclarkg wrote:
2019-04-23, 16:01
If you attempt to install the xpi file from the Thunderbird site I get the "not supported" error.
You need to install the PRE-WebExtension versions of these dictionaries. As a reminder, Pale Moon does *not* support WebExtensions.

For example, in the case of en-AU, pick v2.2 -- not v2.2.1webext:
https://addons.thunderbird.net/en-US/th ... ersion-2.2
Linux 64-bit and 32-bit user.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 5683
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Can´t install languages for spell check.

Unread post by New Tobin Paradigm » 2019-04-23, 20:26

I'll get all new dictionaries up very soon. I been busy.
Image
- The universe is a spheroid region, 705 meters in diameter. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/

User avatar
Aube Bleue
Moonbather
Moonbather
Posts: 59
Joined: 2015-11-13, 03:36
Location: Québec

Re: Can´t install languages for spell check.

Unread post by Aube Bleue » 2019-04-23, 20:30

New Tobin Paradigm wrote:
2019-04-23, 20:26
I'll get all new dictionaries up very soon. I been busy.
I know you are! Thanks, Tobin.
Linux 64-bit and 32-bit user.

Post Reply