Ads Load and Disappear with ABL

General discussion, compatibility and contributed extensions.

Moderators: Lootyhoof, FranklinDM

Locked
CharmCityCrab
Banned user
Banned user
Posts: 638
Joined: 2015-06-25, 00:47

Ads Load and Disappear with ABL

Post by CharmCityCrab » 2015-12-09, 21:18

Hey, just a quick question:

I've noticed that when first loading pages on Pale Moon with Ad-Block Latitude installed, that sometimes ads will appear briefly and then disappear as the page continues to load. Most often, this happens shortly after launching the browser. Is this expected behavior? A bug? A potential problem with my personal setup?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27869
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Ads Load and Disappear with ABL

Post by Moonchild » 2015-12-09, 21:24

This is expected behavior with v3.0.* of ABL because of its bootstrapped/lazy-loading nature.
Come 3.5.*, this should no longer happen because of the change in architecture that loads the extension in its entirety before any pages are loaded.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

CharmCityCrab
Banned user
Banned user
Posts: 638
Joined: 2015-06-25, 00:47

Re: Ads Load and Disappear with ABL

Post by CharmCityCrab » 2015-12-09, 23:14

Moonchild wrote:This is expected behavior with v3.0.* of ABL because of its bootstrapped/lazy-loading nature.
Come 3.5.*, this should no longer happen because of the change in architecture that loads the extension in its entirety before any pages are loaded.
Thanks!

Locked