Incompatible Theme for Pale Moon 31.0

Add-ons for Pale Moon and other applications
General discussion, compatibility, contributed extensions, themes, plugins, and more.

Moderators: FranklinDM, Lootyhoof

User avatar
darkrats
Newbie
Newbie
Posts: 6
Joined: 2019-08-29, 17:51

Incompatible Theme for Pale Moon 31.0

Unread post by darkrats » 2022-05-10, 10:26

Just update my PM to version 31.0 and my favorite them (Moonfox3) no longer works. Tried installing from the official site, but no luck there. If anyone else uses this theme and finds one that works, please post a link.

I found a temporary workaround, until the official updated theme becomes available.

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2728
Joined: 2012-06-28, 01:20

Re: Incompatible Theme for Pale Moon 31.0

Unread post by ron_1 » 2022-05-10, 11:36

See this post from the main theme developer: https://forum.palemoon.org/viewtopic.php?f=46&t=28016&start=40#p227031

The pertinent part:
I will update all of the themes (hopefully in preparation of rather than a reaction to) v31 at some point, but it will need to be sporadic I'm afraid. I've been quite busy with some major turbulence in personal matters the past month or so.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4670
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: Incompatible Theme for Pale Moon 31.0

Unread post by Night Wing » 2022-05-10, 13:19

@ darkrats

I'm in the same boat as you since my favorite theme, Micro Moon 1.10.2 only goes to version 29. So as a workaround, since I use a 27" external monitor which allows me to have lots of folders on the Bookmarks Toolbar, I'm now using DM Franklin's "Milestone 10" 1.2.1 theme which supports the 31 versions.

Like you, I'm hoping my favorite theme gets updated to support the 31 versions.
Linux Mint 20.3 (Una) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
Bendy_Demon
Moongazer
Moongazer
Posts: 14
Joined: 2022-03-18, 21:12

Re: Incompatible Theme for Pale Moon 31.0

Unread post by Bendy_Demon » 2022-05-10, 16:47

Yeah, I was a bit bummed when I couldn't get my favorite themes which is either Tangomoon or Walnutty but am glad to hear it will be forthcoming eventually.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4670
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: Incompatible Theme for Pale Moon 31.0

Unread post by Night Wing » 2022-05-10, 20:07

Since "Milestone 10" v1.2.1 is a little hard for me to read because of my poor eyesight on Pale Moon 31.0, I've switched to "Moonscape" v7.2.1 which my eyesight likes better on Pale Moon (31.0).
Linux Mint 20.3 (Una) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
TheRealMaestro
Fanatic
Fanatic
Posts: 116
Joined: 2019-08-13, 00:30
Location: Cosy Island

Re: Incompatible Theme for Pale Moon 31.0

Unread post by TheRealMaestro » 2022-05-13, 19:45

I am in the same place: the Qute themes are obsolete, and I have been using Fox 2: The Moon instead. Lootyhoof has been selfless for improving the themes that he has notwithstanding his mother’s loss. I wish him the best in this, and would like to thank him for his devotion.
Browser: Pale Moon (Pusser’s repository for Debian)
Operating System: Linux Mint Debian Edition 4 (amd64)
Hardware: HP Pavilion DV6-7010 (1400 MHz, 6 GB)

alex04
Moonbather
Moonbather
Posts: 57
Joined: 2013-09-16, 16:09

Re: Incompatible Theme for Pale Moon 31.0

Unread post by alex04 » 2022-05-14, 09:55

maybe the theme will work if you change max version to 31.* in install.rdf ?

https://i.ibb.co/ZgD1yTX/moonfox.png

with bandizip portable its easy to do this.

User avatar
moonbat
Knows the dark side
Knows the dark side
Posts: 3913
Joined: 2015-12-09, 15:45
Contact:

Re: Incompatible Theme for Pale Moon 31.0

Unread post by moonbat » 2022-05-15, 07:06

alex04 wrote:
2022-05-14, 09:55
maybe the theme will work if you change max version to 31.* in install.rdf ?
No, themes are more strict about version compatibility because of specific CSS changes and what applies to extensions won't work with them. You may end up borking the look of the browser in unexpected ways resulting in it being unusable if you force install an incompatible theme. Just wait for it to be updated, else you'll have to find a different one.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20.1 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
AutoPageColor|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

Post Reply