Sage Feed Reader no longer works on PM 28

General discussion, compatibility and contributed extensions.

Moderators: satrow, FranklinDM, Lootyhoof

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Fri, 17 Aug 2018, 08:07

Hello, ALL --

For years I have been using the Sage addon as my RSS reader with both Firefox and then PM after I left FF. Sage 1.5.2.1 is the latest version that works with PM 27.9.4 64 bit Windows 8.1. Later versions of Sage do not work at all. Yesterday 16 Aug 2018 I updated to PM 28. All versions of Sage have now stopped working completely with PM 28. I had to go back to PM 27.9.4 to get it to work again. I use Sage quite a bit so I really don't want to lose it if I update PM to 28.

Does anyone have any workarounds here? Otherwise it looks as though I will not be able to update past PM 27.9.4.

I appreciate any help. Thanks to all.

Uburoi

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader no longer works on PM 28

Unread postby riiis » Fri, 17 Aug 2018, 16:51

uburoi wrote:Sage 1.5.2.1 is the latest version that works with PM 27.9.4 64 bit Windows 8.1. ... All versions of Sage have now stopped working completely with PM 28.

All versions of Sage use the keyword "const" a lot in their javacript files. Beginning with PM 28, Pale Moon has stopped supporting such use of the keyword "const", when "const" is used as a variable ("var"). To fix, all such uses of the keyword "const", in the Sage extension, should be replaced with the keyword "var".

Off-topic:
Latest versions of Sage may be uninstallable from AMO, because AMO requires Firefox 38 or higher, to install, whereas Pale Moon is viewed by AMO as Firefox 27.0 ("general.useragent.override.addons.mozilla.org" in Pale Moon version 28.0.0 (64-bit) is set at a default value of "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0"). Thus, to install the latest version of Sage in Pale Moon, first download Sage version 1.5.5 from AMO. Then install Sage version 1.5.5 in Pale Moon from the downloaded file. Note that, in order to work in Pale Moon 28, Sage version 1.5.5 needs to be changed or forked, in the same manner as Sage 1.5.2.1. And other changes to Sage may also be necessary.
Last edited by riiis on Fri, 17 Aug 2018, 16:54, edited 1 time in total.

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Re: Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Sat, 18 Aug 2018, 03:58

Hello, Sir --

Thanks for such a quick reply. I followed your directions and it still does not work. So I'm back to Sage 1.5.2.1 and PM 27.9.4 for now. But thanks again for your help.

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader no longer works on PM 28

Unread postby riiis » Sat, 18 Aug 2018, 16:34

uburoi wrote:it still does not work. So I'm back to Sage 1.5.2.1 and PM 27.9.4 for now.

I tried all recent versions of Sage in PM 28, from Sage 1.5.2.1 forward. Sage initially displays available feeds in the Pale Moon sidebar. Unfortunately, while Sage 1.5.2.1 appears compatible with the Pale Moon 27 sidebar, no version of Sage appears compatible with the Pale Moon 28 sidebar.

The latest version of Sage (version 1.5.5) installs and works well, and without modification, in Basilisk. So, Sage perhaps can be fixed to install and run in Pale Moon 28, as well. But more likely, it may be time to move on to another feed reader.

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Re: Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Sun, 19 Aug 2018, 05:54

riiis wrote:
But more likely, it may be time to move on to another feed reader.


Sadly, I think you are correct. It appears that no version of Sage works with PM 28.

I have also tried all the latest versions of a Sage fork called Sage ++ by Higmmer. Same result.

If I need to use another feed reader, I would like it to be as similar to Sage as possible. By chance, do you or anyone else here have any suggestions?

Thanks so much for your help. Take care.

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader no longer works on PM 28

Unread postby riiis » Mon, 20 Aug 2018, 16:57

uburoi wrote:

The latest version of Sage (version 1.5.5) installs and works well, not only in Basilisk, but also in Firefox 52 ESR and Waterfox 56. So, the Sage Feed Reader appears to work in Pale Moon and all related browsers, except for Pale Moon 28. Accordingly, I took another and more-detailed look at Sage version 1.5.5. And, with the following changes to Sage version 1.5.5, Sage now appears to work well in Pale Moon 28.

Change line 31 of overlay.xul file. Change from:

Code: Select all

oncommand="SidebarUI.toggle('viewSageSidebar');"/>

Change to:

Code: Select all

oncommand="toggleSidebar('viewSageSidebar');"/>

Code: Select all

  <broadcasterset id="mainBroadcasterSet">
    <broadcaster id="viewSageSidebar"
      autoCheck="false"
      label="&sage.toolbarLabel;"
      type="checkbox" group="sidebar"
      sidebarurl="chrome://sage/content/sidebar.xul"
      sidebartitle="&sage.sidebarTitle;"
      oncommand="toggleSidebar('viewSageSidebar');"/>
  </broadcasterset>
"SidebarUI.toggle"might be deprecated code, removed from Pale Moon 28, but still supported by the related browsers. Regardless, unless other major issue(s) show up with Sage version 1.5.5, I should be able to submit a fix to APMO, within a short few days, for use of "Sage Feed Reader for Pale Moon" in PM 28.

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Sage Feed Reader now at APMO

Unread postby riiis » Mon, 20 Aug 2018, 23:25

Sage Reader 1.0.0 is now available at Pale Moon add-ons.

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Re: Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Tue, 21 Aug 2018, 05:01

Wonderful!! Both your fix and your fork are working beautifully. Before now Sage 1.5.5 would not work with either PM 27.9.4 or PM 28. Now Sage works with both.

Thanks you so much for your help. I've stoppped pulling out my hair.

Best regards. Stay well.

Uburoi

User avatar
Fermat
New to the forum
New to the forum
Posts: 1
Joined: Tue, 21 Aug 2018, 10:57
Location: Portsmouth, UK

Re: Sage Feed Reader no longer works on PM 28

Unread postby Fermat » Tue, 21 Aug 2018, 11:02

riiis, you are a life saver! I can't thank you enough.

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Re: Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Tue, 21 Aug 2018, 23:51

Hello, riiis --

In working with your fork, I noticed that in your options menu, the category "Settings" which is in the original Sage addon, is missing. If it is not too much of a hassle for you, is there any way you can add that to your fork? It is quite useful, at least to me.

Thanks for considering. Again many thanks for your efforts here.

Take care.

Uburoi

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader now at APMO

Unread postby riiis » Wed, 22 Aug 2018, 03:12

Sage Reader 1.1.0 is now available at Pale Moon add-ons. To change Sage Reader settings, click the Sage Reader "Options" button in Pale Moon's "Add-ons Manager" tab.

User avatar
bradley
New to the forum
New to the forum
Posts: 1
Joined: Wed, 22 Aug 2018, 04:50

Re: Sage Feed Reader no longer works on PM 28

Unread postby bradley » Wed, 22 Aug 2018, 04:52

Great release!
Best regards. Stay well.
Last edited by bradley on Wed, 22 Aug 2018, 08:34, edited 1 time in total.

uburoi
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: Thu, 07 Jan 2016, 22:16
Location: California

Re: Sage Feed Reader no longer works on PM 28

Unread postby uburoi » Wed, 22 Aug 2018, 06:01

riiis ---

Thank you, thank you, thank you!

Take care.

Uburoi

NickFortune
Moongazer
Moongazer
Posts: 13
Joined: Fri, 04 Dec 2015, 15:10
Location: here

Re: Sage Feed Reader no longer works on PM 28

Unread postby NickFortune » Wed, 29 Aug 2018, 08:25

With 1.1 and 1.2 the sidebar links no longer work for me. I generally middle click them to open in a new tab, but they won't open at all.

1.0 works well however, so I downgraded and I've turned off automatic updates.

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader no longer works on PM 28

Unread postby riiis » Wed, 29 Aug 2018, 15:04

NickFortune wrote:With 1.1 and 1.2 the sidebar links no longer work for me. I generally middle click them to open in a new tab, but they won't open at all.

By "sidebar links no longer work", are you referring to the feed item list (feed detail) in the lower panel of the Sage sidebar? If so, the links in this feed item list work perfectly for me (including middle click to open in a new tab).
sage-settings.jpg
sage-settings.jpg (52.75 KiB) Viewed 232 times

Try opening the "sidebar layout" menu in the Sage sidebar. "Feed Item List" should be checked. If "Feed Item List" is not checked, the lower panel of the Sage sidebar will not appear.

Note, if "Render feeds in contents area" is checked, the "Feed Item List" is opened in a tab, instead of (or in addition to) opening in the sidebar. This setting is not available in Sage Reader version 1.0.0. If neither "Feed Item List" nor "Render feeds in contents area" is checked, clicking on a feed, in the top panel of the Sage sidebar, does nothing. So, one or the other, or both, of these options should be checked.
Last edited by riiis on Wed, 29 Aug 2018, 15:37, edited 1 time in total.

NickFortune
Moongazer
Moongazer
Posts: 13
Joined: Fri, 04 Dec 2015, 15:10
Location: here

Re: Sage Feed Reader no longer works on PM 28

Unread postby NickFortune » Mon, 03 Sep 2018, 08:11

I always middle-click on the entry in the upper panel. It's always worked in the past.

User avatar
jorgepp
New to the forum
New to the forum
Posts: 1
Joined: Mon, 10 Sep 2018, 07:40

Re: Sage Feed Reader no longer works on PM 28

Unread postby jorgepp » Mon, 10 Sep 2018, 07:43

uburoi wrote:Hello, ALL --

For years I have been using the Sage addon as my RSS reader with both Firefox and then PM after I left FF. Sage 1.5.2.1 is the latest version порно that works with PM 27.9.4 64 bit Windows 8.1. Later versions of Sage do not work at all. Yesterday 16 Aug 2018 I updated to PM 28. All versions xxx of Sage have now stopped working completely with PM 28. I had to go back to PM 27.9.4 to get it to work again. I use Sage quite a bit so I really don't want to lose it if I update PM to 28.

Does anyone have any workarounds here? Otherwise it looks as though I will not be able to update past PM 27.9.4.

I appreciate any help. Thanks to all.

Uburoi


With 1.1 and 1.2 the sidebar links no longer work for me. I generally middle click them to open in a new tab, but they won't open at all.

1.0 works well however, so I downgraded and I've turned off automatic updates.

riiis
Lunatic
Lunatic
Posts: 413
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Sage Feed Reader no longer works on PM 28

Unread postby riiis » Mon, 10 Sep 2018, 16:39

NickFortune wrote:I always middle-click on the entry in the upper panel. It's always worked in the past.

jorgepp wrote:With 1.1 and 1.2 the sidebar links no longer work for me. I generally middle click them to open in a new tab, but they won't open at all. 1.0 works well however, so I downgraded and I've turned off automatic updates.

Note the "Render feeds in contents area" preference ("extensions.sage.renderFeeds" in "about:config"):
    When this preference is set to "true", clicking on a feed in the Sage upper panel opens feeds in an existing tab.
    When this preference is set to "true", middle-clicking on a feed in the Sage upper panel opens feeds in a new tab.
    When this preference is set to "false", clicking (or middle-clicking) on a feed, in the Sage upper panel, does ABSOLUTELY NOTHING.
    When this preference is set to "false", the "Feed Item List" preference must be enabled or set to "true" (so that feed items can be opened exclusively, by clicking or middle-clicking, from the Sage lower panel).
By default, Sage 1.0.0 sets the preference "extensions.sage.renderFeeds" to "true". By default, both Sage 1.2.0 and Sage 1.1.0 set the preference "extensions.sage.renderFeeds" to "false". Thus, by downgrading (from Sage 1.2.0 or Sage 1.1.0) to Sage 1.0.0, users only accomplish the minimal task of toggling the preference "extensions.sage.renderFeeds" from "false" to "true". That task would be accomplished more easily by checking the menu item "Render feeds in contents area" (in Sage 1.2.0 sidebar options).
render-feeds-in-content-area.jpg
render-feeds-in-content-area.jpg (48.86 KiB) Viewed 106 times
Last edited by riiis on Mon, 10 Sep 2018, 16:45, edited 1 time in total.

NickFortune
Moongazer
Moongazer
Posts: 13
Joined: Fri, 04 Dec 2015, 15:10
Location: here

Re: Sage Feed Reader no longer works on PM 28

Unread postby NickFortune » Wed, 12 Sep 2018, 12:53

Thanks for the info.

Did the default for that setting change? I have absolutely no recollection of ever messing around with sage's about:config settings.

Just trying to work out why there was a difference between 1.0 and 1.2.

[edit]

Looking at about:conf, the renderFeeds setting is at its default. In 1.0 that default is true, in 1.2 it is false. Manually setting it to true fixes the problem as you describe.

Thanks again.
Last edited by NickFortune on Wed, 12 Sep 2018, 13:09, edited 1 time in total.


Return to “Browser extensions”

Who is online

Users browsing this forum: BenFenner, Google [Bot], Isengrim, Potkeny and 8 guests