Page 4 of 6

Re: [Release] Australium

Posted: 2017-08-05, 00:06
by LimboSlam
Hey there Lootyhoof, I got a little issue. But first, thanks for all your hard and awesome work on these wonderful themes! :thumbup: :)

For awhile, I've ignored this issue because as the web moves towards HTML5 video/audio, there is becoming less content to run Flash with. However, some websites haven't made that move, yet. It's especially annoying when you need to use Flash or Unity Web Player and you have this minor glitch:
Minor Fix.jpg
Minor Fix.jpg (40.41 KiB) Viewed 2245 times


Offending website: https://www.maketecheasier.com/chrome-os-vs-windows10s/

Re: [Release] Australium

Posted: 2017-08-05, 00:31
by Lootyhoof
Hmm..interesting. I'll take a look into it as I find time and get a fix released. :)

EDIT: Odd, I can't see this popup on that site. Are there other sites where this appears? Does this happen with other themes?

Re: [Release] Australium

Posted: 2017-08-05, 05:50
by Moonchild
With the combination of "ask to activate" for flash, and allowing ads, the plugin indicator is shown briefly and then removed again on the default theme. A blank doorhanger like that means that the plugin it wants to ask permission for was present and has been removed again (probably using flash for tracking there). It's probably also got something to do with the fact that mixed active content is being blocked on that same page (meaning the ad networks in use are not compatible with https).
I'm not sure why the indicator wouldn't be removed again in your theme, since that is not something the theme itself touches?

Re: [Release] Australium

Posted: 2017-08-05, 22:58
by Lootyhoof
Looking into this further (using Australium with Flash ask to activate and ads allowed), I don't see any issue on this page. The indicator briefly flashes as Moonchild mentions above, then goes again. If you manage to click the indicator before it goes away it opens the standard click-to-play plugin dialog (which shows correctly), though this of course also removes itself at the same time as the indicator.

LimboSlam, are you using any extensions which may cause this? Please try to disable them and see if the issue persists.

Also, not mentioned in your post (but can see in the screenshot and confirmed), I'll fix the margins on that close button for the doorhangers at some point too (I thought I'd done this a while ago to be honest...). :thumbup:

Re: [Release] Australium

Posted: 2017-08-06, 00:23
by LimboSlam
Well, that is the issue, I can't reproduce it. At least, not easily. I will try to find another website, disable any possible add-on conflicts, and report back.

Re: [Release] Australium

Posted: 2017-08-07, 15:02
by superA
Off-topic:
Clearly off topic here, but I can't stand not asking this..
How did you manage to enable FF's tracking protection, in your browser ? :eh:

Re: [Release] Australium

Posted: 2017-08-07, 16:37
by Lootyhoof
superA wrote:
Off-topic:
Clearly off topic here, but I can't stand not asking this..
How did you manage to enable FF's tracking protection, in your browser ? :eh:
Off-topic:
If you're referring to the shield icon in the address bar, that's not tracking protection, but instead mixed content blocking. At some point Mozilla decided to use the mixed content icon for tracking protection, though since that isn't in Pale Moon I took a few liberties. ;)

Re: [Release] Australium

Posted: 2017-08-07, 20:23
by superA
Thanks Looythoof, good to know.

Re: [Release] Australium

Posted: 2017-08-08, 02:08
by LimboSlam
Yeah, I have no idea how this appears or why? I am using Stratum 1.2.7.
Stratum.jpg
Stratum.jpg (40.08 KiB) Viewed 2069 times
Stratum 2.jpg
Stratum 2.jpg (43 KiB) Viewed 2069 times
See offending website: https://www.facebook.com/BleepingComput ... 2931919543.

Re: [Release] Australium

Posted: 2017-09-27, 11:23
by alex04
Looks like there is a problem with PM 27.5.0 and option "use a custom style". When enabled the colour in the preview is always bright green, doesnt matter what colour you choose. And in status bar the colour is still dark blue, the default one.

Tested with new profile with only Astralium installed

Im using 32bit PM 27.5.0 on W7 64bit.

Re: [Release] Australium

Posted: 2017-09-27, 21:57
by Lootyhoof
Thanks for reporting this. Looks like fallout from recent changes to the statusbar code - I'll look into it and hopefully get an update out soon.

Re: [Release] Australium

Posted: 2017-09-28, 06:43
by gracious1
alex04 wrote:Looks like there is a problem with PM 27.5.0 and option "use a custom style". When enabled the colour in the preview is always bright green, doesnt matter what colour you choose. And in status bar the colour is still dark blue, the default one.

Tested with new profile with only Australium installed
Lootyhoof wrote:Looks like fallout from recent changes to the statusbar code
I noticed exactly the same problem with PM 27.5.0 on Ubuntu 14.04 using these themes in a clean profile: Camimoon, XMoon, and Noia Moon.

(I picked those at random. Is the problem, then, with every theme?)

When I switched back to the Default theme (and restarted the browser), the problem went away.

Re: [Release] Australium

Posted: 2017-09-28, 21:49
by Lootyhoof
Unfortunately, yes, this will affect all themes. I'll be working over time to get this fixed.

Re: [Release] Australium

Posted: 2017-10-20, 16:03
by Lootyhoof
Australium has been updated to v4.0.1. This makes the minimum required Pale Moon version be 27.5.0.

What's new?
- fix statusbar progressmeter
- sync devtools styling with default

Re: [Release] Australium

Posted: 2017-10-20, 18:54
by LimboSlam
Has the margins been fixed for the exit button?

Thanks again for the release! :thumbup:

Re: [Release] Australium

Posted: 2017-10-20, 19:31
by Lootyhoof
LimboSlam wrote:Has the margins been fixed for the exit button?
What exit button is this? I don't recall being reported such an issue.

Re: [Release] Australium

Posted: 2017-10-20, 22:43
by LimboSlam
Lootyhoof wrote:What exit button is this? I don't recall being reported such an issue.
See here: https://forum.palemoon.org/viewtopic.ph ... 30#p118834. I believe it's still a reoccurring issue.

Re: [Release] Australium

Posted: 2017-10-20, 23:46
by Lootyhoof
Ah, whoops, I did miss this. I'll fix it next time I get chance, sorry.

Re: [Release] Australium

Posted: 2017-10-21, 13:41
by Lootyhoof
LimboSlam wrote:
Lootyhoof wrote:What exit button is this? I don't recall being reported such an issue.
See here: https://forum.palemoon.org/viewtopic.ph ... 30#p118834. I believe it's still a reoccurring issue.
Hmm...it looks normal to me for basically any doorhanger notifications, see below as example:

Image

Was this only an issue on that problematic popup (that I never could reproduce...)?

Re: [Release] Australium

Posted: 2017-10-21, 21:08
by LimboSlam
Lootyhoof wrote:Hmm...it looks normal to me for basically any doorhanger notifications.... Was this only an issue on that problematic popup (that I never could reproduce...)?


The doorhangers I am reproducing are flash based, sorry about the miscommunication. But uhh..I thought I had included a link? See below please:
Test site.jpg
Test site.jpg (44.73 KiB) Viewed 1678 times
https://ninjakiwi.com/Games/Action/Play ... ult-4.html
Test site #2.jpg
Test site #2.jpg (44.34 KiB) Viewed 1678 times
https://www.silvergames.com/en/police-pursuit-3d
Test site #3.jpg
Test site #3.jpg (45.88 KiB) Viewed 1678 times
http://pbskids.org/curiousgeorge/busyday/span_allie/