Old Firefox themes no longer work with PM 28?

Anything about browser themes, both Full Themes and Lightweight Themes (personas) should go here.

Moderators: satrow, FranklinDM, Lootyhoof

User avatar
Weboh
Moon lover
Moon lover
Posts: 84
Joined: Tue, 30 Sep 2014, 20:29
Location: Florida

Old Firefox themes no longer work with PM 28?

Unread postby Weboh » Mon, 10 Sep 2018, 00:03

I have a lot of old Firefox themes I like switch between from time to time. I was able to use them with PM 27 (not without glitches here and there, sure, but they were small enough that I could live with it. In PM 28, I'm no longer able to enable the themes.

I used to use an extension that lets Pale Moon ignore version numbers in extension files and let me install it anyway (https://addons.mozilla.org/firefox/addon/checkcompatibility/). That extension appears to still be compatible, but I'm unable to activate any theme not specifically targeting PM 28.

What's especially strange about this is I think I remember seeing a post that said PM 28 would just ignore Firefox compatibility and let you install every Firefox extension. Did I misunderstand? Are extension conflicts the reason I can't enable these themes? Thoughts?

mrnhmath
Hobby Astronomer
Hobby Astronomer
Posts: 29
Joined: Wed, 21 Jun 2017, 02:37

Re: Old Firefox themes no longer work with PM 28?

Unread postby mrnhmath » Mon, 10 Sep 2018, 00:29

Pale Moon doesn't support non-PM themes and extensions and one should not expect that FF add-ons will work on PM without changes, as they have long diverged since then. Get someone to port them over or do it yourself.

http://developer.palemoon.org/Add-ons:T ... te/Changes

User avatar
Weboh
Moon lover
Moon lover
Posts: 84
Joined: Tue, 30 Sep 2014, 20:29
Location: Florida

Re: Old Firefox themes no longer work with PM 28?

Unread postby Weboh » Mon, 10 Sep 2018, 01:08

I know Pale Moon doesn't officially support them, but they've worked well enough in the past (though not without issues since they weren’t officially supported) without me needing to make changes to the themes themselves—just changes to Pale Moon like making it ignore the reported version compatibility of extensions. I don't think the theme platform would have changed so dramatically in this version of Pale Moon that the themes shouldn't work at all; after all, some of themes I'm using haven't been updated since 2012 and still worked up to today.

Goodydino
Lunatic
Lunatic
Posts: 388
Joined: Tue, 10 Oct 2017, 21:20

Re: Old Firefox themes no longer work with PM 28?

Unread postby Goodydino » Tue, 11 Sep 2018, 19:34

I thought Theme Compatibility Provider was supposed to adapt themes to work at least partially. it worked for me with PM 27. Also, I am still using the Noiamoon theme quite happily. I edited install.rdf to increase the max version to preclude Pale Moon refusing to use it. You can do the same thing to whatever addon you want to use. Quite often that works.

User avatar
Lootyhoof
Themeist
Themeist
Posts: 1138
Joined: Thu, 09 Feb 2012, 23:35
Location: United Kingdom

Re: Old Firefox themes no longer work with PM 28?

Unread postby Lootyhoof » Wed, 12 Sep 2018, 12:37

Just because they worked before doesn't mean they'll work now, too much has changed for that. If a theme hasn't been created (or forked) specifically for Pale Moon then it's highly likely it won't work.

It's not "just a few changes." Check the Theme Changes page linked above if you want evidence. These themes do need active maintenance to remain compatible with us, and even those made for earlier Pale Moon versions would look wrong in the latest version.

User avatar
Weboh
Moon lover
Moon lover
Posts: 84
Joined: Tue, 30 Sep 2014, 20:29
Location: Florida

Re: Old Firefox themes no longer work with PM 28?

Unread postby Weboh » Wed, 12 Sep 2018, 14:12

Aw. That's unfortunate. I don't see any changes on that page that seem to me like they'd make the themes wholly incompatible, but I acknowledge that I'm not a theme pro like you are.

Is there any chance there will be an extension like Theme Compatibility Provider or Moon Tester Tool that will make the themes at least usable? I don't expect the themes to function exactly like one designed for Pale Moon would, but it would be nice to at least have the option. That way we can have more themes to use without you having to maintain even more. :P

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4778
Joined: Tue, 09 Oct 2012, 19:37

Re: Old Firefox themes no longer work with PM 28?

Unread postby New Tobin Paradigm » Thu, 13 Sep 2018, 01:32

Compatibility for Firefox extensions mean almost nothing to XPIProvider on Pale Moon.. Themes and other types of add-ons need not apply.

Themes aren't programmed they are styled as in css which must match the id and class selectors of the very structure of a xul document.. If they don't match they won't be styled or styled properly.

This is very much application specific where as with extensions which do have their application specific targets for doing UI controls or modifing and extending application specific feature also largely rely on APIs of the platform.

Also, checkcompatibility won't work anymore as the ability to globally disable compatibility for add-ons has been altered.
Image

== We got to install microwave ovens / Custom kitchen deliveries / We got to move these refrigerators / We got to move these color TVs ==
http://binaryoutcast.com/ | http://thereisonlyxul.org/

User avatar
Weboh
Moon lover
Moon lover
Posts: 84
Joined: Tue, 30 Sep 2014, 20:29
Location: Florida

Re: Old Firefox themes no longer work with PM 28?

Unread postby Weboh » Thu, 13 Sep 2018, 20:19

Ah. Checkcompatibility not working any more really explains why they stopped working. Does anyone know of another extension that will do the same thing in Pale Moon 28?

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4778
Joined: Tue, 09 Oct 2012, 19:37

Re: Old Firefox themes no longer work with PM 28?

Unread postby New Tobin Paradigm » Thu, 13 Sep 2018, 21:02

No. And there won't be one.
Image

== We got to install microwave ovens / Custom kitchen deliveries / We got to move these refrigerators / We got to move these color TVs ==
http://binaryoutcast.com/ | http://thereisonlyxul.org/


Return to “Themes”

Who is online

Users browsing this forum: No registered users and 1 guest