Tangerinemoon 2.1.0 strange behaviour

Anything about browser themes, both Full Themes and Lightweight Themes (personas) should go here.

Moderators: satrow, Lootyhoof, Andrew Gilbertson

Goodydino
Moon lover
Moon lover
Posts: 85
Joined: Tue, 10 Oct 2017, 21:20

Tangerinemoon 2.1.0 strange behaviour

Postby Goodydino » Tue, 21 Nov 2017, 20:56

Tangerinemoon 2.1.0 will not display any close buttons or findbar buttons unless the files with the images are renamed (and renamed in the stylesheets also). I renamed close.png to close2.png and find.png to find2.png. I also had to use a different navigator throbber with a different filename. Why is that? I have never before had to rename a file to get an image to appear in a theme. Even with a different file, the static throbber does not appear, but the animated one does. What is going on with that?

User avatar
Lootyhoof
Themeist
Themeist
Posts: 938
Joined: Thu, 09 Feb 2012, 23:35
Location: United Kingdom

Re: Tangerinemoon 2.1.0 strange behaviour

Postby Lootyhoof » Tue, 21 Nov 2017, 21:55

Can't confirm here:

Image

Have you tried disabling other add-ons/stylings?

Goodydino
Moon lover
Moon lover
Posts: 85
Joined: Tue, 10 Oct 2017, 21:20

Re: Tangerinemoon 2.1.0 strange behaviour

Postby Goodydino » Wed, 22 Nov 2017, 18:57

Why would I need to do that? I do not have that problem with any other theme (and never have with Firefox, Thunderbird or SeaMonkey themes). I have no theme-specific settings in userChrome.css. The other 8 themes I added to Pale Moon are fine.
I fixed the static throbber. It now appears. Still does not explain why I had to use a different filename, however.

User avatar
Lootyhoof
Themeist
Themeist
Posts: 938
Joined: Thu, 09 Feb 2012, 23:35
Location: United Kingdom

Re: Tangerinemoon 2.1.0 strange behaviour

Postby Lootyhoof » Wed, 22 Nov 2017, 21:59

We need to test with a clean profile, is why. Just because it works for other themes does not always mean it works for all of them.

Goodydino
Moon lover
Moon lover
Posts: 85
Joined: Tue, 10 Oct 2017, 21:20

Re: Tangerinemoon 2.1.0 strange behaviour

Postby Goodydino » Thu, 23 Nov 2017, 21:56

I had forgotten, but I had to import whole global and mozapps directories from another theme into Tangerinemoon in order to change the background colours, since I do not like the sytem colours of MacOS. (Of course, I had to rewrite most of chrome.manifest.) I believe I used those from Aeromoon. Aeromoon is working fine. I shall just leave it, since all the images appear now, even if I did have to rename some of them.
I have changed colours in most of the themes I am using.


Return to “Themes”

Who is online

Users browsing this forum: No registered users and 1 guest