Compatibility Reports for Post-v25 Pale Moon

Anything to do with the Pale Moon add-ons website. (addons.palemoon.org)
Not for questions about add-ons themselves!

Moderators: satrow, Lootyhoof, FranklinDM

Forum rules
Important: This board is for specifics regarding the add-ons website (addons.palemoon.org) and not to report extension compatibility issues or discuss different extensions.
Please only post here when your topic is directly related to the add-ons website service so our moderators don't have to move your posts all the time...
User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4981
Joined: Tue, 09 Oct 2012, 19:37

Compatibility Reports for Post-v25 Pale Moon

Unread postby New Tobin Paradigm » Sun, 19 Oct 2014, 05:44

PLEASE READ THE FOLLOWING CAREFULLY


We are working as fast as we can to provide alternatives such as Pseudo-Static versions of your add-ons that have stopped working. Please give us time to make sure that the problems have been recognized and that they have been fully resolved with a pseudo-static version before we upload them to the site as to not provide a broken version. This also applies to the seeming lag time between reporting here and appearing on the Known incompatible page on the add-ons site.

=== Why is this needed? ===
We are working on providing extensions in a clear, organized and future-proof way to our users. To make the process of submitting, processing and publishing extensions as smooth and fast as possible, we need a clear and structured report of each extension, without duplicates, and without a number of different edited copies or user-modified extensions floating about through other channels. We are trying to keep the "Wild West" factor to a minimum.

=== What to check before reporting? ===
In addition to checking whether an extension has already been reported or not, you should also check if an older version of an extension is available for Pale Moon. Especially if you come from a later version of Firefox that has required extension developers to cater to the Australis user interface, the "latest" or "current" version that addons.mozilla.org offers may not be available for or compatible with Pale Moon.
You should always check if an older version of the extension (listed under Version Information -> See complete version history) is available on Mozilla's add-ons site that is compatible with "Firefox 24.9", and install that version, instead of the "latest". Check the buttons to install - a green or yellow one means the extension version is compatible, a grey one means it is not.

Although some people may suggest to disable compatibility checking and force-install the latest version anyway, this is strongly discouraged because the extension will likely not function properly!

=== Post your report in the following format ===
Name: Name of Add-on
Type: Extension
Issue: What apparently is not working
Cause: If you have done any research include this part otherwise don't
Workaround: If you have attempted a fix include this part otherwise don't
AMO: Link to the add-on (please strip the locale part such as /en-US/ and please put inside a url tag so it is not shortened)

=== Guidelines ===
  • Your report should be ONLY in the above format.
  • Reports not following the above format will be deleted without comment.
  • Repeated reports will be deleted without comment.
    --- PLEASE check the known incompatible page, PREVIOUS posts in this thread and the ARCHIVE thread FIRST - see resources below).
  • Off-topic discussion will either be moved to different threads if significant, or deleted without comment if not
  • Please DO NOT, UNDER ANY CIRCUMSTANCES, LIST "Upgraded to Pale Moon 25" or similar as a cause or your report will be deleted without comment.
    If you do not know the exact cause, leave it blank!
  • Please DO NOT, UNDER ANY CIRCUMSTANCES, LIST "Downgrade to Pale Moon 24.x" or similar as a workaround or your report will be deleted without comment.
    If you do not know of a workaround on the current version of Pale Moon, leave it blank!
    If you do know of a workaround, please try to test and verify that what you have done completely fixes the issue, where possible.
  • DO NOT, UNDER ANY CIRCUMSTANCES, POST XPI Files (edited add-ons) or advise users to modify the add-on themselves here or ANYWHERE on the forum. The attachments/links will be removed.

If you wish to help out with a potential fix or edited xpi file send a Private Message (PM) with them attached to ME or if you wish to have others test versions likewise use the private messaging system.

NO REQUEST FOR SUPPORT TO PALE MOON PROJECT STAFF WILL BE ACCEPTED REGARDING THE USE OF A ROUGE EDITED ADD-ON OR EDITING THEM YOURSELF - YOU HAVE BEEN WARNED

=== Other Resources ===

Please know that despite these strict rules, guidelines, and extreme measures we appreciate your efforts and value your contributions.
Thank you! :thumbup:
New Tobin Paradigm

Help I'm steppin' into the Twilight Zone / Place is a madhouse, feels like being cloned
My beacon's been moved under moon and star / Where am I to go, now that I've gone too far

http://binaryoutcast.com/ | http://thereisonlyxul.org/

majkl

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby majkl » Tue, 08 Mar 2016, 14:28

Tab Groups Helper already working on newest version.(Best plugin author ever, he fixed it in notime.)

User avatar
Antonius32
Add-ons Team
Add-ons Team
Posts: 695
Joined: Sun, 25 May 2014, 11:18
Location: Netherlands

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Antonius32 » Thu, 02 Jun 2016, 18:36

2016-06-02

I've added the following add-ons to the "PENDING" section within the list of add-ons with known compatibility issues:

  • Archive.is Now
  • Complete YouTube Saver
  • Customize Titlebar
  • Download status
  • QuickPasswords
  • Random Bookmark
  • SoundCloud Player
  • YouTube Video and Audio Downloader
I've added the following add-ons to the "WORKAROUNDS" section:

  • Biscuit
  • CacheViewer
  • Element Hiding Helper for Adblock Plus
  • FlashGot Mass Downloader
  • iMacros for Firefox
  • ReloadEvery
  • TabGroups Manager
I've moved the following add-ons to the "FIXED" section:


The list is updated regularly to reflect the current status of reported add-ons, so be sure to check back every now and then.

Thanks for reporting your issues and workarounds, everyone!
:thumbup:
Image

Isarpilot

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Isarpilot » Tue, 12 Jul 2016, 00:59

Name: Pinterest Pin-it Button from the pinterest.com site
Type: Extension
Issue: Not compatible. Won't install.
Cause: -
Workaround: -
AMO: https://assets.pinterest.com/ext/Pinterest_Firefox.xpi

CraigPD
Lunatic
Lunatic
Posts: 289
Joined: Tue, 01 Jan 2013, 19:03
Location: Mexico

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby CraigPD » Sun, 14 Aug 2016, 04:30

Try it. I've been using Download Statusbar v0.9.10 without ill-effect since 2013 and I doubt anything would have changed since AOM started signing. The pending compatibility issue may relate to Download_Status_Bar which is altogether different.

User avatar
LimboSlam
Board Warrior
Board Warrior
Posts: 1028
Joined: Mon, 09 Jun 2014, 04:43
Location: USA

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby LimboSlam » Sun, 14 Aug 2016, 05:01



Yes this one works, but is a bit outdated and so it may have some issues; obsolete is what is looks like, IMHO though.

CraigPD wrote:The pending compatibility issue may relate to Download_Status_Bar which is altogether different.


And yes, this one is definitely compatible with Pale Moon as the developer has fixed several bugs pertaining to us. Plus I personally use it.
With Pale Moon by my side, surfing the web is quite enjoyable and takes my headaches away! :)
God is not punishing you, He is preparing you. Trust His plan, not your pain.#‎TrentShelton #‎RehabTime

ibrokemypie

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby ibrokemypie » Thu, 18 Aug 2016, 06:31

Name: Enpass
Type: Extension
Issue: Does not install, have checked for versions.
AMO: https://addons.mozilla.org/en-US/firefox/addon/enpass-password-manager/

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4981
Joined: Tue, 09 Oct 2012, 19:37

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby New Tobin Paradigm » Tue, 23 Aug 2016, 03:04

ibrokemypie wrote:Name: Enpass
Type: Extension
Issue: Does not install, have checked for versions.
AMO: https://addons.mozilla.org/en-US/firefox/addon/enpass-password-manager/


This extension was never compatible with Pale Moon. It is also a Jetpack extension.
New Tobin Paradigm

Help I'm steppin' into the Twilight Zone / Place is a madhouse, feels like being cloned
My beacon's been moved under moon and star / Where am I to go, now that I've gone too far

http://binaryoutcast.com/ | http://thereisonlyxul.org/

mhubbard
Newbie
Newbie
Posts: 3
Joined: Wed, 14 Sep 2016, 13:27

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby mhubbard » Wed, 14 Sep 2016, 13:35

Name: Scientific Calculator
Type: Extension
Issue: Icon does not appear on Status Bar
Cause:
Workaround: Use version 5.0.2.1
AMO: https://addons.mozilla.org/firefox/addon/scientific-calculator/versions/

Baerbeisser

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Baerbeisser » Sun, 09 Oct 2016, 11:10

Name: NoScript Anywhere NSA++
Type: Extension
Issue: Checkboxes in window "whitelisted sites" are resetted after page-reload. Useless this way. On Pale Moon mobile.
AMO: https://noscript.net/nsa/#download
Last edited by Baerbeisser on Sun, 09 Oct 2016, 12:34, edited 2 times in total.

Baerbeisser

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Baerbeisser » Sun, 09 Oct 2016, 11:21

Name: uMatrix
Type: Extension
Issue: Button to its Dashboard does not work on Pale Moon mobile.
Workaround: put chrome://umatrix/content/dashboard.html in urlbar
AMO: https://addons.mozilla.org/firefox/addon/umatrix/

dark_moon

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby dark_moon » Sun, 09 Oct 2016, 13:43

A lot of addons doesn't work in Android Pale Moon.
Also this thread is about the desktop version.

And NoScript for Android isn't maintained. A uMatrix for Android doesn't exist.

Baerbeisser

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Baerbeisser » Sun, 09 Oct 2016, 14:14

dark_moon wrote:A lot of addons doesn't work in Android Pale Moon.
Also this thread is about the desktop version.

And NoScript for Android isn't maintained. A uMatrix for Android doesn't exist.


Android Pale Moon is no Post-v25 Pale Moon? :shock:
@NoScript: Really a pity, there are now nearly as much Android devices as PCs. Sadly i dont find any contact information.
@uMatrix: seems i was a little too fast to answer. I assumed, cause uBlock works on FF & PM for Android and Self-Destructing Cookies had a similiar issue a version prior, its the same case with uMatrix too.

I really should have a full-blown Linux on my mobile device...

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4981
Joined: Tue, 09 Oct 2012, 19:37

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby New Tobin Paradigm » Sun, 09 Oct 2016, 14:20

You guys do know that when I get up I am gonna blow all this irrelevant discourse away right? It clearly states that this thread has special rules and sidebar discussion and improper reports get deleted without question or comment..
New Tobin Paradigm

Help I'm steppin' into the Twilight Zone / Place is a madhouse, feels like being cloned
My beacon's been moved under moon and star / Where am I to go, now that I've gone too far

http://binaryoutcast.com/ | http://thereisonlyxul.org/

nimanima
Moon lover
Moon lover
Posts: 82
Joined: Tue, 26 Jan 2016, 21:59

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby nimanima » Wed, 23 Nov 2016, 00:23

Pale Moon 27.0 (recognized by Mozilla Add-Ons page as "Firefox 27")

Too Many Tabs 1.4.3.1 (newest version for versions lower than Firefox 29)

https://addons.mozilla.org/de/firefox/a ... d.1-signed

Works properly with Pale Moon 26.5 (recognized by Mozilla Add-Ons page as "Firefox 24.9")

For me one of the most essential add-ons, so I would be really thankful for a fix. There seems to be no alternative.

User avatar
Nigaikaze
Keeps coming back
Keeps coming back
Posts: 943
Joined: Sun, 02 Feb 2014, 22:15
Location: Chicago, IL, USA

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Nigaikaze » Wed, 23 Nov 2016, 01:17

Hey Tobin, considering the changes in PM between v25 and v27, maybe we should create a new thread for post-v27 compatibility reports? Just a thought.

markusGE

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby markusGE » Wed, 23 Nov 2016, 11:40

Name: New Tab Tools
Type: Extension
Issue: Fails to show interface on quick dial page, no tiles or options button
AMO: http://addons.mozilla.org/firefox/addon/new-tab-tools/versions/?page=2#version-26.1-signed
Additional Comments: For as long as I have been using this extension, the last version of this add-on to work with PM was version 26.1. I have had no problems whatsoever with it, other than having to reinstall after installing PM updates.
However, with PM 27, installed yesterday, the extension is no longer working, it doesn't even show the tiles or its options button on the quick dial page. Only the background image I set a long time ago, still on PM26.something, is displayed.
I could not find any info on this being a JetPack extension. If I missed something, please tell me.
In the meantime, I have gone back to the PM26.5, but IMHO this is no long-term option.

Brew1Cool1

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby Brew1Cool1 » Wed, 23 Nov 2016, 16:56

Name: Add Bookmark Here ²
Type: Extension
Issue: The shortcut "Add Bookmark Here" does not display anywhere. Tried recommended version and all others.
Cause: Unknown
Workaround: Unknown
AMO: https://addons.mozilla.org/firefox/addon/add-bookmark-here-2/

User avatar
JustOff
Localization Coordinator
Localization Coordinator
Posts: 1704
Joined: Thu, 03 Sep 2015, 19:47
Location: UA
Contact:

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby JustOff » Wed, 23 Nov 2016, 18:18

Brew1Cool1 wrote:Name: Add Bookmark Here ²
Type: Extension
Issue: The shortcut "Add Bookmark Here" does not display anywhere. Tried recommended version and all others.
Cause: Unknown
Workaround: Unknown
AMO: https://addons.mozilla.org/firefox/addon/add-bookmark-here-2/

Workaround is known, use the search dude :coffee:
Here are the add-ons I made in a spare time. That was fun!

riiis
Lunatic
Lunatic
Posts: 439
Joined: Sat, 17 May 2014, 15:51
Location: USA

Re: Compatibility Reports for Post-v25 Pale Moon

Unread postby riiis » Thu, 24 Nov 2016, 03:08

markusGE wrote:Name: New Tab Tools
Type: Extension
Issue: Fails to show interface on quick dial page, no tiles or options button
AMO: http://addons.mozilla.org/firefox/addon/new-tab-tools/versions/?page=2#version-26.1-signed
Additional Comments: For as long as I have been using this extension, the last version of this add-on to work with PM was version 26.1. I have had no problems whatsoever with it, other than having to reinstall after installing PM updates.
However, with PM 27, installed yesterday, the extension is no longer working, it doesn't even show the tiles or its options button on the quick dial page. Only the background image I set a long time ago, still on PM26.something, is displayed.
I could not find any info on this being a JetPack extension. If I missed something, please tell me.
In the meantime, I have gone back to the PM26.5, but IMHO this is no long-term option.

New Tab Tools version-26.1-signed overrides Pale Moon's quick dial page with the Firefox 30 newtab page. Apparently, this Firefox 30 newtab page is not compatible with Pale Moon 27. To fix, replace New Tab Tools version-26.1-signed with the slightly older New Tab Tools version-24.1-signed (https://addons.mozilla.org/firefox/addo ... 4.1-signed). (Note, the options button for version-24.1 is there on the quick dial page, but may be hard-to-see or transparent. To find, sweep your mouse over the upper right corner of the quick dial grid page.)

If you use "New Tab Tools" only as a pure speed dial, you might consider replacing "New Tab Tools" with "Speed Start" (https://addons.mozilla.org/addon/speed-start/), or other speed dial extension.


Return to “The Pale Moon add-ons website”

Who is online

Users browsing this forum: No registered users and 3 guests