Please add an "outdated" tag to Decentraleyes

Anything to do with the Pale Moon add-ons website. (addons.palemoon.org)
Not for questions about add-ons themselves!

Moderators: satrow, FranklinDM, Lootyhoof

Forum rules
Important: This board is for specifics regarding the add-ons website (addons.palemoon.org) and not to report extension compatibility issues or discuss different extensions.
Please only post here when your topic is directly related to the add-ons website service so our moderators don't have to move your posts all the time...
Post Reply
User avatar
Andrew Herbert
Newbie
Newbie
Posts: 5
Joined: 2019-11-25, 21:46

Please add an "outdated" tag to Decentraleyes

Post by Andrew Herbert » 2019-11-25, 22:21

The Decentraleyes add-on is out-of-date to its Firefox counterpart, and as such, has critical problems that will not be solved:

https://git.synz.io/Synzvato/decentraleyes/issues/190

https://git.synz.io/Synzvato/decentraleyes/issues/211

Tracking protection add-ons are the ones that most need to be up-to-date, therefore it's imperative to add an "outdated" tag in order not to let users have a false sense of security. The last update date isn't enough, since users don't expect specific add-ons for Pale Moon by official developers to be outdated, as opposed to ones from the Classic Add-Ons Archive or even ones ported by unofficial developers.

User avatar
Lootyhoof
Themeist
Themeist
Posts: 1300
Joined: 2012-02-09, 23:35
Location: United Kingdom

Re: Please add an "outdated" tag to Decentraleyes

Post by Lootyhoof » 2019-11-25, 22:49

Perhaps you should check with the developer before assuming it is outdated because it hasn't been updated in an arbitrary amount of time. Version numbers mean nothing in this scenario given the different codebases (XUL vs WebExtension).

User avatar
moonbat
Keeps coming back
Keeps coming back
Posts: 809
Joined: 2015-12-09, 15:45
Location: Australia

Re: Please add an "outdated" tag to Decentraleyes

Post by moonbat » 2019-11-25, 23:29

Lootyhoof wrote:
2019-11-25, 22:49
Perhaps you should check with the developer before assuming it is outdated because it hasn't been updated in an arbitrary amount of time.
The 2 issues he linked to both ask the developer this question and both were closed without any further reply - and are over 2 years old.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
adesh
Keeps coming back
Keeps coming back
Posts: 774
Joined: 2017-06-06, 07:38

Re: Please add an "outdated" tag to Decentraleyes

Post by adesh » 2019-11-26, 06:08

moonbat wrote:
2019-11-25, 23:29
both were closed without any further reply
There is a reply:
> Will there be any further updates [...] for Pale Moon [...] If not, is it safe to [...] use 1.3.10?

Yes. It is absolutely safe to continue to use version 1.3.10, and the Pale Moon compatible codebase will receive maintenance updates, as well as library bundle additions, for as long as absolutely possible.
https://git.synz.io/Synzvato/decentrale ... #note_3380

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6262
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Please add an "outdated" tag to Decentraleyes

Post by New Tobin Paradigm » 2019-11-26, 06:44

During the latter years of Firefox extensions at least half the extension updates for all actively maintained extensions were version bumps and compatibility fixes. Since we don't tend to obsessively refactor and bust stuff constantly the bulk of Pale Moon extension updates are for bug fixes and new features with compatibility updates being rare.

So if we haven't specifically changed something that would bust an extension and that extension is rather feature complete then newer versions aren't being produced by developers unless they need to be. It depends more on their development plan and need than us driving them through constant version bumps and bustages.

This is how it was in the days before Mozilla lost their god damned minds and of course the purges.
Image
- Gorhill is an interdimensional shape-shifting reptilian.. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

Post Reply