Compatibility Reports for Post-v25 Pale Moon

Anything to do with the Pale Moon add-ons website.

Moderators: satrow, Lootyhoof, Andrew Gilbertson

Forum rules
Important: This board is for specifics regarding the add-ons website (addons.palemoon.org) and not to report extension compatibility issues or discuss different extensions.
Please only post here when your topic is directly related to the add-ons website service so our moderators don't have to move your posts all the time...
Bouzoukis
New to the forum
New to the forum
Posts: 1
Joined: Wed Dec 21, 2016 3:34 pm

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Bouzoukis » Wed Jan 11, 2017 1:30 pm

Name: Shoptimate
Type: Jetpack / SDK Extension
Issue: Not compliant with Pale Moon 27.0.3
AMO: https://addons.mozilla.org/fr/firefox/addon/shoptimate/

Kind regards
Keep up the Good Job! :thumbup:

stepaniuk
Newbie
Newbie
Posts: 4
Joined: Fri Jan 20, 2017 7:41 am

Re: Compatibility Reports for Post-v25 Pale Moon

Postby stepaniuk » Fri Jan 20, 2017 7:55 am

Name: Multiple Tab Handler
Type: Extension
Issue: Shift+click selection doesn't work
Cause:
Workaround:
AMO: https://addons.mozilla.org/en-US/firefox/addon/multiple-tab-handler/versions/?page=1#version-0.7.2014050101.1-signed

markusGE
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: Sun Oct 11, 2015 11:29 am
Location: Austria, Europe

Re: Compatibility Reports for Post-v25 Pale Moon

Postby markusGE » Sat Jan 28, 2017 3:20 pm

Another Problem with New Tab Tools

Name: New Tab Tools
Type: Extension
Issue: Fails to set new tile image
AMO: http://addons.mozilla.org/firefox/addon/new-tab-tools/versions/?page=2#version-24.1-signed
Additional Comments: Since the release of Palemoon 27, the last version of this add-on to work with PM was version 24.1. I have had no problems whatsoever with it, other than having to reinstall after updating PM.
However, when rearranging my tiles today, I was unable to assign custom images to my tiles. Those images already there were kept, but new ones were not adopted. Also, loading from an exported settings ZIP-file, tile images would be loaded, but tile ordering would not.
When going to NTT24.1 after installing PM27.0.0 (I previously used NTT26.1, which no loner works in PM27+), all that used to work just fine. I´m now on PM27.0.3, though.
Since everything was fine initially, and only seems to have developed after PM updates, I'm thinking this is a PM-related problem, not related to the extension (please correct me, though, that's only guesswork).

markusGE
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: Sun Oct 11, 2015 11:29 am
Location: Austria, Europe

Re: Compatibility Reports for Post-v25 Pale Moon

Postby markusGE » Sun Jan 29, 2017 4:48 pm

Follow up: I kept experimenting a little, since I´ve had two more ideas come to my mind. And I indeed found workaround to the problems described, though it's, admittedly, somewhat complicated, and there are certain requirements one must meet first.


1: On the backup drives of my PC, I had and old backup sitting around (and ready to be removed) containing and old installation of PM, V26.5.0 to be exact. I copied the contents of that Palemoon folder over my existing Palemoon installation folder, allowing it to replace existing files, thus backdating the version of Palemoon in use.

2: I then opened Palemoon, ignored all the remarks it made about other extensions, and installed NewTabTools, Version 26.1-signed. That version of NTT only works up to PM26.5.0, but it does so flawlessly.

3: Next I closed and re-opened Palemoon, to ensure everything was loaded fine in the versions desired, and made my changes to the NTT newTab page.

4: Afterwards, I exported the changes via the "Export Settings" button in the NewTabTools entry in Palemoon's extensions overview.

5: Then, I let Palemoon update to the current version (search for updates must be initialized manually).

6: When PM was done updating, I installed NTT24.1 again, since that is the last version of NTT to work with PM27+.

7: I opened Palemoon again to check if everything was fine, and it was.

8: Should, for some reasons (cache cleared or history removed) the NTT tiles change in an undesired way, one can no simply re-download and -install NTT 24.1 again. After restarting PM, the previously export settings can then be imported again just fine, and WILL WORK!


Admittedly, this workaround is quite complicated, and it would still be desirable to get NTT working the way it should instead. Also, it includes messing with PM program files, and so I don't take any liability should doing the above break anything on someone else' system.

illiad
Moon lover
Moon lover
Posts: 80
Joined: Sun May 15, 2016 1:04 pm

Re: Compatibility Reports for Post-v25 Pale Moon

Postby illiad » Tue Feb 07, 2017 2:29 pm

Does anyone know about using pale moon on a domain system, with active directory???

I am working for a company that uses a basic version, using server 2012 and satellite PCs using windows 7..
A lot of proprietary software is used that needs win7 and IE11... :roll:

Also, They use K7 antivirus to manage protection from the server... https://www.k7computing.com/eng/k7-antivirusplus.html

if you have any experience???? https websites just keep getting 'no cert' :cry: :problem:

palemoon not secure.jpg
VM 150Mbs in london england :coffee: on Intel Core I7 3GHz on Gigabyte X58a Mobo.
Latest PM 27.6(64bit) on win7(64bit) sp1, modded to run and update despite no access to 'program file' folder on active directory domain.. :ugeek:

User avatar
Andrew Gilbertson
Fanatic
Fanatic
Posts: 237
Joined: Thu Jul 16, 2015 1:43 pm
Location: US/Tampa

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Andrew Gilbertson » Wed Feb 08, 2017 1:04 pm

illiad wrote:Does anyone know about using pale moon on a domain system, with active directory???

I am working for a company that uses a basic version, using server 2012 and satellite PCs using windows 7..
A lot of proprietary software is used that needs win7 and IE11... :roll:

Also, They use K7 antivirus to manage protection from the server... https://www.k7computing.com/eng/k7-antivirusplus.html

if you have any experience???? https websites just keep getting 'no cert' :cry: :problem:

palemoon not secure.jpg

I suspect that your company has a "transparent" proxy that is intercepting your HTTPS traffic and re-encrypting using their own cert. Check with your IT department (or check if there's proxy settings configured for IE in the "Internet" control panel options, and copy those if there are).

But being part of a domain system using ActiveDirectory shouldn't produce this - I'm on a configuration like that at work (and Windows 7, even) and don't have any problems using Pale Moon.

Cassol
Moongazer
Moongazer
Posts: 12
Joined: Sun Feb 12, 2017 7:50 pm

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Cassol » Sun Feb 12, 2017 8:31 pm

Name: Tree Style Tab
Type: Extension
Issue: Add-on does nothing starting with PM 27.1.0; issue applies to the version recommended as workaround on https://addons.palemoon.org/incompatible/ (0.14.2014051101.1)
Cause:
Workaround:
AMO: https://addons.mozilla.org/firefox/addon/tree-style-tab/

Potentially helpful, or not: I believe that the workaround used to work fine in 25.x; I began to notice minor bugs at, I think, some point in the 26.x line, but I can't quite recall when it first became noticeable. I do recall the appearance of an irritating tab placement issue precisely at the change to 27.x, but even that was still little to no more than a minor annoyance; small bugs aside, the extension otherwise worked as of 27.0.3. With the change to 27.1.0, it no longer does anything at all.

Further comment: Advanced tab management is an absolutely critical part of my browsing requirements, and the lack of such capabilities is an outright deal breaker; however, I don't want to go back to Firefox, or worse, move to lol Chrome, and I believe in helping those who help themselves. As such, I will gladly dedicate some time/effort to this issue, be it by helping pinpoint causes, testing solutions/workarounds/etc, or however else I can be of help, to the extent of my (admittedly fairly limited) availability/resources/knowledge/etc. Point me to what I have to do, and if I at all can, I shall. Additionally, I'll be extremely thankful if someone is able to point me to another extension that can replace Tree Style Tab's basic function (as in the one in its name), if nothing else on a temporary basis.

Cassol
Moongazer
Moongazer
Posts: 12
Joined: Sun Feb 12, 2017 7:50 pm

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Cassol » Sun Feb 12, 2017 11:44 pm

Apparently I can't edit or delete my own post above (am I doing something wrong?), but it seems this thread contains a workaround to the issue described in it: https://forum.palemoon.org/viewtopic.php?f=16&t=14730.

Apologies for the double post and for being blind. :) Feel free to delete/merge/etc the posts as required/appropriate.

Edit: it seems I can edit and delete this one, though? Interesting...

User avatar
Andrew Gilbertson
Fanatic
Fanatic
Posts: 237
Joined: Thu Jul 16, 2015 1:43 pm
Location: US/Tampa

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Andrew Gilbertson » Mon Feb 13, 2017 12:56 pm

Cassol wrote:Apparently I can't edit or delete my own post above (am I doing something wrong?), but it seems this thread contains a workaround to the issue described in it: https://forum.palemoon.org/viewtopic.php?f=16&t=14730.

Apologies for the double post and for being blind. :) Feel free to delete/merge/etc the posts as required/appropriate.

Edit: it seems I can edit and delete this one, though? Interesting...


Edit is only available for a short time (I forget exactly how long), so if you try to edit an older post, that's not going to work, but if it's very recent, it definitely will.

We should probably lock this thread, since extension compatibility has seen extensive changes with 27.x.y versions of Pale Moon.

Cassol
Moongazer
Moongazer
Posts: 12
Joined: Sun Feb 12, 2017 7:50 pm

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Cassol » Mon Feb 13, 2017 1:28 pm

Oh, I see; that certainly makes sense. Thanks for the feedback. :)

I believe a new thread should probably be made for 27.1.0 and beyond, yes. Now that the fixed TST from the linked thread allows me to browser normally, I began to notice that this new version broke at least one more extension as well (thankfully, one that isn't mission critical to me); if I begin to check closely, I'll probably find a few more.

Venom88
Newbie
Newbie
Posts: 4
Joined: Tue Feb 14, 2017 11:43 am

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Venom88 » Tue Feb 14, 2017 11:46 am

Name: The Old Reader Notifier
Type: Extension
Issue: Does not install, have checked for versions.
AMO: https://addons.mozilla.org/firefox/addo ... -notifier/

Venom88
Newbie
Newbie
Posts: 4
Joined: Tue Feb 14, 2017 11:43 am

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Venom88 » Tue Feb 14, 2017 11:50 am

Name: Links for later
Type: Extension
Issue: Not compatible. Won't install.
AMO: https://addons.mozilla.org/firefox/addo ... for-later/

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20067
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Compatibility Reports for Post-v25 Pale Moon

Postby Moonchild » Tue Feb 14, 2017 10:04 pm

Since this thread was initially started for the compatibility issues with the change of GUID in Pale Moon, anything that's being added now should simply be posted on a case by case basis in the Pale Moon extension compatibility board. The add-ons team will take it from there.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.


Return to “The Pale Moon add-ons website”

Who is online

Users browsing this forum: No registered users and 3 guests