BUG: Functionless video play in PM 27.1 (PM 26 works!)

Browser plug-in compatibility issues and discussion.
(e.g. Flash, Adobe reader, authentication plug-ins)

Moderators: satrow, Indalecio, Andrew Gilbertson, Lootyhoof

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Tue Feb 14, 2017 7:33 pm

Hello there,

on PM 27.1 it is not possible to play live tv channel of my local television now:
http://www.ceskatelevize.cz/ct24#live

I restarted PM into Safe Mode but the video is still unavailable.
On FF everything works. And also.. i tried the website on older version and i found that it works on Pale Moon 26!
So obviously there is some bug comming with new version.

Can anybody inspect the problem and tell me how ti resolve this?

Thank you
XT
Attachments
ct24.jpg
the screenshot of functionless video in PM Save Mode

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1226
Joined: Mon May 20, 2013 6:19 pm
Location: Earth
Contact:

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby trava90 » Tue Feb 14, 2017 10:04 pm

Can you check if any errors are in the Error Console?

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Tue Feb 14, 2017 10:19 pm

And where do i find Error Console?

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1226
Joined: Mon May 20, 2013 6:19 pm
Location: Earth
Contact:

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby trava90 » Wed Feb 15, 2017 2:03 am

Pale Moon button > Web Developer > Error Console

GMforker
Lunatic
Lunatic
Posts: 259
Joined: Thu Aug 27, 2015 6:29 am
Location: Czech Republic

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby GMforker » Wed Feb 15, 2017 3:25 am

1.png
PM 27.2.0a1 (27.1.0) - an error
2.png
PM 26.5.0 - OK
3.png
FF 51.0.1 - OK
4.png
FF 38.0.5 - OK

See also viewtopic.php?f=29&p=106631

GMforker
Lunatic
Lunatic
Posts: 259
Joined: Thu Aug 27, 2015 6:29 am
Location: Czech Republic

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby GMforker » Wed Feb 15, 2017 4:20 am

See http://scz.hit.gemius.pl/gstream.js

about:config:

general.useragent.override.ceskatelevize.cz
= Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.9) Gecko/20100101 Firefox/27.9 Chrome (Pale Moon)
= Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.9) Gecko/20100101 Firefox/27.9 Microsoft (Pale Moon)
= Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.9) Gecko/20100101 Firefox/27.9 Safari (Pale Moon)

Works...

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18328
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby Moonchild » Wed Feb 15, 2017 11:35 am

Looks like another example of people using a player that does UA sniffing and when finding "unknown" falling back to Apple's "HLS" playlist format as "video".
i.e.: broken detection library on the site, they should have a look into it and fix it. OP: have you tried contacting them?
Light travels faster than sound. That's why some people look brilliant, until you hear them speak.
Image

GMforker
Lunatic
Lunatic
Posts: 259
Joined: Thu Aug 27, 2015 6:29 am
Location: Czech Republic

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby GMforker » Wed Feb 15, 2017 11:50 am

Moonchild wrote:have you tried contacting them?

Not yet, but I will...

Edit: ...and the answer is short and simple: We only support the browsers: Chrome, Firefox and Opera for the HTML5 Player, and Internet Explorer for the Flash Player.

It is probably very difficult (for public service media)...
Last edited by GMforker on Wed Feb 15, 2017 12:29 pm, edited 1 time in total.

User avatar
kizo07
Banned user
Banned user
Posts: 344
Joined: Mon Oct 17, 2016 2:11 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby kizo07 » Wed Feb 15, 2017 12:19 pm

btw, with flash enabled + no proxy and almost disabled uBo/uMatrix I'm able to watch streaming...wright now they talking about Trump/Israel

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Wed Feb 15, 2017 7:54 pm

Hello there, i tried new installation of PM 27.1.0 and same nothing. I tried to disable FlashPlayes and same nothing too. It is reasonable to take care about uM/AdB/uB addons but it seems that any addon is not the problem (everything works on PM 26.X; with same setup).
i am just wondering where is the problem resp. on which side:

a/ PM
what is sure is that it works on PM26.X, so there must me something "new" what causes the issue in v27.X
b/ sever
on another side the server probably updated the player (there is a new GUI) so there might be some issue with optimalisation. but PM26.X works, so there must be some fix from Pale Moon team for PM 27.X, i guess;)

The difference of the error from between blank PM 27.1.0 and my 'profiled' PM 27.1.0 is that the blank PM shows constatly "loading" page, while my 'profiled' PM shows the error screen (my screenshot above).

to GMforker:
what did you mean about "about:config @ general.useragent.override.ceskatelevize.cz". Is it some temporary fix?

to kizo07:
how did you resolve the problem? again, i restarted PM 27.1.0 in Safe Mode and also i used blank new installation without any add-on and live streaming does not work.. But archived videos i am able to play on blank PM 27, but there is strange behaviour - it does not start automatically.

p.s.: i also wrote to Ceska Televize (www.ceskatelevize.cz) and reported them the issue. They have 30 days to answer;)

User avatar
kizo07
Banned user
Banned user
Posts: 344
Joined: Mon Oct 17, 2016 2:11 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby kizo07 » Wed Feb 15, 2017 8:57 pm

techX wrote:resolve the problem

with flash enabled + no proxy and almost disabled uBo/uMatrix I'm able to watch streaming
Here 30 sec live streaming video http://www36.zippyshare.com/v/wJGls6lS/file.html
captured 10 min ago

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Thu Feb 16, 2017 1:48 pm

As i did mention in my previous posts...

a/ i have NEW (blank) PM 27.1.0 Portable
b/ no add-on installed (no uM, uB, AdB etc.)
(+c/ "no proxy" si sat up)

The result is still the same i.e. the live streaming and videos (for example here: http://www.ceskatelevize.cz/ct24#live) still does not work and this error window with message shows up.
So what is sure is that there is something wrong with new PM 27.X because on PM 26.X everything works - see my previous mesage, please.

I just waitting the answer from GMforker about "about config @ general.useragent.override.ceskatelevize.cz".
Do i have to create new string?

It will be nice if somebody will help to find out the real solution.
Thank you

p.s.: to kizo07: you do not need to prove that your streaming works, to tell this it is just enough.

User avatar
kizo07
Banned user
Banned user
Posts: 344
Joined: Mon Oct 17, 2016 2:11 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby kizo07 » Thu Feb 16, 2017 2:47 pm

techX wrote:tell this it is just enough

Ok. My streaming works just fine in new Pale Moon 27.1

GMforker
Lunatic
Lunatic
Posts: 259
Joined: Thu Aug 27, 2015 6:29 am
Location: Czech Republic

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby GMforker » Thu Feb 16, 2017 6:52 pm

techX wrote:I just waitting the answer from GMforker about "about config @ general.useragent.override.ceskatelevize.cz".
Do i have to create new string?

Yes. See also viewtopic.php?f=29&p=106631#p106677 (viewtopic.php?f=29&p=106631#p106680).

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Thu Feb 16, 2017 7:38 pm

Today i have got an answer from the server (cekatelevize.cz). In short they have answered me this:

"Because of gradual terminating of the support for Adobe Flash Player in all browsers, the iVisílaní ČT switched from 13th of February to HTML 5 player. We can not guarantee the proper function of iVisílaní (live streaming video) on your Pale Moon browser."

So it is confirmed that the server terminating the support of Flash Player and replaced it with HTML5 player. And it also seems that PM 27.x is not ready for that and/or suffers from some bug which is not in version 26.

It seems that everything is now about HTML5 player. The trend is obvious: more and more websites will leave Flash Player (finally!) so i guess this is not the lonely issue of 'some website'.

So how to resolve this video issue with PM 27.x??
Let me know here just relevant answers with understading that the problem persists. Thank you.

p.s.: i have 32-bit PM installations

User avatar
razzberry
New to the forum
New to the forum
Posts: 1
Joined: Sat Feb 25, 2017 10:45 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby razzberry » Sat Feb 25, 2017 11:34 pm

Flash wouldn't play for me after updating to 27.1.1 (32bit), not in FB nor YT... after nosing around in the settings I found this in the Pale Moon Commander/JavaScript tab

Completely Disable JavaScript was ticked.

Unticked, everything back to normal working perfectly. Hope this helps. :coffee:

User avatar
techX
Moonbather
Moonbather
Posts: 50
Joined: Mon Nov 14, 2016 11:54 pm

Re: BUG: Functionless video play in PM 27.1 (PM 26 works!)

Postby techX » Sat Mar 25, 2017 3:03 pm

to: razzberry

I tried to disable Java but it did not work either with my 32-bit PM Portable v27.2.1. We tried to resolve the issue in another post here but until this day the HTML5 video on my blank new PM (no add-ons, just default new PM) does not work. I actually still testing it on the national internet television here: http://www.ceskatelevize.cz/ct24/ct24#live (they run HTML5 Player now).

I still waitting for the fix;)
In v26 it works. So i guess there must be some way to make it in v27 too.


Return to “Browser plug-in compatibility”

Who is online

Users browsing this forum: No registered users and 1 guest