Audio-Technica.com does not work at all Topic is solved

Support and discussions for the Apple Mac OS X builds of Pale Moon
Forum rules
Important note:
The Mac OSX version of Pale Moon is provided by various people and is not official or in any way organized at this moment. Your assistance in bringing this build to fruition is greatly appreciated, but you can expect there to be bugs and problems as long as we don't have a maintainer or official builds!

Any specific bugs you find that don't have their own topic yet: please make a new topic; one bug per topic please to keep things organized.

Please also note that these builds are currently created by various independent Mac OS X people and not by our core team; core devs will likely not be able to provide insight or assistance due to lack of Mac hardware and OS/build knowledge for Mac. You'll have to solve the issues among yourselves.
Locked
KlarkKentThe3rd
Lunatic
Lunatic
Posts: 362
Joined: 2018-04-20, 20:31

Audio-Technica.com does not work at all

Post by KlarkKentThe3rd » 2020-02-15, 06:17

https://www.audio-technica.com/world_map/

User agent override did not help.

User avatar
adesh
Board Warrior
Board Warrior
Posts: 1222
Joined: 2017-06-06, 07:38

Re: Audio-Technica.com does not work at all

Post by adesh » 2020-02-15, 08:49

I'm able to see the wold map and choose my country.

What does not wot "at all"? Screenshots and some prose would help.

User avatar
Kerebron
Apollo supporter
Apollo supporter
Posts: 47
Joined: 2016-12-04, 22:01

Re: Audio-Technica.com does not work at all

Post by Kerebron » 2020-02-15, 13:01

I've got no problems with the site, everything is working fine.

User avatar
Kathuluforz
Lunatic
Lunatic
Posts: 301
Joined: 2019-06-13, 13:42
Location: Montana

Re: Audio-Technica.com does not work at all

Post by Kathuluforz » 2020-02-15, 13:43

For me the map shows, and I can click my location (USA) and then a small window pops up; accept cookies or don't, any choice I make does nothing. I can X-out the window which takes me back to the map.
Also nothing was being blocked in UBO or uMatrix and tried all 3 default user agents.
Error console returns:
Timestamp: 2/14/2020 8:03:34 PM
Error: DEPRECATION WARNING: This path to Console.jsm is deprecated. Please use Cu.import("resource://gre/modules/Console.jsm") to load this module.
You may find more details about this deprecation at: https://bugzil.la/912121
Callstack:
resource://gre/modules/devtools/Console.jsm 19 null
chrome://downloads_window/content/modules/watchwindows.jsm 47 null
resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/rico-x/AppData/Roaming/Moonchild%20Productions/Pale%20Moon/Profiles/p8gshusr.default/extensions/%7Ba7213cf2-fa1e-4373-88ff-255d0abd3020%7D.xpi!/bootstrap.js 144 startup
resource://gre/modules/addons/XPIProvider.jsm 4462 XPI_callBootstrapMethod
resource://gre/modules/addons/XPIProvider.jsm 2159 XPI_startup
resource://gre/modules/AddonManager.jsm 195 callProvider
resource://gre/modules/AddonManager.jsm 733 _startProvider
resource://gre/modules/AddonManager.jsm 880 startup
resource://gre/modules/AddonManager.jsm 2456 startup
resource://gre/components/addonManager.js 58 observe

Source File: resource://gre/modules/Deprecated.jsm
Line: 85

Timestamp: 2/14/2020 8:19:44 PM
Error: DEPRECATION WARNING: PlacesBackups.getMostRecent is deprecated and will be removed in a future version
You may find more details about this deprecation at: https://bugzilla.mozilla.org/show_bug.cgi?id=859695
Callstack:
resource://gre/modules/PlacesBackups.jsm 286 PB_getMostRecent
resource://app/components/nsBrowserGlue.js 1122 BG__shouldBackupBookmarks
resource://app/components/nsBrowserGlue.js 232 BG_observe

Source File: resource://gre/modules/Deprecated.jsm
Line: 85
I really have no clue what it all means and there was more (repeated i think) but I thought this was a good start for anyone
with more experience might understand it.
Pale Moon 28.14.2 (64) Win7 pro (64)

"People will come to love their oppression, to adore the technologies that undo their capacities to think." ~ Aldous Huxley
'DON'T PANIC'

User avatar
therube
Board Warrior
Board Warrior
Posts: 1350
Joined: 2018-06-08, 17:02

Re: Audio-Technica.com does not work at all

Post by therube » 2020-02-15, 13:54

window pops up; accept cookies or don't, any choice I make does nothing
Ditto.

Could be that for those that the site works, a cookie was already set, so the cookie location/language prompt was bypassed...

Looks like some countries work.
Australia, Africa, but not the US.
Last edited by therube on 2020-02-15, 13:56, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28125
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Audio-Technica.com does not work at all

Post by Moonchild » 2020-02-15, 13:56

Ah so it's the cookie choice window that doesn't work, this doesn't show up on all territories so it depends on which region you choose.

Why? Because their click() handler starts with event.preventDefault(), and "event" is not defined at this level. Most likely they are wanting to use a "global" event prototype on the window, which is in fact an open issue Issue #595 (UXP).
Since the JS aborts due to the error, the buttons won't respond.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Locked