Pale Moon 27.9.3 for Snow Leopard

Support and discussions for the Apple Mac OSX builds of Pale Moon

Moderator: satrow

Forum rules
Important note:
The Mac OSX version of Pale Moon is still very much in development. Your assistance in bringing this build to fruition is greatly appreciated, but you can expect there to be bugs and problems for a while yet!

Any specific bugs you find that don't have their own topic yet: please make a new topic; one bug per topic please to keep things organized.

Please also note that these builds are currently created by Sugis and Moonchild will likely not be able to provide insight or assistance due to lack of Mac hardware and OS/build knowledge for Mac.
User avatar
wicknix
Moonbather
Moonbather
Posts: 64
Joined: Mon, 26 Mar 2018, 04:47
Location: Wisconsin, USA

Pale Moon 27.9.3 for Snow Leopard

Unread postby wicknix » Tue, 12 Jun 2018, 17:23

Silence is golden, but duct tape is silver...

verdant
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Tue, 24 Oct 2017, 20:29

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby verdant » Tue, 12 Jun 2018, 22:17

Continued thanks to you wicknix :D

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Wed, 13 Jun 2018, 00:58

I just downloaded New Moon 27.9.3 and am used it to write the reply to myself after booting the image on a Slow Leopard ramdisk. Using Gecko compatibility mode, it displays the Paypal test page for PCI DSS http://sandbox.paypal.com/
- so does 27.3.0 when running it now after closing New Moon, but now the system won't allow me to switch back to Firefox.
Will .9.3 be the last update to 27?
Last edited by retroburrower on Wed, 13 Jun 2018, 01:49, edited 1 time in total.

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Wed, 13 Jun 2018, 01:07

so I closed Pale Moon, and a Firefox window displays, but the menu bar was still Pale Moon's. I then closed it again and relaunched New Moon, but the problem persists, so I had to force quit Firefox and restore the session, which seemed to cause it to overheat, as the fan kicked on.

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Wed, 13 Jun 2018, 01:12

I just tried to see if the problem of not being able to switch to Firefox repeats by closing New Moon and relaunching Pale Moon, and it didn't, but the fans are still running.

User avatar
Snow Leopard Lover
Newbie
Newbie
Posts: 3
Joined: Sat, 02 Jun 2018, 07:09

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby Snow Leopard Lover » Wed, 13 Jun 2018, 16:08

Hello wicknix, thanks again for your work!

Everything works fine (iMac 27", late 2009, 10.6.8).

Image

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Fri, 15 Jun 2018, 22:54

Paypal's test page also works in Native & Firefox modes. However Smith's only recognises the latter, otherwise it sends you to
https://www.smithsfoodanddrug.com/unsupported
Can we have the option of opening the final version for Snow Leopard in 32-bit mode, please, if it's not too much extra work?

User avatar
wicknix
Moonbather
Moonbather
Posts: 64
Joined: Mon, 26 Mar 2018, 04:47
Location: Wisconsin, USA

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby wicknix » Sat, 16 Jun 2018, 04:30

Can we have the option of opening the final version for Snow Leopard in 32-bit mode, please, if it's not too much extra work?


I looked in to that, and it is too much work for me to mess with. It would involve me wiping my current build environment and installing all the macports "universal" packages. The other option is building natively on an old 32 bit core solo/duo machine, which i don't have. All my intel machines are core2duo 64 bit.

Cheers
Silence is golden, but duct tape is silver...

kbhasi
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: Wed, 25 Jan 2017, 10:40

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby kbhasi » Sat, 30 Jun 2018, 09:01

wicknix wrote:The other option is building natively on an old 32 bit core solo/duo machine, which i don't have. All my intel machines are core2duo 64 bit.


I have a 2006 (32 bit) Mac mini running Mac OS 10.6.8 Server, which I could let you use, but there are some caveats and issues:

  1. The server is located in Singapore, which means you'll get Singaporean adverts if you try to load web sites within the environment.
  2. I'm currently in the process of transitioning to a new server, which involves this old one going down from time to time, and also me having to change port assignments to point to the new server later on. For that, I could notify you via DM if that ever happens, but I'll try to check if you're using the environment.
  3. I currently don't have Xcode, GCC, and MacPorts installed
  4. 2 GB of RAM might be limiting
  5. Screen Sharing on 10.6 doesn't support multiple users.

On second thought, you may want to try finding an old 2006 Mac on the online classifieds in your area, as they may be cheap.

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Sat, 30 Jun 2018, 22:31

The reason for my asking was to limit the browser to run with the least amount of overhead. But if I'm going to test it with Flash in 64-bit, what version should I be running? Currently it's using 32-bit 22.0.0.209. I have a MacBook 3,1 running a Core 2 Duo from around Xmas 2007.
Last edited by retroburrower on Sat, 30 Jun 2018, 22:33, edited 1 time in total.

User avatar
wicknix
Moonbather
Moonbather
Posts: 64
Joined: Mon, 26 Mar 2018, 04:47
Location: Wisconsin, USA

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby wicknix » Sun, 01 Jul 2018, 17:56

kbhasi wrote:
I have a 2006 (32 bit) Mac mini running Mac OS 10.6.8 Server....


Thanks for the offer, however PM27 is nearing end of life. PM28 and beyond will not run on snow leopard. Minimum requirements will be OSX 10.7 Lion or higher. I will however continue to build PM27 for 64 bit snow leopard until it is no longer updated.

Cheers
Silence is golden, but duct tape is silver...

retroburrower
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Mon, 11 Sep 2017, 01:48

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby retroburrower » Mon, 09 Jul 2018, 16:41

And having only 1GB is the reason for trying to limit overhead. So when trying to run things needing Flash, a notice appears saying that it's outdated. Clicking on that notice allows it to run, but there are problems in having graphics displayed correctly as at
https://www.mlb.com/gameday/rockies-vs- ... state=live
It oddly displays a garbled version of an image from Natural Grocers that had been displayed in SeaMonkey, before closing it to run NewMoon. If this is due to running an outdated version of Flash, which one should be used instead?
Last edited by retroburrower on Mon, 09 Jul 2018, 16:59, edited 1 time in total.

User avatar
wicknix
Moonbather
Moonbather
Posts: 64
Joined: Mon, 26 Mar 2018, 04:47
Location: Wisconsin, USA

Re: Pale Moon 27.9.3 for Snow Leopard

Unread postby wicknix » Tue, 10 Jul 2018, 03:43

I don't know. I didn't even know flash still existed, nor have i run in to any site that i frequent that required it. Haven't had it installed since flash 10.

Cheers
Silence is golden, but duct tape is silver...


Return to “Pale Moon for Mac OSX”

Who is online

Users browsing this forum: No registered users and 5 guests