Palemoon missing in Debian/Ubuntu repo

For contributed third party builds not necessarily configured like the main product.
e.g. AVX builds, SSE builds, Pandora builds.
User avatar
jreleb
New to the forum
New to the forum
Posts: 1
Joined: 2024-04-30, 05:32

Palemoon missing in Debian/Ubuntu repo

Unread post by jreleb » 2024-04-30, 06:12

Hi,

in Steven Pusser's Debian and Ubuntu repository palemoon is only available for Ubuntu 18.04 bionic. Both gtk-2 and gtk-3 builds are missing in every other release. The installation instructions show them only for Ubuntu 18.04 (and erroneously the gtk-2 builds for Debian unstable). Something gone wrong?

The Ubuntu 18.04 build seems to work for Ubuntu 22.04 anyway.

Thanks for the awesome effort anyway!

Greets
jre

lazyest
Hobby Astronomer
Hobby Astronomer
Posts: 29
Joined: 2016-02-25, 08:09
Location: Minsk, Belarus
Contact:

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by lazyest » 2024-05-29, 11:44

status of previous and current builds are excluded :(

User avatar
johnpalo
New to the forum
New to the forum
Posts: 1
Joined: 2024-06-07, 08:28

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by johnpalo » 2024-06-07, 08:40

Hello all,
i am a longtime user of palemoon, i am sad now that i can't install it anymore under Ubuntu noble 24.04, it shows unmet dependencies , libavcodec57-59 can not be installed.
Lintian output is:
E: palemoon: depends-on-obsolete-package Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) => libgdk-pixbuf-2.0-0 and optionally libgdk-pixbuf-xlib-2.0-0
E: palemoon: embedded-library libavutil [usr/lib/palemoon/libmozavutil.so]
E: palemoon: embedded-library libjpeg [usr/lib/palemoon/libxul.so]
E: palemoon: embedded-library libpng [usr/lib/palemoon/libxul.so]
E: palemoon: embedded-library nspr [usr/lib/palemoon/libnspr4.so]
E: palemoon: embedded-library nss [usr/lib/palemoon/libnss3.so]
W: palemoon: mismatched-override embedded-library usr/lib/palemoon/libmozsqlite3.so: sqlite [usr/share/lintian/overrides/palemoon:2]
W: palemoon: mismatched-override embedded-library usr/lib/palemoon/libxul.so: libjpeg [usr/share/lintian/overrides/palemoon:1]
W: palemoon: national-encoding [usr/lib/palemoon/dictionaries/en-US.dic]
W: palemoon: no-manual-page [usr/bin/palemoon]
N: 0 hints overridden; 2 unused overrides

Lintian finished with exit status 2
--------------------------------------------------
Is there a fix around the corner? Or should i fiddle with source codes?
Please advise
John

User avatar
Pentium4User
Board Warrior
Board Warrior
Posts: 1181
Joined: 2019-04-24, 09:38

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by Pentium4User » 2024-06-07, 10:12

For me it looks like he is not maintaining that anymore, as he also doesn't seem to reply here: viewtopic.php?f=3&t=11466&p=251973&hili ... tu#p251973
The profile picture shows my Maico EC30 E ceiling fan.

Lucio Chiappetti
Astronaut
Astronaut
Posts: 675
Joined: 2014-09-01, 15:11
Location: Milan Italy

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by Lucio Chiappetti » 2024-06-07, 10:18

I use the (gtk2) tarball from this very Pale Moon site both on (X)ubuntu 20.04 (desktop) and 22.04 (laptop), as well on a Opnesuse desktop. I do not use the repositories. Despite the fact I was skeptical on frequent updates, I now converted to update Pale Moon as soon as a new version appears. This runs extremely smooth and fast on ubuntu (on suse my procedure, which includes keeping a backup of the old version and profile - which is likely unnecessary - requires just a few more manual steps because of different admin permissions).
I suggest you use the version from the Pale Moon site.
The reasonable man adapts himself to the world: the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man. (G.B. Shaw)

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 5217
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by Night Wing » 2024-06-07, 12:28

Lucio Chiappetti wrote:
2024-06-07, 10:18
I use the (gtk2) tarball from this very Pale Moon site both on (X)ubuntu 20.04 (desktop) and 22.04 (laptop), as well on a Opnesuse desktop. I do not use the repositories.
Like you, I also manually update 64 bit linux Pale Moon (GTK2) from this site's page below when a new version has been released.

https://www.palemoon.org/download.shtml

Been doing it this way for a very long time. And 64 bit Linux Pale Moon runs great in 64 bit Debian 12.5 (Bookworm) Xfce without any problems as well as in MX Linux and Linux Mint.

If Steve is not updating Pale Moon anymore, the others on here might think about doing it manually at this time.
Linux Mint 21.3 (Virginia) Xfce w/ Linux Pale Moon, Linux Waterfox, Linux SeaLion, Linux Firefox
MX Linux 23.3 (Libretto) Xfce w/ Linux Pale Moon, Linux Waterfox, Linux SeaLion, Linux Firefox
Linux Debian 12.6 (Bookworm) Xfce w/ Linux Pale Moon, Linux Waterfox, Linux SeaLion, Linux Firefox

Lucio Chiappetti
Astronaut
Astronaut
Posts: 675
Joined: 2014-09-01, 15:11
Location: Milan Italy

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by Lucio Chiappetti » 2024-06-07, 14:36

Could even do it automatically (Preferences->Advanced->Updates). I have the middle option ticked, but if one has 100% trust and is lazy could tick the top option. I have 99% trust, and prefer to backup my profile before updating. I can always do the update later from Help->Check for updates (actually there are cases in which I update soon after the announcement on the forum and before being prompted by Pale Moon,
The reasonable man adapts himself to the world: the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man. (G.B. Shaw)

User avatar
seriousness
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2021-05-15, 11:44

Re: Palemoon missing in Debian/Ubuntu repo

Unread post by seriousness » 2024-06-15, 20:35

I just updated to 33.1.1-1.gtk3 from the Ubuntu 22.04 repo! :thumbup:

Post Reply