Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

For contributed third party builds not necessarily configured like the main product.
e.g. AVX builds, SSE builds, Pandora builds.
User avatar
paleuser2
Newbie
Newbie
Posts: 5
Joined: 2021-05-09, 01:36

Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by paleuser2 » 2021-05-09, 02:31

Hi,

i knew already that there would be a discontinue of the support for old firefox-extensions.
But i don't expected this to happen rightnow.

So my situation is like this: actually i'm running debian 10, want to switch to the upcomming debian 11 shortly.

Because i don't knew the old firefox-extensions would be blocked with the 29.2 release, the last version i got here is the 29.1 palemoon for debian 10.
I always used the debian-builds from Steve Pusser, wich always worked flawless here (Many, many thanks to Mr. Steve Pusser for his work, by the way).

I checked for replacements of my extensions on 'addons.palemoon.org/extensions' but couldn't find sufficient replacements for my installed extensions.
That's why i'm looking now for .deb-packages for palemoon 29.1.1 for debian 10 and for debian testing (the upcomming debian 11) from Steve Pusser to bridge the time until i can find replacements for my extensions.

As long as i can see Mr. Steve Pusser don't maintain a archive with old versions of his palemoon-builds.
Is there anybody who can tell me where i can get these? Or is there a way to contact Mr. Pusser directly?


I would be very thankful if somebody could help.


Greetings



P.S.
I don't know i it's off-topic here (then disregard this), but maybe somebody who reads this know about replacements for my essential (can't live without them) extensions:

Advanced Night Mode: mainly switch website-colors from black-on-white to white-on-black.

Foxreplace: change website-text-snippets regarding your own rules.

Link Ninja: open bulk-links in new tabs.

Remove-It-Permanently: remove website-elements regarding your own, saved rules.
Last edited by paleuser2 on 2021-05-09, 11:38, edited 1 time in total.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 10457
Joined: 2012-10-09, 19:37
Location: The Seriphia Galaxy

Re: Urgently looking for palemoon 29.1.1 linux .deb

Unread post by New Tobin Paradigm » 2021-05-09, 10:53

Oh ffs.
Conversion Software Version 7.0
Image

KlarkKentThe3rd
Lunatic
Lunatic
Posts: 469
Joined: 2018-04-20, 20:31

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by KlarkKentThe3rd » 2021-05-09, 21:55

Moderator note: Please stick to the forum rules. Quote only relevant.
paleuser2 wrote:
2021-05-09, 02:31
i knew already that there would be a discontinue of the support for old firefox-extensions.
But i don't expected this to happen rightnow.

So my situation is like this:
...
You can find links to older builds on this forum. You will have to install manually. Those old extensions will not longer be supported, so keep using an older build. You can hope some of them will be ported, but you might end up porting them yourself. Some extensions are easy to port (you can ask me how, but my method will only work for some, and for a few months until PM changes rules again).

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2816
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by coffeebreak » 2021-05-10, 06:46

paleuser2 wrote:
2021-05-09, 02:31
Advanced Night Mode
[...]
Remove-It-Permanently
Advanced Night Mode was moved by its developer and is now installed and updated from GitHub. It remains Pale Moon-compatible.

Remove-It-Permanently appears to have just been forked for Pale Moon and is also available on GitHub.


Concerning older Steve Pusser builds, this running thread may be useful: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories.
(Also, you might want to be aware of the PM archive (not Steve Pusser's): https://www.palemoon.org/archived.shtml)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 30811
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by Moonchild » 2021-05-10, 11:38

coffeebreak wrote:
2021-05-10, 06:46
(Also, you might want to be aware of the PM archive (not Steve Pusser's): https://www.palemoon.org/archived.shtml)
The archive only contains official tarballs of official mainline binaries - it doesn't archive third party builds, re-packs or distro-specific package formats.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
"It kind of sucks when you realize that being human is a scarce commodity." -- Bob Bilheimer
Image

User avatar
RandLin
Moongazer
Moongazer
Posts: 10
Joined: 2021-05-07, 22:19

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by RandLin » 2021-05-10, 20:01

After you login into the Open Build service, you can branch a package at a specific version.
To branch Pale Moon at version 29.1.1, for example, you could use this link: https://build.opensuse.org/packages/palemoon/branches/home:stevenpusser?revision=706.
Make sure under More Options you check Stay on this Revision. Also once its branched, make sure to disable Build Publishing so you are not distributing unauthorized builds. This will rebuild Pale Moon 29.1.1 for all OS's supported by Steve Pusser.
Image (Why can't I stop walking??)

User avatar
paleuser2
Newbie
Newbie
Posts: 5
Joined: 2021-05-09, 01:36

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by paleuser2 » 2021-05-10, 20:28

KlarkKentThe3rd wrote:
2021-05-09, 21:55
You can find links to older builds on this forum. You will have to install manually.
That's why i asked for Steve Pusser's .deb builds. Because i don't have to build anything myself but they install flawless on debian.

Those old extensions will not longer be supported, so keep using an older build. You can hope some of them will be ported, but you might end up porting them yourself.
I have no clue about porting extensions.

Some extensions are easy to port (you can ask me how, but my method will only work for some, and for a few months until PM changes rules again).
Would be fine if you could could give me a hint how to port my extensions for 29.2 and above versions.

Greetings

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 10457
Joined: 2012-10-09, 19:37
Location: The Seriphia Galaxy

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by New Tobin Paradigm » 2021-05-10, 22:58

Local hacking will only get you so far and helps no one in the longer term.
Conversion Software Version 7.0
Image

User avatar
paleuser2
Newbie
Newbie
Posts: 5
Joined: 2021-05-09, 01:36

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by paleuser2 » 2021-05-11, 17:34

RandLin wrote:
2021-05-10, 20:01
After you login into the Open Build service, you can branch a package at a specific version.
To branch Pale Moon at version 29.1.1, for example, you could use this link: https://build.opensuse.org/packages/palemoon/branches/home:stevenpusser?revision=706.
Make sure under More Options you check Stay on this Revision.
Did so.

Also once its branched, make sure to disable Build Publishing so you are not distributing unauthorized builds. This will rebuild Pale Moon 29.1.1 for all OS's supported by Steve Pusser.
Can' t find that option nor where i can download the 29.1.1 versions then.
There's a 'download package' link, but if i follow that link, the download site shows: 'No data for home:palemoonuser:branches:home:stevenpusser / palemoon'


Greetings

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 466
Joined: 2017-04-20, 21:25
Contact:

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by Lunokhod » 2021-05-12, 12:38

Depending on your package management methods and history you might find older versions in your local package cache:
/var/cache/apt/archives
And once you have found a deb at the right version, you can copy the file to other systems of the same arch, ie 32 / 64 bit, and install it:
# dpkg -i path/to/deb
Wait, it's all Ohio? Always has been...

User avatar
RandLin
Moongazer
Moongazer
Posts: 10
Joined: 2021-05-07, 22:19

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by RandLin » 2021-05-12, 21:06

paleuser2 wrote:
2021-05-11, 17:34
...

Can' t find that option nor where i can download the 29.1.1 versions then.
There's a 'download package' link, but if i follow that link, the download site shows: 'No data for home:palemoonuser:branches:home:stevenpusser / palemoon'


Greetings
Log in (if you logged out) and go to your branch of Pale Moon.
Click on the package called palemoon.
Once there click on the Repositories tab. EDIT: while your there, disable 'Publish Flag' for all. I could post a picture of what I'm talking about if it helps you.
Under the Build Flag column, click on your distribution you want .deb packages files for.
Download the .deb file for your arch.
Note: you have to be logged in to download the package.

That's what I do.
Image (Why can't I stop walking??)

User avatar
paleuser2
Newbie
Newbie
Posts: 5
Joined: 2021-05-09, 01:36

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by paleuser2 » 2021-05-12, 22:57

RandLin wrote:
2021-05-12, 21:06

Log in (if you logged out) and go to your branch of Pale Moon.
Click on the package called palemoon.
Once there click on the Repositories tab. EDIT: while your there, disable 'Publish Flag' for all.
The 'Publish Flag' was already set to disabled by default for all builds.
Nevertheless i switched (to be sure) the top left (Row: All, Column: All) manually again to disabled.
Then a small dot appeared at the disabled-sign.

I could post a picture of what I'm talking about if it helps you.
Under the Build Flag column, click on your distribution you want .deb packages files for.
Download the .deb file for your arch.
No picture needed, good explanation.
Thanks for your help.


Greetings.

User avatar
RandLin
Moongazer
Moongazer
Posts: 10
Joined: 2021-05-07, 22:19

Re: Urgently looking for palemoon 29.1.1 linux .deb (Steve Pusser builds)

Unread post by RandLin » 2021-05-13, 20:04

Moderator note: unnecessary full-post quote removed. Please follow forum rules.
paleuser2 wrote:
2021-05-12, 22:57
I forgot that branching a package disables build publishing, so that part was unnecessary.
Best of luck and I hope Pale Moon extension replacements become available for you soon.
Image (Why can't I stop walking??)

Post Reply