Steve's GPG signature for Ubuntu Repository invalid! Topic is solved

For contributed third party builds not necessarily configured like the main product.
e.g. AVX builds, SSE builds, Pandora builds.
Post Reply
nero355
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-15, 18:20

Steve's GPG signature for Ubuntu Repository invalid!

Post by nero355 » 2021-02-02, 17:15

Code: Select all

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_20.04  InRelease: The following signatures were invalid: EXPKEYSIG 0FAD31CA8719FCE4 home:stevenpusser OBS Project <home:stevenpusser@build.opensuse.org>
W: Failed to fetch http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_20.04/InRelease  The following signatures were invalid: EXPKEYSIG 0FAD31CA8719FCE4 home:stevenpusser OBS Project <home:stevenpusser@build.opensuse.org>
W: Some index files failed to download. They have been ignored, or old ones used instead.
I can't get this fixed without his help so how can I reach him to report this ? :mrgreen:

His website shows the following instructions at the moment :

Code: Select all

echo 'deb http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_20.04/ /' | sudo tee /etc/apt/sources.list.d/home:stevenpusser.list
curl -fsSL https://download.opensuse.org/repositories/home:stevenpusser/xUbuntu_20.04/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home_stevenpusser.gpg > /dev/null
sudo apt update
sudo apt install palemoon
If you need any additional information please let me know ;)

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1323
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by Isengrim » 2021-02-02, 18:30

Code: Select all

The following signatures were invalid: EXPKEYSIG 0FAD31CA8719FCE4
I'm seeing the same thing on Debian Testing. Looks like the signing keys expired. Steve will need to fix this on his end.
a.k.a. Ascrod
Linux Mint 19.3 Cinnamon (64-bit), Debian Bullseye (64-bit), Windows 7 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
Tharthan
Board Warrior
Board Warrior
Posts: 1238
Joined: 2019-05-20, 20:07
Location: New England

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by Tharthan » 2021-02-02, 19:06

I sent him a PM to give him a heads up.
"This is a war against individuality and intelligence. Only thing we can do is stand strong."adesh, 9 January 2020

"I used to think I was a grumpy old man, but I don't hold a candle compared to Tharthan."Cassette, 9 September 2020

Image

nero355
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-15, 18:20

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by nero355 » 2021-02-02, 23:02

Tharthan wrote:
2021-02-02, 19:06
I sent him a PM to give him a heads up.
Many thanks! :thumbup: :mrgreen:

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 743
Joined: 2015-08-01, 18:33
Location: California

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by stevepusser » 2021-02-02, 23:05

Thanks--I think that happened years ago, too. The solution at that time was to repeat the step to download the "Release.key" file and add it to the trusted key archive. Let me know if that fixes it.

nero355
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-15, 18:20

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by nero355 » 2021-02-03, 16:16

stevepusser wrote:
2021-02-02, 23:05
Thanks--I think that happened years ago, too. The solution at that time was to repeat the step to download the "Release.key" file and add it to the trusted key archive. Let me know if that fixes it.
I tried that immediately ofcourse and it did not work yesterday and neither did it today :

cat /etc/apt/sources.list.d/home:stevenpusser.list

Code: Select all

deb http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_20.04/ /
cat /etc/apt/trusted.gpg.d/home_stevenpusser.gpg

Code: Select all

W���/H� ]}\ʦ��
�\            #>p�����N��M�����k��2C�2�����5�Z~W?4����dm��}q�Q���ޠE�m�
  !��� 8�GFd]��▒�ǚD�7��X�5�D�LG�E��S��O`{
                                         ��n-��1�<�+�*�լ�ak�,�▒��Na�����
                                                                        �Y9��ۭ��zE�1߬}uU��W���D▒i�5�NÁ��6��C��f�A�z?NTX▒�`*��`�c��(����\�]8���a��Sw��Dhome:stevenpusser OBS Project <home:stevenpusser@build.opensuse.org>�>(`�u
(As far as this is usefull when it sent via webpages encoding...)

I am using Kubuntu 20.04 LTS by the way.

Soo... what to do next ?!

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 743
Joined: 2015-08-01, 18:33
Location: California

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by stevepusser » 2021-02-03, 19:59

Remove the old key first. See it with "apt-key list".

Remove the expired key: (example)

Code: Select all

sudo apt-key del "F961 1EC6 ADCF DD30 3362  217A 0FAD 31CA 8719 FCE4"
20.04 amd64 packages are failing to build with gcc-9, the default compiler in 20.04. I'm uploading a special source for that build that forces it to use gcc-8, which worked in a test build on my local laptop. (crosses fingers and hopes)

You should be able to use the same updated repo key for the special package--if it succeeds, it will just show up as an update.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1636
Joined: 2013-05-20, 18:19
Location: Somewhere in Sector 001
Contact:

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by trava90 » 2021-02-03, 20:16

Off-topic:
stevepusser wrote:
2021-02-03, 19:59
20.04 amd64 packages are failing to build with gcc-9, the default compiler in 20.04.
Steve, can you post or PM me the build log?

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 743
Joined: 2015-08-01, 18:33
Location: California

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by stevepusser » 2021-02-03, 22:02

trava90 wrote:
2021-02-03, 20:16
Off-topic:
stevepusser wrote:
2021-02-03, 19:59
20.04 amd64 packages are failing to build with gcc-9, the default compiler in 20.04.
Steve, can you post or PM me the build log?
It should be viewable for anyone, even if you aren't signed in on the OBS. But attached is a zip of the log.
fail-log.zip
(286.88 KiB) Downloaded 7 times
The actual error is probably a bit before the actual stop, since the other threads keep going until they're done, but it didn't jump out at me.

I tried a local build that forced it to use the gcc-8 that's still in 20.04 repos, and that succeeded. I then made a separate package with that tweak just to get that up on the OBS, and it's still building: https://build.opensuse.org/package/show ... ocal-amd64

I think I can fiddle with alternatives for the gcc versions in the debian/control file so I can get all the builds to go from just one source. I could also try adding

Code: Select all

Build-Conflicts: gcc-9, g++-9
If I add build-depend alternatives for the various versions of gcc, it will use the first available one in the list

Code: Select all

gcc-10, gcc-8, gcc-7, gcc-6, gcc-5, gcc-4.9, gcc-4.8
So for those old Ubuntu 16.04 builds, it would skip all the others until it got down to 4.8--even though the 32-bit builds fail there, too.

nero355
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-15, 18:20

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by nero355 » 2021-02-04, 16:08

stevepusser wrote:
2021-02-03, 19:59
Remove the old key first. See it with "apt-key list".

Remove the expired key: (example)

Code: Select all

sudo apt-key del "F961 1EC6 ADCF DD30 3362  217A 0FAD 31CA 8719 FCE4"
20.04 amd64 packages are failing to build with gcc-9, the default compiler in 20.04. I'm uploading a special source for that build that forces it to use gcc-8, which worked in a test build on my local laptop. (crosses fingers and hopes)

You should be able to use the same updated repo key for the special package--if it succeeds, it will just show up as an update.
It works now! Thnx! :mrgreen:

BenFenner
Fanatic
Fanatic
Posts: 222
Joined: 2015-06-01, 12:52
Location: US Southeast

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by BenFenner » 2021-02-18, 19:20

I finally got around to updating my Linux Mint system and ran into this problem. After faffing around a bit with less-than desirable solutions, I found this thread and was able to get everything working as intended again.

Thank you stevepusser and others! :D

BenFenner
Fanatic
Fanatic
Posts: 222
Joined: 2015-06-01, 12:52
Location: US Southeast

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by BenFenner » 2021-02-18, 21:42

Welp, of course it can't be that easy.
Apparently this was all left-over from when I tried to install PM via the package manager. That never worked right, so I installed via *.deb file.
I've fixed the package manager stuff, and actually updated that version of PM I have installed. :crazy:

But now I guess I have to figure out how to update the instance I'm actually using. Probably just download the latest *.deb file...
I'm such a mess.

BenFenner
Fanatic
Fanatic
Posts: 222
Joined: 2015-06-01, 12:52
Location: US Southeast

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by BenFenner » 2021-02-19, 14:17

I can't edit my post above (time limit?) so I'm posting anew.

I either just needed to restart PM one more time to have the update from the package manager take effect, or the browser is "installed" from a *.deb file and it finally updated on its own.

Either way, I'm on 29.0.1 now and good to go. :)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 30036
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by Moonchild » 2021-02-19, 14:51

Off-topic:
BenFenner wrote:
2021-02-19, 14:17
I can't edit my post above (time limit?) so I'm posting anew.
Correct, there is a limited time in which you can edit your posts. This measure was necessary to prevent people from being wantonly destructive to posts on the forum.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
dotCentre
Newbie
Newbie
Posts: 3
Joined: 2021-03-01, 13:55

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by dotCentre » 2021-03-01, 14:01

A.
curl -fsSL https://download.opensuse.org/repositor ... elease.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home_stevenpusser.gpg > /dev/null

B.
curl -fsSL https://download.opensuse.org/repositor ... elease.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home:stevenpusser.gpg > /dev/null

diff is "_" / ":" in "home:stevenpusser.gpg > /dev/null"

try :
"sudo ln /etc/apt/trusted.gpg.d/home_stevenpusser.gpg home:stevenpusser.gpg"

bye all
stay clean in your mind
:-)

User avatar
dotCentre
Newbie
Newbie
Posts: 3
Joined: 2021-03-01, 13:55

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by dotCentre » 2021-03-09, 11:48

Hello other Palemoon users/developers

since I am not an expert like most of you here,
would any one please tell me is my last post was of some help or not , thank you.

In my case situation i was have that problem an I was unable to update Palemoon with the said error.

Search quit a bit the web to try to understand the crypto part / key of the error.

Then I have notice the "_" instead ":" in the in the / etc / apt / trusted.gpg.d / home_stevenpusser.gpg
And the curl command line to install it had the "_"

A quick lookup at my other machines, all was showing the same .

Having no clues if this was because some new "behaviour" of some crypto part / key part
or an error from Palemoon that would latterly be addressed,
I installed a symlink file and the update did work without any more errors.

I was happy to share that information here, since I have seen it was a concern from a several months.

Am I the only one to had this problem ?
Was this problem already solved and I did miss any previous explanation ?
Or just no one here have read my few modest lines ?

Keep you mind clean
:-)
dc

BenFenner
Fanatic
Fanatic
Posts: 222
Joined: 2015-06-01, 12:52
Location: US Southeast

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by BenFenner » 2021-03-09, 15:10

dotCentre wrote:
2021-03-09, 11:48
Was this problem already solved and I did miss any previous explanation ?
Correct.

User avatar
dotCentre
Newbie
Newbie
Posts: 3
Joined: 2021-03-01, 13:55

Re: Steve's GPG signature for Ubuntu Repository invalid!

Post by dotCentre » 2021-03-09, 18:21

Thank you very much BenFenner,

I appreciate more than what I could say.
And sorry for any noise.

I am anyhow still struggling to find it here.
Please, would it be possible to point me on to it,
I of course would learn something from it.

With the hope it is ! too much asking...

Thank you

Keep your mind clean
dc

Post Reply