Pale Moon SSE for Linux

For contributed third party builds not necessarily configured like the main product.
e.g. AVX builds, SSE builds, Pandora builds.

Moderator: satrow

roytam1
Fanatic
Fanatic
Posts: 159
Joined: 2015-03-11, 07:01
Location: Hong Kong

Re: Pale Moon SSE for Linux

Unread post by roytam1 » 2018-07-08, 12:09

if you want to change compiler, it is better to run "mach clobber" first, so it cleans up obj directory and no mix-up of object files created by different compiler.

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-07-08, 14:54

roytam1 wrote:if you want to change compiler, it is better to run "mach clobber" first, so it cleans up obj directory and no mix-up of object files created by different compiler.
Thanks for the suggestion, I tried it, but I got the same result :(

Walter Dnes
Astronaut
Astronaut
Posts: 604
Joined: 2015-07-30, 20:29
Location: Vaughan, ON, Canada

Re: Pale Moon SSE for Linux

Unread post by Walter Dnes » 2018-07-08, 23:04

The 4.9.4 script doesn't work for me either. I apologize, but there must be a typo somewhere in there. Anyhow, if you have 4.9.3, no point in installing 4.9.4. Next question; what are you building
  • Firefox 45
  • Pale Moon 27.something
  • Pale Moon 28 beta
If you're building 28 beta, you can use GCC 7.3 if you wish

Next question; are you building on the same machine that it will be running on? That also makes a difference.
There's a right way
There's a wrong way
And then there's my way

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-07-09, 04:14

I'm trying to build roytam1's Firefox 45 ESR.
On same machine.
Last edited by AthlonXPUser on 2018-07-09, 04:14, edited 1 time in total.

Walter Dnes
Astronaut
Astronaut
Posts: 604
Joined: 2015-07-30, 20:29
Location: Vaughan, ON, Canada

Re: Pale Moon SSE for Linux

Unread post by Walter Dnes » 2018-07-17, 20:34

Version 27.9.4 tarball is available for downloading. This is a security/usability update. Please read the full release notes at: http://www.palemoon.org/releasenotes.shtml

The download URL for the SSE build is ftp://contrib:get@ftp.palemoon.org/SSE-Linux/palemoon-27.9.4SSE.linux-i686.tar.bz2

Since this is not a mainstream build, it has to be installed manually. See the first post in this thread for install instructions.
There's a right way
There's a wrong way
And then there's my way

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-07-21, 23:09

yami_ wrote:
AthlonXPUser wrote:You mean I should compile webkit too? Surf's webpage tells: "Compile your own webkit or expect hell.". I tried to compile webkit, it took 30 (thirty) fucking hours on my Athlon XP when it said it failed to generate the documentation
And generating documentation was probably one of the last things it needs to do... Yes, I suggested you should compile your own webkit. But seems that you won't be able to do this. Well, you use Lubuntu, right? If so, there is surf package available for Ubuntu based distros (I have discovered it today). You could try to install it this way. The 2.x versions use webkit2gtk and 0.x versions should use older webkitgtk.
I was able to cross-compile WebKit (with LXC) for 32bit pentium 3 arch. It generated an 1.3GB .so file (and some smaller other files in the lib folder). How can I use these files with surf?

(It is not possible to build WebKit on 32 bit systems because linking the 1.3GB .so file requires more than 4GB memory for a single linker process.)

yami_
Astronaut
Astronaut
Posts: 502
Joined: 2018-04-26, 11:05

Re: Pale Moon SSE for Linux

Unread post by yami_ » 2018-07-22, 11:10

AthlonXPUser wrote:How can I use these files with surf?
You can replace the libwebkit2gtk-4.0.so from the libwebkit2gtk-4.0-dev package with the one the you have compiled. The you can try to compile surf again.
Off-topic:
I must say, the webkit2gtk dynamically loaded library should be much smaller than 1,3 GB. The one that comes with libwebkit2gtk-4.0-dev package has only 50 MB...
cat came back from Berkeley waving flags -- rob pike

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-07-22, 23:29

It was very large because I was building it with -DCMAKE_BUILD_TYPE=RelWithDebInfo instead of -DCMAKE_BUILD_TYPE=Release. With Release it was only 53MB.
Then I tried what you suggested but I got this:

Code: Select all

** (surf:3381): ERROR **: 01:01:20.269: Unable to fork a new child process: Failed to execute child process “/usr/local/libexec/webkit2gtk-4.0/WebKitWebProcess” (No such file or directory)
Trace/breakpoint trap (core dumped)
So it is not that easy or I don't know...
I'm able to compile WebKit with 5 easy steps/commands in a VM. In the VM I installed everything from scratch (VM is 32 bit Lubuntu 18.04) and then surf works with my compiled WebKit. I do the very same on my Athlon XP and compile fails because some header file doesn't exists. Doesn't make any sense. I'm doing exactly the same thing, both on a fresh system.

By the way, I found SSE2 instructions in WebKit's source hardcoded with no SSE2 check. Also, when surf is crashing on Athlon XP with libwebkit2gtk-4.0-dev package then it says SIGILL for LFENCE, which is an SSE2 instruction.

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-07-23, 21:33

Wow, finally I actually made it!
I just copied the files it was missing from somewhere else where they were, then I've overwritten libjavascriptcoregtk-4.0.so, libwebkit2gtk-4.0.so and libwebkit2gtkinjectedbundle.so everywhere and now my compiled WebKit runs on my Athlon XP! Feels good man! 8-) By the way it was still not working because of SSE2, but I've fixed it in the source, recompiled it, copied over the new files and now it works!!! Thank you everybody for the so much help! :thumbup:

yami_
Astronaut
Astronaut
Posts: 502
Joined: 2018-04-26, 11:05

Re: Pale Moon SSE for Linux

Unread post by yami_ » 2018-07-24, 08:15

That is good to hear.
cat came back from Berkeley waving flags -- rob pike

User avatar
Serpentine
Moongazer
Moongazer
Posts: 8
Joined: 2018-06-11, 02:22

Re: Pale Moon SSE for Linux

Unread post by Serpentine » 2018-08-06, 12:59

Hi Walter,
thank you very much for the update!
Walter Dnes wrote:Version 27.9.4 tarball is available for downloading. [...]

The download URL for the SSE build is ftp://contrib:get@ftp.palemoon.org/SSE-Linux/palemoon-27.9.4SSE.linux-i686.tar.bz2
[...]
I'm sorry I have to tell you I can't download the file. This ftp-Server wouldn't connect. I tried since yesterday with different ftp-clients.

e.g.: This is what filezilla gives me

Code: Select all

Status:	Auflösen der IP-Adresse für ftp.palemoon.org
Status:	Verbinde mit 80.255.0.190:21...
Fehler:	Zeitüberschreitung der Verbindung
Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen
Status:	Nächsten Versuch abwarten...
and so on, again and again. Every other client I tried gave an equal result, even wget.

Maybe you can do something that the server connects.
Greetings
Serpentine
Last edited by Serpentine on 2018-08-06, 13:00, edited 1 time in total.

Walter Dnes
Astronaut
Astronaut
Posts: 604
Joined: 2015-07-30, 20:29
Location: Vaughan, ON, Canada

Re: Pale Moon SSE for Linux

Unread post by Walter Dnes » 2018-08-06, 13:29

Serpentine wrote:Maybe you can do something that the server connects.
Greetings
Serpentine
I can't connect either. I've notified the people who deal with this, so they can look into it.
There's a right way
There's a wrong way
And then there's my way

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24203
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Pale Moon SSE for Linux

Unread post by Moonchild » 2018-08-06, 16:36

Server has been given a swift kick up the behind.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
AthlonXPUser
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2018-06-28, 19:57

Re: Pale Moon SSE for Linux

Unread post by AthlonXPUser » 2018-08-16, 16:16

AthlonXPUser wrote:Wow, finally I actually made it!
I just copied the files it was missing from somewhere else where they were, then I've overwritten libjavascriptcoregtk-4.0.so, libwebkit2gtk-4.0.so and libwebkit2gtkinjectedbundle.so everywhere and now my compiled WebKit runs on my Athlon XP! Feels good man! 8-) By the way it was still not working because of SSE2, but I've fixed it in the source, recompiled it, copied over the new files and now it works!!! Thank you everybody for the so much help! :thumbup:
Off-topic:
My commits are merged into WebKit master. This means that you will be able to run any WebKit-based browser in the future. To make it work on non-SSE2 machines, it was only needed to delete a little code. I can suggest trying apt-get install epiphany-browser, it is using the newest WebKit and runs on machines without SSE2. Well, not right now, but when the version is released which has my modifications. I don't know when it will be, but I'll keep you updated.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24203
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Pale Moon SSE for Linux

Unread post by Moonchild » 2018-08-16, 16:42

Pale Moon SSE for Linux has been discontinued with the advent of Pale Moon 28.

Closing this thread.

PS: There's no real point discussing webkit here.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Locked