Increasing problems with PM

General discussion area and chat

Moderator: satrow

Forum rules
This General Discussions forum is an open chat area, so you can talk about almost any subject. Please keep things civil, though!

Please do try to somewhat stick to the relevance of this forum, which focuses on everything around the Pale Moon project and its user community. "Totally random" subjects don't really belong here, even in the general discussion area.
Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Increasing problems with PM

Unread postby Peano » Thu, 30 Nov 2017, 23:42

I'm running the latest version of PM, always install updates when they're offered. Windows 7 Pro 64-bit, Dell Studio desktop.

I'm having increasing problems with PM that don't occur on other browsers (IE and SlimJet). For instance, on some sites, the Home and End keys will not jump the page to the top and bottom (but if I go to SlimJet, those keys works as they're supposed to). Same with the up and down arrows to scroll a page.

Here's another that just cropped up: I often upload photos to forums that use Disqus comments. Never had any problem until yesterday. When I hit Enter to upload a photo, got this error message:

Image

It's a jpeg well under 5MB. When I switch to SlimJet, the images upload as always. Having the same problem today, and SlimJet solves it.

I like Pale Moon primarily because it works pretty much the same as the old versions of Firefox that I got used to. But I'm approaching the point where the aggravations might not be worth the candle. SlimJet works flawlessly; I think I could adapt to the differences that seem a bit strange to me right now.

I don't mean this as a rant. Just wonder if others are experiencing such difficulties with PM. It seems to be getting worse, not better.

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1617
Joined: Tue, 19 May 2015, 02:26
Location: Arizona U.S.

Re: Increasing problems with PM

Unread postby Thehandyman1957 » Fri, 01 Dec 2017, 00:21

What type of add on's do you have?
"A common mistake people make when trying to design something
completely FOOLPROOF, is underestimating the ingenuity of complete FOOLS! ;) "

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Fri, 01 Dec 2017, 00:38

UBlock Origin is the main one, but I've had that all along and it hasn't interfered with image uploads to Disqus. I hadn't added any when this latest problem started.

User avatar
Greywool
Apollo supporter
Apollo supporter
Posts: 45
Joined: Thu, 10 Sep 2015, 10:45
Location: Finland

Re: Increasing problems with PM

Unread postby Greywool » Fri, 01 Dec 2017, 01:16

Can you offer examples of pages on which arrow/home/etc keys work properly and on where it fails?
One possiblity which might affect their behaviour is if you've accidentally enabled caret browsing. Hit F7 to make sure it's disabled

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Fri, 01 Dec 2017, 02:18

Thank you. Hitting F7 solved the Home/End and up/down problem. I never heard of caret browsing before, so I appreciate that.

That doesn't have any effect on the image-uploading problem. Not sure what's going on there.

Thanks again.

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1617
Joined: Tue, 19 May 2015, 02:26
Location: Arizona U.S.

Re: Increasing problems with PM

Unread postby Thehandyman1957 » Fri, 01 Dec 2017, 03:51

It is possible your filter lists got updated. I would try PM in Safe Mode just to be sure.
"A common mistake people make when trying to design something
completely FOOLPROOF, is underestimating the ingenuity of complete FOOLS! ;) "

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Fri, 01 Dec 2017, 05:32

Thehandyman1957 wrote:It is possible your filter lists got updated. I would try PM in Safe Mode just to be sure.


Thank you. I tried it in safe mode, and pictures uploaded as they should. Then launched PM normally and disabled uBlock Origin, and they also uploaded normally. So the ad blocker is causing the problem.

SlimJet has a built-in ad blocker that doesn't interfere like this, so that's one more factor in favor of switching to SlimJet.

Thanks again for your suggestion!

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 835
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

Re: Increasing problems with PM

Unread postby gracious1 » Fri, 01 Dec 2017, 07:55

Peano wrote:
Thehandyman1957 wrote:It is possible your filter lists got updated. I would try PM in Safe Mode just to be sure.
Thank you. I tried it in safe mode, and pictures uploaded as they should. So the ad blocker is causing the problem.


To resolve this issue: First, make sure you have the latest release installed. Then, open the Dashboard and make sure your filters are up-to-date. If uBlock Origin remains a problem, then you should open an issue at ublock/assets at Github. I have found that when I have reported issues there I get a very fast response.
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone ◊ Int'l Day of Peace 21 Sept. ◊

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1159
Joined: Sun, 19 Aug 2012, 20:32

Re: Increasing problems with PM

Unread postby back2themoon » Fri, 01 Dec 2017, 12:14

Peano wrote:Thank you. I tried it in safe mode, and pictures uploaded as they should. Then launched PM normally and disabled uBlock Origin, and they also uploaded normally. So the ad blocker is causing the problem.

Not necessarily. It's probably one of the filter lists you use that causes the issue with a recent update. Ad-blockers use filter lists, but they are not the same thing. Check with your filterlists to see which one is the cause.
Safe Mode / clean profile info: Menu/Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides

Windows 10 Pro - Pale Moon x64 - FossaMail x64 - Emsisoft Anti-Malware

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Fri, 01 Dec 2017, 16:42

back2themoon wrote:Not necessarily. It's probably one of the filter lists you use that causes the issue with a recent update. Ad-blockers use filter lists, but they are not the same thing. Check with your filterlists to see which one is the cause.


Thanks, but I don't know what or where filterlists are.

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1617
Joined: Tue, 19 May 2015, 02:26
Location: Arizona U.S.

Re: Increasing problems with PM

Unread postby Thehandyman1957 » Sat, 02 Dec 2017, 02:02

If you click on your UBlock icon and look to the right below the big blue power button you will see either a set
of gears or sliders. Click on that.
Screenshot - 12_1_2017 , 6_57_52 PM.png

Then click on the "3rd Party filters tab.
Screenshot - 12_1_2017 , 6_58_57 PM.png

You can uncheck one at a time and try your upload till you find the offending filter.
Then just disable it and you should be good to go.

It's not PM causing this and you could have the same issue with Slimjet if it was running the same add on.
So it's not really a good comparison. ;)
"A common mistake people make when trying to design something
completely FOOLPROOF, is underestimating the ingenuity of complete FOOLS! ;) "

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Sat, 02 Dec 2017, 02:10

Ok, thank you very much. I will try that.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 835
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

Re: Increasing problems with PM

Unread postby gracious1 » Sat, 02 Dec 2017, 06:18

Even after you have tested the filters and found the offending one, it's still a good idea to open an issue at uBlock/uAssets at Github so people know that a filter breaks something (that way they can fix it for future releases).
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone ◊ Int'l Day of Peace 21 Sept. ◊

Peano
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sat, 11 Oct 2014, 01:33
Location: USA

Re: Increasing problems with PM

Unread postby Peano » Sat, 02 Dec 2017, 16:50

gracious1 wrote:Even after you have tested the filters and found the offending one, it's still a good idea to open an issue at uBlock/uAssets at Github so people know that a filter breaks something (that way they can fix it for future releases).

Done. Thank you.

The culprit appears to be Ads > EasyList. When I disabled that, the problem resolved.

sindi
Moonbather
Moonbather
Posts: 65
Joined: Wed, 21 Dec 2016, 02:23

Re: Increasing problems with PM

Unread postby sindi » Tue, 20 Feb 2018, 18:20

F7 for Caret Browsing does nothing (Pale Moon SSE for linux). I disabled uBlock and rebooted - no change.


Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 6 guests