Pale Moon Crashes with ABORT: X_ShmPutImage

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 02:26

I'm getting this in my terminal from a private page on BlogSpot after PaleMoon crashes hard:

Code: Select all

###!!! ABORT: X_ShmPutImage: BadMatch (invalid parameter attributes); 29 requests ago: file /home/palemoon/PaleMoon/pmsrc/toolkit/xre/nsX11ErrorHandler.cpp, line 145
###!!! ABORT: X_ShmPutImage: BadMatch (invalid parameter attributes); 29 requests ago: file /home/palemoon/PaleMoon/pmsrc/toolkit/xre/nsX11ErrorHandler.cpp, line 145
Segmentation fault
Using PaleMoon Version: 25.6.0 (x64) - just installed it yesterday on a brand new installation of Linux Mint as I am in the process of ditching Kubuntu.
I can send you the output from troubleshooting info if you need it.
I've installed Chrome (webkit), Maxthon (trident) and Opera (not sure what it uses) as well as the default installation of Firefox - I'll try the page out in the various browsers and get back to you with the results.

Moderator note: Split into separate topic since this is a completely different error message.
Last edited by Shadeclan on 2015-08-01, 02:44, edited 1 time in total.
Image

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Palemoon crashes all the time here too

Post by Shadeclan » 2015-08-01, 02:43

Shadeclan wrote:... I've installed Chrome (webkit), Maxthon (trident) and Opera (not sure what it uses) as well as the default installation of Firefox - I'll try the page out in the various browsers and get back to you with the results ...
Sorry to be the bearer of bad news but PaleMoon is the only browser that crashes. However, I do have additional information. There is a video frame embedded in the webpage. The crash doesn't happen until I scroll down far enough that the top edge of the frame should appear - at that point, PaleMoon just disappears and the error I posted appears in the terminal.

Hope that helps.
Image

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1610
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by trava90 » 2015-08-01, 03:09

Can you post a link to the specific page this happens on?
Shadeclan wrote:brand new installation of Linux Mint
x86 or x64? KDE edition?

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 12:04

trava90 wrote:x86 or x64? KDE edition?
64 bit Mint.
trava90 wrote:Can you post a link to the specific page this happens on?
This particular page is a private blog on BlogSpot and I can't give it out. However, I'll look around and see if I can find a public page that it happens on.

I have noticed that Linux PaleMoon seems to have issues with video display that Windows PaleMoon does not. For example, going to fullscreen on a YouTube page causes a strange shaking effect but doesn't cause PaleMoon to crash but Windows PaleMoon displays it just fine.
Image

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 12:18

Shadeclan wrote:This particular page is a private blog on BlogSpot and I can't give it out. However, I'll look around and see if I can find a public page that it happens on ...
I didn't find that error, but I did find a very reproducible and possibly related issue. Here's the scenario:

I have 2 tabs up. One tab is this forum page. The other tab is the YouTube page I previously posted. I click on the YouTube tab - the page displays and the video starts playing like normal. I click on the forum page - the forum page is displayed. Everything seems fine. Then, without actually returning to the YouTube page, I click the close button on the YouTube tab. PaleMoon crashes but this time it leaves no error message in the terminal!

I'll keep searching for a public page that causes the BadMatch error.
Image

SvenG

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by SvenG » 2015-08-01, 12:40

Shadeclan wrote:
trava90 wrote:x86 or x64? KDE edition?
64 bit Mint.
Highlight by me.

Your "scenario" works fine here.

User avatar
ketmar
Lunatic
Lunatic
Posts: 362
Joined: 2015-07-28, 11:10
Location: Earth

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by ketmar » 2015-08-01, 13:03

that may be gstreamer-related. you may try to set "media.gstreamer.enabled" to false, this will disable video playback, but may prevent crashing until the root of the issue is found. dunno if "no video, but no crash" is better then "no video, do crash", though. ;-)

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:17

Shadeclan wrote:
trava90 wrote:x86 or x64? KDE edition?
64 bit Mint.
I thought that KDE was a desktop / user interface and that Linux Mint uses the Cinnamon desktop / interface instead.
Image

SvenG

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by SvenG » 2015-08-01, 14:24

Shadeclan wrote:
Shadeclan wrote:
trava90 wrote:x86 or x64? KDE edition?
64 bit Mint.
I thought that KDE was a desktop / user interface and that Linux Mint uses the Cinnamon desktop / interface instead.
Mint comes in three flavors: Cinnamon, MATE, KDE and Xfce.

EDIT: should read four.... instead of three
Last edited by SvenG on 2015-08-01, 14:32, edited 1 time in total.

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:28

SvenG wrote:Your "scenario" works fine here.
I can't explain it.

Started PaleMoon in safe mode - still does it.
Image

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:30

SvenG wrote:Mint comes in four flavors: Cinnamon, MATE, KDE and Xfce.
I'm using Cinnamon flavor! :)
Image

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:38

ketmar wrote:that may be gstreamer-related. you may try to set "media.gstreamer.enabled" to false, this will disable video playback, but may prevent crashing until the root of the issue is found. dunno if "no video, but no crash" is better then "no video, do crash", though. ;-)
Hmmmm ... it's already set to false ... :problem:

Setting it to true makes no difference.
Last edited by Shadeclan on 2015-08-01, 14:40, edited 1 time in total.
Image

User avatar
ketmar
Lunatic
Lunatic
Posts: 362
Joined: 2015-07-28, 11:10
Location: Earth

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by ketmar » 2015-08-01, 14:40

then try to set it to "true". ;-)

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:40

ketmar wrote:then try to set it to "true". ;-)
Already did. No difference
Image

SvenG

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by SvenG » 2015-08-01, 14:40

Are you using an old profile? Found some issues with similar errors (similar = on Firefox instead of Pale Moon) on Ubuntu (should be close enough to Mint), that were said to be caused by a broken profile.

User avatar
ketmar
Lunatic
Lunatic
Posts: 362
Joined: 2015-07-28, 11:10
Location: Earth

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by ketmar » 2015-08-01, 14:44

>Already did. No difference
too bad that there are only two possible values. i'm out of ideas. ;-)

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:45

Ahhh! Found it! It's one of my plug-ins!

List of Plug-ins:
  • DivX Web Player
    QuickTime
    Shockwave Flash
    VLC Multimedia
    Windows Media Player
When I disabled all plug-ins and restarted, the problem went away. I'll pin down which is causing the issue.
Image

SvenG

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by SvenG » 2015-08-01, 14:46

Try Flash first.

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:49

Shadeclan wrote:Ahhh! Found it! It's one of my plug-ins!
It's the Flash plug-in. Leave it to Adobe to screw everything up!
Image

User avatar
Shadeclan
Lunatic
Lunatic
Posts: 303
Joined: 2014-06-05, 17:27
Location: Albany, NY

Re: Pale Moon Crashes with ABORT: X_ShmPutImage

Post by Shadeclan » 2015-08-01, 14:54

Shadeclan wrote:
Shadeclan wrote:Ahhh! Found it! It's one of my plug-ins!
It's the Flash plug-in. Leave it to Adobe to screw everything up!
... and now the private BlogSpot page I spoke of before stopped crashing. There you go. Problem found, if not solved.

Probably should put some sort of error trapping for this plug-in to keep it from making PaleMoon do a nosedive.
Image

Locked