[PM 25.5.0][Solved] no support for html5 audio

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Locked
zerocode

[PM 25.5.0][Solved] no support for html5 audio

Post by zerocode » 2015-07-08, 15:37

html5 audio tag seems not be supported. I test http://www.quackit.com/html_5/tags/html_audio_tag.cfm on Firefox 31.7.0 (works) and on Palemoon 25.5.0 (not supported).

The palemoon is build from sources just as firefox in a gentoo system. Overvlay code here.

Code: Select all

	# Basic configuration:
	mozconfig_init

	mozconfig_disable crashreporter accessibility parental-controls \
		maintenance-service webrtc install-strip

	# Not used and unmaintained. Build fails with them enabled (the default):
	mozconfig_disable tests

	if use optimize; then
		mozconfig_enable optimize=\"-O2\" shared-js
	else
		mozconfig_disable optimize
	fi

	if use official-branding; then
		official-branding_warning
		mozconfig_enable official-branding
	fi

	if use system-libs; then
		mozconfig_with system-nspr system-libevent system-nss system-jpeg \
			system-zlib system-bz2 system-png system-libvpx
		mozconfig_enable system-hunspell system-ffi system-sqlite
	fi

	if use oss; then
		mozconfig_enable oss
	fi

	export MOZBUILD_STATE_PATH="${WORKDIR}/mach_state"
	mozconfig_var PYTHON $(which python2)
	mozconfig_var AUTOCONF $(which autoconf-2.13)
	mozconfig_var MOZ_MAKE_FLAGS "${MAKEOPTS}"

	filter-flags '-O*'

	if [[ $(gcc-major-version) -lt 4 ]]; then
		append-cxxflags -fno-stack-protector
	elif [[ $(gcc-major-version) -gt 4 || $(gcc-minor-version) -gt 3 ]]; then
		if use amd64 || use x86; then
			append-flags -mno-avx
		fi
	fi

	python2 mach # Run it once to create the state directory.
	python2 mach configure || die
And my use flags

Code: Select all

 Installed versions:  25.5.0(03:21:06 25.06.2015)(alsa official-branding optimize system-libs -oss LINGUAS="fr ja ko ru zh_CN -ach -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -ff -fi -fy_NL -ga_IE -gd -gl_ES -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -kk -km -kn -ku -lg -lij -lt -lv -mai -mk -ml -mn -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -si -sk -sl -son -sq -sr -sv_SE -sw -ta -ta_LK -te -th -tr -uk -vi -zh_TW -zu")
     Homepage:            http://www.palemoon.org
     Description:         Pale Moon Web Browser
Last edited by zerocode on 2015-07-09, 02:41, edited 1 time in total.

Axiomatic

Re: [PM 25.5.0] no support for html5 audio

Post by Axiomatic » 2015-07-08, 16:08

I am able to play the audio from the website you posted. No fallback content is displayed, what exactly do you see?

Since mp3 is not free it may rely on support via GStreamer. So try going into about:config, and set the preference 'media.gstreamer.enabled' to 'true'. Then restart your browser, and see if you are able to play the audio from that site.

(Next time you build Pale Moon, you can add --enable-gstreamer in your .mozconfig to provide the preference to be set to true automatically.)

squarefractal

Re: [PM 25.5.0] no support for html5 audio

Post by squarefractal » 2015-07-08, 16:10

You may also need to install the gstreamer-0.10-ffmpeg (or a similarly named) package for things to work.

zerocode

Re: [PM 25.5.0] no support for html5 audio

Post by zerocode » 2015-07-08, 16:14

The gstreamer was disabled and that cause the issue. The example start to work normally once I've enabled gstreamer. Thanks for fast reply.

about:config is so vast that it requires FAQ for most used options. Or advanced help system like emacs configuration variables supplies.

Axiomatic

Re: [PM 25.5.0] no support for html5 audio

Post by Axiomatic » 2015-07-08, 16:23

zerocode wrote:The gstreamer was disabled and that cause the issue. The example start to work normally once I've enabled gstreamer. Thanks for fast reply.

about:config is so vast that it requires FAQ for most used options. Or advanced help system like emacs configuration variables supplies.
I am glad Pale Moon is working for you, if you can please edit the first post (the title) to denote the issue is solved.
Off-topic:
You can use http://kb.mozillazine.org/Knowledge_Base for more information on preferences that you will usually touch, just search for the preference name - it is getting outdated slowly though.

Locked