[solved] Errors with Arch Linux AUR Build

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Locked
User avatar
0strodamus
Fanatic
Fanatic
Posts: 113
Joined: 2014-11-19, 19:48
Location: US

[solved] Errors with Arch Linux AUR Build

Post by 0strodamus » 2015-06-16, 22:01

Hi, I'm experiencing errors with Palemoon 25.5.0-1 built using the Arch Linux AUR PKGBUILD. I'm getting the error when closing a tab. The error is:

Code: Select all

Assertion Failed

ASSERT: Giving up waiting for the tab closing animation to finish (bug 608589)
Stack Trace: 
0:([object XULElement],[object XULElement])
I am building with the following changes to the options in the mozconfig.in file provided by the AUR build:

Code: Select all

ac_add_options --disable-safe-browsing
ac_add_options --disable-url-classifier
The binary version provided by trava90 works fine (thanks trava90!). I'm happy to keep using Pale Moon for Linux. I'm just curious why the AUR compiled version is giving these errors.
Last edited by 0strodamus on 2015-08-05, 02:14, edited 1 time in total.
archlinux | OpenRC | TOMOYO Linux | Xfce

"In his house at R'lyeh dead Cthulhu waits dreaming."


User avatar
0strodamus
Fanatic
Fanatic
Posts: 113
Joined: 2014-11-19, 19:48
Location: US

Re: Errors with Arch Linux AUR Build

Post by 0strodamus » 2015-06-17, 20:00

Thanks squarefractal. I'll try searching first next time. :oops:
archlinux | OpenRC | TOMOYO Linux | Xfce

"In his house at R'lyeh dead Cthulhu waits dreaming."

User avatar
0strodamus
Fanatic
Fanatic
Posts: 113
Joined: 2014-11-19, 19:48
Location: US

Re: Errors with Arch Linux AUR Build

Post by 0strodamus » 2015-08-05, 02:13

I found the solution to my issue, so I thought I would update this thread in case it can help anyone else. The "Assertion Failed" errors were caused by the Print Edit extension and downgrading to version 15.5 or lower fixes the issue. Unfortunately, 15.5 has a "Retain edits from previous session?" bug, but 15.3 works well. :thumbup:
archlinux | OpenRC | TOMOYO Linux | Xfce

"In his house at R'lyeh dead Cthulhu waits dreaming."

Locked