Java for PM 25.0.2 (x64) linux?

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Zootal

Java for PM 25.0.2 (x64) linux?

Unread post by Zootal » 2014-11-05, 21:45

I'm running PM 25.0.2 (x64) on 64 bit linux. In about:plugins, I see "No installed plugins found".

If I run firefox, and look at about:plugins I see Java(TM) Plug-in 11.25.2. I added this to firefox by symlinking my java libnpjp2.so to /usr/lib64/mozilla/plugins. There is also a skype plugin there, and firefox sees that also. Palemoon does not seem to recognize either.

So the question is, how do I get java working in PaleMoon?


Zootal

Re: Java for PM 25.0.2 (x64) linux?

Unread post by Zootal » 2014-11-06, 15:23

I did use the search, and advising one to do so doesn't help any.

I finally realized that 64 bit PaleMoon was not looking in /usr/lib64 like you would expect a 64 bit app to do, but was looking in /usr/lib.

So the answer is that although on a 64 bit system FireFox looks in /usr/lib64/mozilla/plugins, 64 bit PaleMoon looks in /usr/lib/mozilla/plugins, and you have to copy /usr/lib64/mozilla to /usr/lib/mozilla. Once I did that, PaleMoon recognized my plugins, and java seems to work. The java control panel won't run, it crashes, but that does not seem to be a PaleMoon problem. I'll have to get that resolved before I can resume PaleMoon testing, but for now the answer is to copy or symlink /usr/lib64/mozilla/plugins to /usr/lib/mozilla/plugins.

Lucio Chiappetti
Lunatic
Lunatic
Posts: 271
Joined: 2014-09-01, 15:11
Location: Milan Italy

Re: Java for PM 25.0.2 (x64) linux?

Unread post by Lucio Chiappetti » 2014-11-06, 16:07

When I installed PM 24 I was happily surprised by the fact that I did not have to migrate the plugins (while I had to migrate addons and other prefs from ~/.mozilla/firefox/wynwa44x.default/to ~/.moonchild\ productions/pale\ moon/w5zr0qvy.default/ (actually did it with FEBE) ...

... in fact in my case both firefox and PM look for plugins in ~/.mozilla/plugins/ where I have a soft link
libnpjp2.so -> /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libnpjp2.so*
The reasonable man adapts himself to the world: the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man. (G.B. Shaw)

Zootal

Re: Java for PM 25.0.2 (x64) linux?

Unread post by Zootal » 2014-11-07, 14:31

[quote=
... in fact in my case both firefox and PM look for plugins in ~/.mozilla/plugins/ where I have a soft link
libnpjp2.so -> /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libnpjp2.so*[/quote]

I don't even have a ~/.mozilla/plugins/ - don't really want to customize plugins for each user, either, hence the usage of /usr/lib64/mozilla/plugins. I just found it odd that 64 bit PM would look in /usr/lib/mozilla/plugins, where 64 bit firefox uses /usr/lib64/mozilla/plugins.

Locked