PM not remembering location of window when closed maximized

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Locked
maharin

PM not remembering location of window when closed maximized

Post by maharin » 2014-07-25, 16:48

I'm using Linux Mint 16 KDE 64-bit with two monitors.

If PM is not maximized it seems to remember its last location just fine regarless of which monitor I last used it on. However, if I maximize it on either monitor it always returns maximized on the first monitor when I open it again. Just to make it interesting I set the size of the window such that it would be the same size as if maximized on the second monitor and it had the same behavior.

Just to be clear, as long as PM is not maximized it behaves as expected and remembers which monitor and postion it was last at. If it is maximized then it will reappear on the first monitor (but still be maximized).

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29270
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: PM not remembering location of window when closed maximi

Post by Moonchild » 2014-07-25, 17:54

This may be because of the screen edge logic that is normally enabled; it depends a little on how your setup treats your desktop across multiple monitors.

You can try setting browser.sessionstore.exactPos to true, that might help.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

maharin

Re: PM not remembering location of window when closed maximi

Post by maharin » 2014-07-25, 17:59

Moonchild wrote:This may be because of the screen edge logic that is normally enabled; it depends a little on how your setup treats your desktop across multiple monitors.

You can try setting browser.sessionstore.exactPos to true, that might help.
I tried that and it doesn't seem to help as it still resets to the first monitor on loading. Thank you for trying to help, though.

On my system, both monitors are joined along one edge to form a single virtual desktop. If I have it set up with multiple virtual desktops then both monitors switch at the same time when I switch desktops. I would much rather have each monitor have its own set of virtual desktops but I don't know how (or even if) it can be set up that way.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29270
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: PM not remembering location of window when closed maximi

Post by Moonchild » 2014-07-25, 18:11

What you may want to do is manually resize the window to fill your screen. I'm not too well-versed in how X remembers window states, and there may be a simple solution in the browser code for it but that would be something for the PM4Linux devs to look at.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

maharin

Re: PM not remembering location of window when closed maximi

Post by maharin » 2014-07-25, 18:37

Moonchild wrote:What you may want to do is manually resize the window to fill your screen.
I tried that as well with no luck. It might be comparing the window size to the screen/desktop size to figure out if it is maximized and then reacting accordingly. When I size to to fit the full monitor (minus a task bar at the bottom) it behaves just like when I maximize it and it returns maximized on the first screen.

In the mean time I'm playing around with getting it "close to maximized" but that is proving difficult because KDE wants to snap the window edge to the edge of the screen when I get too close.

EDIT: Well, I can "maximize" it on three edges and leave the fourth (the right one in my case) a little less than maximum and all works well, so I'll just leave this alone for now. Thank you again for your help!

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 29270
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: PM not remembering location of window when closed maximi

Post by Moonchild » 2014-07-25, 22:04

maharin wrote:When I size to to fit the full monitor (minus a task bar at the bottom) it behaves just like when I maximize it and it returns maximized on the first screen.
maharin wrote:Well, I can "maximize" it on three edges and leave the fourth (the right one in my case) a little less than maximum and all works well
That sounds like something that might be an oddity/bug in the X window manager then. Pale Moon would not make any specific checks like that and switching behavior based on how "close" it is to being maximized.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

maharin

Re: PM not remembering location of window when closed maximi

Post by maharin » 2014-08-04, 17:49

I found a solution using KDE. Using KDE I can tell my system to automatically force Pale Moon to open at a specific location (upper-left corner of the second monitor in my case) and then have it forcibly remember the maximize setting of the window. So now when Pale Moon is not maximized it behaves as it should and when it is maximized, KDE acts on it so it also behaves as I would expect.

How To:
Set up the application to the size and position you want it to stay. In the upper-left corner of the window there is a button (usually with the application icon on it) that opens up a menu. On that menu there is an option for More Actions. Clicking More Actions reveals another menu with an option for "Special Application Settings". Click on that option to open up the options dialog. In my case I checked the position option and then the two maximize options (horizontal and vertical). Click OK and you're done.

Locked