Incompatible Greasemonkey 2.0

General discussion, compatibility and contributed extensions.

Moderators: satrow, Lootyhoof, FranklinDM

Beoulve

Incompatible Greasemonkey 2.0

Postby Beoulve » Fri, 20 Jun 2014, 07:31

First off, thanks for providing a Linux build for this, I've switched to it full time for a week or so and it's been pretty good.

Recently though, Greasemonkey has been updated to version 2.0, which is 'not available for Firefox 24' according to its Mozilla add-on page.

Is there any workaround to install it?

Image

cyansmoker

Re: Incompatible Add-on

Postby cyansmoker » Fri, 20 Jun 2014, 08:02

You could conceivably download the xpi from its source URL; for instance https://addons.mozilla.org/firefox/down ... 2.0-fx.xpi then go to Extensions -> Install add-on from file.

This is not guaranteed to work and, honestly, it seems like a bad idea to install an add on that expects more recent browser capabilities.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4982
Joined: Tue, 09 Oct 2012, 19:37

Re: Incompatible Add-on

Postby New Tobin Paradigm » Fri, 20 Jun 2014, 08:08

I can confirm that 2.0 is not functioning correctly with Pale Moon. My suggestion is to use version 1.15
New Tobin Paradigm

Help I'm steppin' into the Twilight Zone / Place is a madhouse, feels like being cloned
My beacon's been moved under moon and star / Where am I to go, now that I've gone too far

http://binaryoutcast.com/ | http://thereisonlyxul.org/

SvenG

Re: Incompatible Add-on

Postby SvenG » Fri, 20 Jun 2014, 09:57

What exactly is not working with GM 2.0 in PM? I have it running since yesterday and have no problem so far.

This thread should be moved to the Add-ons section and the title should be a bit more descriptive. Thanks :)
Last edited by SvenG on Fri, 20 Jun 2014, 15:52, edited 1 time in total.

jumba

Re: Incompatible Greasemonkey 2.0

Postby jumba » Fri, 20 Jun 2014, 11:59

probably this and maybe other internal changes that depends 29.0+
For stability, reliability, and security the privileged sandbox has been updated to match the new changes to unsafeWindow for the Add-on SDK. In order to write values to unsafeWindow you will need to use the new methods cloneInto(), exportFunction(), and/or createObjectIn().

buggy

Re: Incompatible Greasemonkey 2.0

Postby buggy » Fri, 20 Jun 2014, 13:01

I tried the 2.0, all my scripts worked, not seen any bug. But i prefer to return to the 1.15 in waiting more infos from the pros :mrgreen:

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4982
Joined: Tue, 09 Oct 2012, 19:37

Re: Incompatible Greasemonkey 2.0

Postby New Tobin Paradigm » Fri, 20 Jun 2014, 15:46

My youtube center script completely made youtube non-functional also a few other small scripts weren't working either. I dunno.. Needs more testing and more contact with the dev see if they would atleast provide 1.15 compatibility with PM if not complete.
New Tobin Paradigm

Help I'm steppin' into the Twilight Zone / Place is a madhouse, feels like being cloned
My beacon's been moved under moon and star / Where am I to go, now that I've gone too far

http://binaryoutcast.com/ | http://thereisonlyxul.org/

SvenG

Re: Incompatible Greasemonkey 2.0

Postby SvenG » Fri, 20 Jun 2014, 16:40

Ah, thanks, good to know, so maybe I am just using the right scripts (not using that many at all). At least using 2.0 doesn't make you computer explode so one can try but from what I have read so far updating is no real benefit for those whose scripts are working. Possible but not worth the effort.


Return to “Browser extensions”

Who is online

Users browsing this forum: No registered users and 5 guests