[Gremlins] No Indications of Being in Private Mode

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

cb474

[Gremlins] No Indications of Being in Private Mode

Unread postby cb474 » Sat, 17 May 2014, 08:48

I just installed Palemoon, as an alternative to Firefox, after experienced the debacle that is FF29 and Australis. Palemoon is great, I'm so glad this project exists.

One strange thing I'm noticing, however, is that when I open I private window (either while I'm already running non-private windows or when I launch Palemoon in private mode with "palemoon -private") there is zero indication that a window is a private window. I really looked and nothing in the title bar, no icons, nothing.

In FF28, it tells you that it's a private window in the title bar and it opens to a sort of private window about page, rather than my homepage. I find this odd too, that private windows open to my regular homepage, which seems to potentially defeat a bit the purpose of private mode.

Is this a bug? Anyone know what's up? Thanks.
Last edited by Moonchild on Mon, 19 May 2014, 09:36, edited 1 time in total.
Reason: Marked "caused by gremlins"

access2godzilla

Re: No Indications of Being in Private Mode

Unread postby access2godzilla » Sat, 17 May 2014, 09:09


cb474

Re: No Indications of Being in Private Mode

Unread postby cb474 » Sat, 17 May 2014, 09:22

Thanks for the link. I already saw that thread, before I started this one. It does not address the situation I'm describing.

That thread claims that if you open an private window, when you are already in a non-private window, there are icons that indicate which window is in private mode. I do not get any icons like this. The icons pictured in the images in that thread do not appear on private windows, when I open them from a non-private window.

In addition, there is nothing that indicates one is in private mode when launched from the command line, which the other thread does address, but I think this creates confusion. It's nice to have some confirmation that one is in fact in private mode, that the browser launched properly. FF28 does this and I think it's a good feature. It's the only thing I've seen in Palemoon (which does so much so well) that doesn't make sense to me.

Further, as I noted in my OP, launching a private window either way, loads my homepage, instead of a type of private browsing about page. If one wants to work in private mode, one may want to navigate directly to a specific page, without having another website (homepage) launch first, since this potentially loads javascript, allows for xss, and could undermine some of the privacy (and even security) one might have been trying to achieve by launching directly to private mode from the command line.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23038
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: No Indications of Being in Private Mode

Unread postby Moonchild » Sat, 17 May 2014, 10:23

Is this a Linux-specific issue? It works correct on Windows, at least (Purple/ Mask Indicators and PB start page).
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3772
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: No Indications of Being in Private Mode

Unread postby Night Wing » Sat, 17 May 2014, 10:28

This might be a linux issue. I'm using linux SolydX and when I open a Private Window, I get the mask in the Navigation Bar. However, if I click on any of my favorite bookmarks, the little mask in the Navigation Bar is not there anymore and doesn't return no matter how many websites I visit.

Keep in mind, I'm using the Menu Bar with my linux Pale Moon setup.
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

steviem1
Keeps coming back
Keeps coming back
Posts: 813
Joined: Sat, 24 Mar 2012, 09:42
Location: Spain

Re: No Indications of Being in Private Mode

Unread postby steviem1 » Sat, 17 May 2014, 11:29

I rarely if ever use 'Private Browsing' but I see what the OP is getting at. When I launch Pale Moon in 'Private Browsing' mode (Windows OS) there is no sign, ie, no 'Mask' icon to indicate 'Private Browsing' only the mask in the Navigation Bar which as Night Wing states promptly disappears permanently when opening new websites. The OP's other related issue regarding the non - appearance of the 'Mask' icon when opening a new 'Private Browsing window, the 'Mask' icon appears correctly for me every time as it should. The third issue where opening 'Private Browsing' mode per se, launches straight into his 'Home Page' is incorrect behaviour and for me opens into the 'Private Browsing' window. These issues the OP is experiencing could be due to the way he has his UI configured or maybe conflicting add-on issues. Suggest looking at those possibilities first.

access2godzilla

Re: No Indications of Being in Private Mode

Unread postby access2godzilla » Sat, 17 May 2014, 11:58

That thread exactly describes what you specified. You are looking for "palemoon -private-window".

cb474 wrote:launching a private window either way, loads my homepage, instead of a type of private browsing about page

It certainly does not do so for me. Did you try a clean profile?

Moonchild wrote:Is this a Linux-specific issue? It works correct on Windows, at least (Purple/ Mask Indicators and PB start page).

It's the same with Windows too, with -private (not -private-window) <https://i.imgur.com/AeKT7sD.png>. Try it out.

access2godzilla

Re: No Indications of Being in Private Mode

Unread postby access2godzilla » Sat, 17 May 2014, 12:13

Night Wing wrote:I get the mask in the Navigation Bar.

In the nav bar? It's on the row of tabs, and it isn't even movable. <https://i.imgur.com/Z4JAbK0.png>. BTW I can't even reproduce your issue.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23038
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: No Indications of Being in Private Mode

Unread postby Moonchild » Sat, 17 May 2014, 13:24

The permanent "mask" on the right is only present if you have the classic menu enabled. (which would be the case by default in Linux).
I don't have Linux handy right this minute but it should be similar to the windows one:
PB1.png


Otherwise you can see the private browsing status by the color of the Pale Moon button (Purple instead of blue) with a little mask in it.
PB2.png


Regardless, both modes also have (Private Browsing) as a suffix in the title bar.

Note that "permanent" private browsing mode won't show an indicator like mask or color of the button (including starting it with -private). That's by design.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3772
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: No Indications of Being in Private Mode

Unread postby Night Wing » Sat, 17 May 2014, 13:45

Moonchild wrote:The permanent "mask" on the right is only present if you have the classic menu enabled. (which would be the case by default in Linux).


The mask for Windows on the far right on your screenshot does not appear in linux with the Menu Bar displayed. I'll see if I can take a partial screenshot of my linux like you did with your Windows so you can see mine.

The suffix for private browsing does appear in the Title Bar.
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3772
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: No Indications of Being in Private Mode

Unread postby Night Wing » Sat, 17 May 2014, 14:01

Here is a screenshot of my Private Browsing mode showing no Mask at the far right in linux SolydX with the Menu Bar. The suffix (Private Browsing) is in the Title Bar. You'll have to click on the attachment to get a bigger and much clearer picture.
Attachments
PB1366.jpg
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

access2godzilla

Re: No Indications of Being in Private Mode

Unread postby access2godzilla » Sat, 17 May 2014, 14:54

Both the appmenu button and the title are the same as would have been for a normal window (for -private). OP is asking about this mode; as per MC's reply in the linked thread, described behaviour is not a bug.

The mask behaves differently on linux: it remains on the tab bar and integrates with the appmenu button with the menu bar turned off.
@Night wing: the screenshot does not prove the point you raised and without a view of the row of tabs, things remain inconclusive.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3772
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: No Indications of Being in Private Mode

Unread postby Night Wing » Sat, 17 May 2014, 15:26

@A2G

The private browsing mask does appear with a row of tabs in linux SolydX. It's on the far left before the row of tabs and under the word, File, in the Menu Bar. :thumbup:
Attachments
PBM1366.jpg
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23038
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: No Indications of Being in Private Mode

Unread postby Moonchild » Sat, 17 May 2014, 18:04

Night Wing wrote:The mask for Windows on the far right on your screenshot does not appear in linux with the Menu Bar displayed. I'll see if I can take a partial screenshot of my linux like you did with your Windows so you can see mine.

The suffix for private browsing does appear in the Title Bar.


Seems on Linux it's in the tab bar on the left (see a2g's screenshot above)
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3772
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: No Indications of Being in Private Mode

Unread postby Night Wing » Sat, 17 May 2014, 22:14

Moonchild wrote:
Night Wing wrote:The mask for Windows on the far right on your screenshot does not appear in linux with the Menu Bar displayed. I'll see if I can take a partial screenshot of my linux like you did with your Windows so you can see mine.

The suffix for private browsing does appear in the Title Bar.


Seems on Linux it's in the tab bar on the left (see a2g's screenshot above)


That's my screenshot above your comment. ;)
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

cb474

Re: No Indications of Being in Private Mode

Unread postby cb474 » Mon, 19 May 2014, 03:22

Thanks for all the replies and consideration of this issue. Sorry I didn't get back to this sooner, I was traveling yesterday.

I'm running Manjaro Linux (i.e. Arch) and installed Palemoon from the AUR (user) repository.

Strangely, the behavior I was seeing after first installing Palemoon the other day, I'm not seeing now. As I explained in the OP, when I first installed Palemoon there were absolutely no indications that a private window was a private window--regardless of whether the private window was opened from a non-private window or whether Palemoon was launched in private mode with "palemoon -private." No label in the title bar. No mask symbols anywhere. And this was with a clean profile, because this was immediately after I installed Palemoon.

Today (I can't explain why) it's different. The only thing that has happened in the meantime is that I shutdown my system, didn't use it for a day, and restarted it.

Now what I see when I open a private window, with a non-private window already running, is the same as others have noted above. I see the about page stating I have opened a private window (it's no longer loading my homepage instead, as noted in the OP). And I see a mask symbol in the address bar. There is also a paranthetical note in the title bar stating "(Private Browsing)." In addition, if I open a second tab I see a mask symbol at the left side of the label in each tab and each tab is labeled "Private Browsing" (until I load a webpage at which point the logo and label change to that of the webpage). And I when there are at least two tabs open, I see a mask in the tab bar at the left (I suppose I don't see this until I open two tabs, because I have the tab bar hidden with only one tab). Basically it matches the second (Linux) image posted by access2godzilla.

If i open Palemoon from the command line, with "palemoon -private," I get the private browsing about page; the mask symbol in the address bar and on the first tab, but not in the address bar or tab for any subsequent tabs; a non-paranthetical "Private Browsing" label in the title bar, which goes away once I navigate to a webpage; and no mask symbol at the left on the tab bar. And once I have web content loaded, there's no longer any indicaiton that Palemoon is in private browing mode.

So everything seems consistent with how recent versions of Firefox have functioned.

So I honestly can't explain what was going on the other day. I posted my OP right after I had installed Palemoon and configured it a little bit, just to try it out. I guess restarting my system somehow corrected the problem.

I do think, as is dicussed in the thread access2godzilla links to in the second post, that it would be useful even when launched purely in private mode from the command line, to have some ongoing indication that one is in private mode. But I guess Firefox also drops all indications once you load web content, so maybe that's just how it is.

Anyway, thanks again for all the replies to this thread and thanks Moonchild for saving Firefox from itself.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23038
Joined: Sun, 28 Aug 2011, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: [Gremlins] No Indications of Being in Private Mode

Unread postby Moonchild » Mon, 19 May 2014, 09:40

I blame the gremlins ;)

As for permanent private browsing mode not providing an indicator, as said that is by design. It's a concession to people who purposefully set the browser to always be in private browsing mode not needing to be told every...single...time... that yes, they are in PB mode. It was set up that way purposefully, it can never happen on accident, so the indicator is just an annoyance in that case for most people who specifically set it up that way. The one reminder on start-up is enough to verify that it is still operating as-intended. I hope that explains the logic behind it sufficiently?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

cb474

Re: [Gremlins] No Indications of Being in Private Mode

Unread postby cb474 » Tue, 20 May 2014, 07:56

Yes, I guess gremlins are as good an explanation as anything. Once I start using Palemoon more regularly (still need to transfer over all my settings and configurations), I'll have to see if it happens again, but so far so good (no gremlins today either).

I understand that not having an indicator of privacy mode when the browser is set to always launch in privacy mode is by design. But I'm surprised people would find it annoying to have it indicated. I'd much rather have some sort of indication. I guess it just reassures me that I am in fact in privacy mode and everything is working as I intend it. Indeed, Chromium works this way (occasionally I find Chromium useful--since sometimes I just can't figure out what in my NoScript setup is breaking a website). Chromium clearly always indicates that it's in private mode, not just at launch. I like that. Are people really annoyed by a reminder? Did people complain in the past or something? I can live with it how it is, but I don't really understand being annoyed by a persistent private mode indicator.

User avatar
Antonius32
Add-ons Team
Add-ons Team
Posts: 695
Joined: Sun, 25 May 2014, 11:18
Location: Netherlands

Re: [Gremlins] No Indications of Being in Private Mode

Unread postby Antonius32 » Sun, 25 May 2014, 16:19

Hi cb474,

You could add these lines to your userChrome.css file:

Code: Select all

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#main-window:not([privatebrowsingmode]) #appmenu-toolbar-button {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(200,85%,60%), hsl(225,72%,53%) 95%) !important;
    border: 1px solid #000000 !important;
}

#main-window:not([privatebrowsingmode]) #appmenu-toolbar-button:hover:not(:active):not([open]) {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(225,72%,53%), hsl(200,85%,60%) 95%) !important;
    border: 1px solid #000000 !important;
}

#main-window:not([privatebrowsingmode]) #appmenu-toolbar-button:hover:active,
#main-window:not([privatebrowsingmode]) #appmenu-toolbar-button[open] {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(225,72%,53%), hsl(225,72%,53%) 95%) !important;
    border: 1px solid #000000 !important;
}

#appmenu-toolbar-button {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(279,70%,46%), hsl(276,75%,38%) 95%) !important;
    border: 1px solid #000000 !important;
}

#main-window #appmenu-toolbar-button:hover:not(:active):not([open]) {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(276,75%,38%), hsl(279,70%,46%) 95%) !important;
    border: 1px solid #000000 !important;
}

#main-window #appmenu-toolbar-button:hover:active,
#main-window #appmenu-toolbar-button[open] {
    -moz-appearance: none !important;
    color: #FEEDFC !important;
    font-weight: bold !important;
    background: -moz-linear-gradient(hsl(276,75%,38%), hsl(276,75%,38%) 95%) !important;
    border: 1px solid #000000 !important;
}

(The first line is the default opening line. The userChrome file should be in the "chrome" folder within your Pale Moon profile folder. If it doesn't exist, just copy the code into a text file and save it as "userChrome.css" on the location I described.)

This will tell PM4Linux to show a blue appmenu button in normal mode, and a purple appmenu button + the little mask in private mode. Thought this might be a good solution for you..
Image

cb474

Re: [Gremlins] No Indications of Being in Private Mode

Unread postby cb474 » Mon, 26 May 2014, 06:28

Thanks for the idea Antonius32. I created the file and put it in the chrome folder which I found in the indexedDB folder in my default profile folder for Palemoon. That was the only chrome folder I saw. Didn't seem to do anything other than the default behavior I was already getting.

Also, will this only work if I have the menubar disabled and I'm using the menu in the "palemoon" button in the tab bar? I prefer to use the menu bar, so I never see that other menu.

Thanks again.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 6 guests