Installer does not work

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Mercury
Fanatic
Fanatic
Posts: 203
Joined: 2013-11-01, 23:26
Location: Toronto, Canada

Installer does not work

Unread post by Mercury » 2014-04-10, 02:19

Hey,

I just tried using the installer script. I extracted the bz2 file to my desktop, and tried running the sh file from a terminal.

Code: Select all

[127]______@_________:~/Desktop/pminstaller-0.0.5 > ./pminstaller.sh
/usr/bin/sudo
[sudo] password for ______: [sudo] password for ______: /tmp/pminstaller.BVgE8/installer.sh: line 19: yad: command not found
So, I get that I'm missing a tool called "yad", but the instructions mention the "built-in copy of yad" - does that mean yad is supposed to be built-in to my system, or to the installer?

I'm mostly a Windows guy, so I don't know much about the workings of Linux. This is for a netbook running Mint 16.

access2godzilla

Re: Installer does not work

Unread post by access2godzilla » 2014-04-10, 05:22

That shouldn't happen, yad is built into the installer. Some questions:
  • Do you get the password prompt? (It does seem like you're getting it).
  • Is this 32bit or 64bit Mint?
Also, v 0.0.6 has been released now, you might want to check if the problem persists in this version.

EDIT: I tried using the installer on a bunch of distros, including Linux Mint 13 (32bit). I didn't face any problems: http://youtu.be/2yzHBydyzgM
The only one distro I had problems was with Slitaz, and that was not related (absence of bash and sed's unbuffered mode) to the problem you described above.

Mercury
Fanatic
Fanatic
Posts: 203
Joined: 2013-11-01, 23:26
Location: Toronto, Canada

Re: Installer does not work

Unread post by Mercury » 2014-04-11, 03:06

Code: Select all

________@________:~ > cd Desktop/pminstaller-0.0.6
________@________:~/Desktop/pminstaller-0.0.6 > ls
pminstaller.sh  README
________@________:~/Desktop/pminstaller-0.0.6 > ./pminstaller.sh 
/usr/bin/sudo
[sudo] password for ________: [sudo] password for ________: /tmp/pminstaller.I1e2h/installer.sh: line 19: yad: command not found
________@________:~/Desktop/pminstaller-0.0.6 > uname -a
Linux ________ 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
ETA:
Putting my 1337 hacking skills to use:

Code: Select all

________@________:~/Desktop/pminstaller-0.0.6 > mkdir /tmp/pminstaller1
________@________:~/Desktop/pminstaller-0.0.6 > tail -n +28 pminstaller.sh | tar -xJf - -C /tmp/pminstaller1
________@________:~/Desktop/pminstaller-0.0.6 > cd /tmp/pminstaller1
________@________:/tmp/pminstaller1 > ls
bin  installer.sh  tools
________@________:/tmp/pminstaller1 > uname -m
x86_64
________@________:/tmp/pminstaller1 > echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
________@________:/tmp/pminstaller1 > PATH=/tmp/pminstaller1/bin/amd64:/tmp/pminstaller1/tools:$PATH
________@________:/tmp/pminstaller1 > echo $PATH
/tmp/pminstaller1/bin/amd64:/tmp/pminstaller1/tools:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
________@________:/tmp/pminstaller1 > yad --version
0.26.1
________@________:/tmp/pminstaller1 > runasroot yad --version
/usr/bin/sudo
[sudo] password for ________: [sudo] password for ________: sudo: yad: command not found
So the problem seems to be that yad is not found when invoked with runasroot.

access2godzilla

Re: Installer does not work

Unread post by access2godzilla » 2014-04-11, 17:30

The previous versions of the installer had some certain bugs which prevented this as well as caused some other problems. So I deleted the previous versions (no one should be using them) and uploaded v0.1, which should fix the above described issue.

Mercury
Fanatic
Fanatic
Posts: 203
Joined: 2013-11-01, 23:26
Location: Toronto, Canada

Re: Installer does not work

Unread post by Mercury » 2014-04-12, 14:57

The newest installer version (0.1) works on my system!

Locked