Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
sotel
Newbie
Newbie
Posts: 3
Joined: 2020-12-30, 20:00
Location: Bielefeld, Germany
Contact:

Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by sotel » 2020-12-30, 20:35

Since begin of december the Debian package system (apt-get / dpkg) installs the Palemoon package with the version 28.17.0-1 again and again. And I can't find my mistake.
Could you please help me a little bit?

This is what the dist-upgrade process shows:
Preparing to unpack .../palemoon_28.17.0-1_amd64.deb ...
Unpacking palemoon (28.17.0-1) over (28.17.0-1) ...

Whats going wrong there?

--
Jörg Schiermeier
Bielefeld/Germany



Some more infos about the machine, linux and more:

My Debian is:

Code: Select all

joerg@Pythagoras ~/Downloads % uname -a
Linux Pythagoras 5.9.0-5-amd64 #1 SMP Debian 5.9.15-1 (2020-12-17) x86_64 GNU/Linux
My sources.list.d list file for palemoon:

Code: Select all

### -----------------------------------------------------------------
### --- Palemoon - fork of Firefox
### -----------------------------------------------------------------
### --- created: 2020-04-25
### --- changed: 2020-09-06
### -----------------------------------------------------------------
### --- Public key:
### --- https://download.opensuse.org/repositories/home:stevenpusser/Debian_Testing/Release.key
### -----------------------------------------------------------------

deb http://download.opensuse.org/repositories/home:/stevenpusser/Debian_Testing/ /

### -----------------------------------------------------------------
### --- -eof-
### -----------------------------------------------------------------
dpkg -s palemoon tells me:

Code: Select all

Package: palemoon
Status: install ok installed
Priority: optional
Section: web
Installed-Size: 112577
Maintainer: Steven Pusser <stevep@mxlinux.org>
Architecture: amd64
Version: 28.17.0-1
Replaces: palemoon-nonsse2
Provides: gnome-www-browser, www-browser, x-www-browser
Depends: libavcodec54 | libavcodec-extra54 | libavcodec55 | libavcodec-extra55 | libavcodec56 | libavcodec-extra56 | libavcodec57 | libavcodec-extra57 | libavcodec58 | libavcodec-extra58 | libavcodec-ffmpeg56 | libavcodec-ffmpeg-extra56, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.30), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.2.1), libgcc-s1 (>= 4.0), libgdk-pixbuf-2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.30.0), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libstdc++6 (>= 9), libx11-6, libx11-xcb1 (>= 2:1.6.12), libxcb-shm0, libxcb1, libxext6, libxrender1, libxt6
Conflicts: palemoon-nonsse2
Description: Firefox-based, efficient and easy to use web browser
 Pale Moon offers selected features and optimizations to maximize
 the browser's speed, stability and user experience, while maintaining
 compatibility with the thousands of Firefox extensions you have come
 to love and rely on.
 .
 Pale Moon requires a processor that supports the SSE2 instruction set.
 Run "/proc/cpuinfo" in a terminal, and look for sse2 in the flags to ensure
 that your processor supports it.
Homepage: http://www.palemoon.org/
Original-Maintainer: Marian Kadanka <marian.kadanka@openmailbox.org>
apt-cache policy palemoon said:

Code: Select all

palemoon:
  Installed: 28.17.0-1
  Candidate: 28.17.0-1
  Version table:
 *** 28.17.0-1 500
        500 http://download.opensuse.org/repositories/home:/stevenpusser/Debian_Testing  Packages
        100 /var/lib/dpkg/status

vannilla
Board Warrior
Board Warrior
Posts: 1372
Joined: 2018-05-05, 13:29

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by vannilla » 2020-12-30, 23:36

It might be a problem with APT itself, which is notoriously finnicky.
Try uninstalling and reinstalling the package.

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1320
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by Isengrim » 2020-12-30, 23:45

Steve Pusser manages the OBS repository for Pale Moon, so this would be a question for him. I don't think it has anything specifically to do with Aptitude.
a.k.a. Ascrod
Linux Mint 19.3 Cinnamon (64-bit), Debian Bullseye (64-bit), Windows 7 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
billw22
New to the forum
New to the forum
Posts: 1
Joined: 2020-12-19, 12:59
Contact:

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by billw22 » 2020-12-31, 09:20

It might be a problem with APT itself, which is notoriously finnicky.
Try uninstalling and reinstalling the package.
Greetings
its seems to me that I'm facing the similar problem
is there any guide on how to solve that?
I'm a little new and having hard time to figure out it myself

vannilla
Board Warrior
Board Warrior
Posts: 1372
Joined: 2018-05-05, 13:29

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by vannilla » 2020-12-31, 12:19

billw22 wrote:
2020-12-31, 09:20
Greetings
its seems to me that I'm facing the similar problem
is there any guide on how to solve that?
I'm a little new and having hard time to figure out it myself
The following method is quite drastic, so please backup your profile first.
Run these commands:

Code: Select all

apt purge palemoon
apt update
apt install palemoon

sotel
Newbie
Newbie
Posts: 3
Joined: 2020-12-30, 20:00
Location: Bielefeld, Germany
Contact:

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by sotel » 2020-12-31, 14:17

vannilla wrote:
2020-12-30, 23:36
Try uninstalling and reinstalling the package.
This was my first idea:

Result:
Is not working. Not a solution.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 695
Joined: 2015-08-01, 18:33
Location: California

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by stevepusser » 2021-01-01, 01:26

Apparently, since new versions of PM's build-depends get rolled into Debian testing and Sid constantly, the OBS rebuilds a package automatically when that happens, and apt apparently can check the build date of a deb and call it an update, even when the version is the same.

Check the dates of the finished debs here on a stable release: https://download.opensuse.org/repositor ... _10/amd64/

and on testing: https://download.opensuse.org/repositor ... _10/amd64/

You can think of the updates as a compatiblity feature, since you know it's built against the latest updated libraries. Or you can disable the OBS repo until the next PM release, or pin the palemoon package until that time. Maybe there's some way to get apt to just go by the version and not the date, but I really don't have time to grok the dpkg, apt-get, and apt man pages right now...

sotel
Newbie
Newbie
Posts: 3
Joined: 2020-12-30, 20:00
Location: Bielefeld, Germany
Contact:

Re: Debians apt-get wants to install Palemoons v28.17.0-1 package again and again

Post by sotel » 2021-01-02, 23:59

Hello Steve!

I will pin this version.
So: This solution works for me.

Thanks for your answer!
Have a nice and funny new year!

--
Jörg Schiermeier
Bielefeld/Germany

Post Reply