28.17.0 not detected with updater

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
markd89
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2018-09-12, 00:32

28.17.0 not detected with updater

Post by markd89 » 2020-12-18, 17:56

Hi,

I'm running 28.16.0. When I select Help, Check for Updates, no update is found.

I'm running on Debian and this usually works perfectly..

Mark

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2353
Joined: 2012-06-28, 01:20

Re: 28.17.0 not detected with updater

Post by ron_1 » 2020-12-18, 18:38

I assume you're using Steve Pusser's builds (are you?). He hasn't updated them yet to 28.17.

User avatar
Pentium4User
Astronaut
Astronaut
Posts: 570
Joined: 2019-04-24, 09:38

Re: 28.17.0 not detected with updater

Post by Pentium4User » 2020-12-18, 18:40

Steve's builds do not contain the internal updater, so there's no "Check for Updates" in the Help menu.
The reason is that PM is being updated via apt, so there is no need for an internal updater.
Powerline adapters (dLAN) hardly interfere shortwave radio, so stop using them.

Yes, I still use a 64 bit capable Pentium 4 670 processor with Pale Moon.

User avatar
markd89
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2018-09-12, 00:32

Re: 28.17.0 not detected with updater

Post by markd89 » 2020-12-18, 18:49

Pentium4User wrote:
2020-12-18, 18:40
Steve's builds do not contain the internal updater, so there's no "Check for Updates" in the Help menu.
The reason is that PM is being updated via apt, so there is no need for an internal updater.
That's a good question. I've been using PM for so long, I don't remember. I'm pretty sure I downloaded a binary directly from here. The auto-updater has always worked before. It does prompt when there's a new update available. I can also do Help|Check for Updates and that has worked also.

I just tried another machine and got the same behavior. This probably is not surprising since it was set up the same way.

nostril
Apollo supporter
Apollo supporter
Posts: 33
Joined: 2015-01-30, 14:40

Re: 28.17.0 not detected with updater

Post by nostril » 2020-12-18, 18:55

Happens with the standalone tarball too.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 8538
Joined: 2012-10-09, 19:37
Location: Skaro

Re: 28.17.0 not detected with updater

Post by New Tobin Paradigm » 2020-12-18, 19:17

Try now.
return NS_OK;
Image

User avatar
markd89
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2018-09-12, 00:32

Re: 28.17.0 not detected with updater

Post by markd89 » 2020-12-18, 19:48

Confirmed fixed, thanks!!

Post Reply