PPA Steve Pusser

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
Ingrid23
Newbie
Newbie
Posts: 3
Joined: 2020-11-19, 22:16

PPA Steve Pusser

Post by Ingrid23 » 2020-11-20, 14:25

Hi, my Englisch is not perfect but I hope you can read this.

I use Linux Mint 20 Ulyana, and I have now Pale Moon version 28.15.0.

I read on Steve's Twitter account that everybody must update there Pale Moon to version 28.8.1 because there is an exploit in older versions. Some time back I have installed Pale Moon from the Pale Moon website, and added the PPA. Some day's back I got an update from my Update Manager, so normaly I always get the newer versions.

Now I get a Failed notice from the repro > https://www.mupload.nl/img/37lo2d6wh4jv.png

Could anybody forward this to Steve so he can update his repro?

I don't have Twitter, and don't now how to reach him.

Many thanks

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1296
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: PPA Steve Pusser

Post by Isengrim » 2020-11-20, 17:31

If Pale Moon has successfully updated before using the PPA, then it could just be a temporary network issue. How long have you been getting this error?
a.k.a. Ascrod
Linux Mint 19.3 Cinnamon (64-bit), Debian Bullseye (64-bit), Windows 7 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
Ingrid23
Newbie
Newbie
Posts: 3
Joined: 2020-11-19, 22:16

Re: PPA Steve Pusser

Post by Ingrid23 » 2020-11-20, 17:39

Isengrim wrote:
2020-11-20, 17:31
If Pale Moon has successfully updated before using the PPA, then it could just be a temporary network issue. How long have you been getting this error?
Hi, some mounths back I have added the PPA, and normaly I always get the last version of the browser. I have this Failed error now I think for a week. (I don't check my Update manager always, I mean I don't always see the progress bar)

I did check it 1 minute ago and it's still the same. There are no update's at all, and so also no new version.
Normal I always get new versions of Pale Moon except this time I don't get the last version.
Futher I don't change anything if things are working so this is not on my end.

I'm sure the problem is on steve's end. I did send him yesterday a PM, but I don't get a PM back.

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2319
Joined: 2012-06-28, 01:20

Re: PPA Steve Pusser

Post by ron_1 » 2020-11-20, 18:27

There are some things in your original post that don't make any sense. You state you have Pale Moon 28.15.0; that is the current up-to-date version. Any message about 25.8.1 needing updating is a moot point. Unless there is a miscommunication somewhere?

User avatar
Ingrid23
Newbie
Newbie
Posts: 3
Joined: 2020-11-19, 22:16

Re: PPA Steve Pusser

Post by Ingrid23 » 2020-11-20, 18:46

ron_1 wrote:
2020-11-20, 18:27
There are some things in your original post that don't make any sense. You state you have Pale Moon 28.15.0; that is the current up-to-date version. Any message about 25.8.1 needing updating is a moot point. Unless there is a miscommunication somewhere?
Hi sorry but I don't unstand, Steve's Twitter page schow me the last version is 28.8.1.
I have version 28.15.0, so this means I don't have the latest version.

For the rest there is that Failed message in my Update Manager.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28495
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: PPA Steve Pusser

Post by Moonchild » 2020-11-20, 18:59

Um... 15 > 8 :)
Steve might not have tweeted about the later releases though.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2319
Joined: 2012-06-28, 01:20

Re: PPA Steve Pusser

Post by ron_1 » 2020-11-20, 23:52

It would be better to follow his release thread here on the forum, than his tweet account which apparently doesn't get updated as often.

https://forum.palemoon.org/viewtopic.php?f=37&t=11466&start=460

bgstack15
Moon lover
Moon lover
Posts: 96
Joined: 2018-01-22, 23:04

Re: PPA Steve Pusser

Post by bgstack15 » 2020-11-21, 01:33

Unfortunately the numbering convention used by software projects, where you see "28.15.0" is not decimal numbers. That is, Pale Moon "28.15" is not less than "28.2" the way mathematics would indicate. The dots are used to separate integer numbers. So "28.10" follows "28.9" and so on. It is basically, "version 28, subversion 10" and "version 28, subversion 9".

Separately, I am pretty sure Steve Pusser's work for Pale Moon exists on the Open Build Service (OBS), which is technically different from a PPA. A PPA is a package repository on the Ubuntu infrastructure and integrates nicely within that distribution. The OBS provides package repositories, but in a different backend architecture that probably doesn't actually matter to most users.

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 324
Joined: 2017-04-20, 21:25
Contact:

Re: PPA Steve Pusser

Post by Lunokhod » 2020-11-21, 19:10

The address mentioned in your error message as unreachable due to a network issue could be accessed in my browser just now:
http://download.opensuse.org/repositori ... /InRelease
And the repository seems to contain the latest version:
http://download.opensuse.org/repositori ... ntu_20.04/
But there can be temporary network issues, or perhaps you might have some local problem preventing Synaptic connecting to the net.
Wait, it's all Ohio? Always has been...

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 690
Joined: 2015-08-01, 18:33
Location: California

Re: PPA Steve Pusser

Post by stevepusser » 2020-11-24, 20:21

Apparently the OBS was having trouble at that time, but it's now back up.

Post Reply